Ubuntu

Ubuntu fails to properly boot on Macbook Air 2013 6,1 & 6,2

Reported by Jeff Marcom on 2013-07-03
110
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned
Raring
High
Unassigned
Saucy
High
Unassigned

Bug Description

Ubuntu fails to properly boot on Macbook Air 2013 6,1

Ubuntu fails to boot the 13.10 live image from usb without specifying acpi-off as a boot parameter.

After installation is complete the boot process hangs at a purple screen. Booting into recovery mode shows that the process stops at the following:

smpboot: Booting Node 0, #1

I've tried 12.04.2, 13.04, and 13.10. I've also tried booting with kernel ver 3.9.8-030908-generic and the result is the same.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.10.0-2-generic 3.10.0-2.9
ProcVersionSignature: Ubuntu 3.10.0-2.9-generic 3.10.0
Uname: Linux 3.10.0-2-generic x86_64
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 2885 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 2885 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CasperVersion: 1.335
Date: Wed Jul 3 15:31:42 2013
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64+mac (20130703)
MachineType: Apple Inc. MacBookAir6,1
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: initrd=/casper/initrd.lz file=/cdrom/preseed/username.seed boot=casper quiet splash acpi=off BOOT_IMAGE=/casper/vmlinuz
RelatedPackageVersions:
 linux-restricted-modules-3.10.0-2-generic N/A
 linux-backports-modules-3.10.0-2-generic N/A
 linux-firmware 1.110
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/24/2013
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA61.88Z.0099.B00.1305241529
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-35C1E88140C3E6CF
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir6,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-35C1E88140C3E6CF
dmi.modalias: dmi:bvnAppleInc.:bvrMBA61.88Z.0099.B00.1305241529:bd05/24/2013:svnAppleInc.:pnMacBookAir6,1:pvr1.0:rvnAppleInc.:rnMac-35C1E88140C3E6CF:rvrMacBookAir6,1:cvnAppleInc.:ct10:cvrMac-35C1E88140C3E6CF:
dmi.product.name: MacBookAir6,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Jeff Marcom (jeffmarcom) wrote :
Jeff Marcom (jeffmarcom) wrote :

Hardware data was collected via live image boot.

tags: added: precise quantal raring
Changed in linux (Ubuntu Precise):
importance: Undecided → High
Changed in linux (Ubuntu Quantal):
importance: Undecided → High
Changed in linux (Ubuntu Raring):
importance: Undecided → High
Changed in linux (Ubuntu Saucy):
importance: Undecided → High

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
status: New → Confirmed
Changed in linux (Ubuntu Raring):
status: New → Confirmed

Can you follow the "Boot options" instructions on the following wiki to enable additional output on boot:

https://wiki.ubuntu.com/DebuggingKernelBoot

As mentioned on the wiki, it would be great if you can attach a log file which may have captured any messages you see. If you are unable to capture a log file, a digital photo will work just as well. As a last resort you can even copy messages down by hand.

tags: added: kernel-da-key

I have attached a picture of the boot failure when I try to boot without doing anything special.

I forgot to mention that I'm trying to boot the 64-bit Mac (AMD64) desktop image of 13.10 (Saucy Salamander)

Ma Jun (maclin.jun) wrote :

I try 13.04 with the same failure. Then I change the boot parameters as : ro text nomodeset acpi=off and got the kernel panic.

Joseph Salisbury (jsalisbury) wrote :

The 3.11-rc1 kernel is now available. Can you test this kernel and post back if it exhibits this bug?
 http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc1-saucy/

The issue is that I'm so far not able to boot from 13.10 after the installation (the image on the usb key boots most of the time with acpi=0).
I'm stuck with the same error as reported by Ma Jun in #7
I'm going to try chroot to install 3.11-rc1 from the usbkey.

If you have a simpler way to get a bootable version of ubuntu after install let me know!

3.11-rc1 is not better (installed on a dailly 13.10 chrooted) :(
With acpi=off, I still get thesame error as reported by Ma Jun in #7
Without acpi=off, the boot get stuck at "smpboot: Booting Node 0, Processors #1" (No error message but it is stuck).

Picture of the boot faillure on 3.11-rc1 without acpi=off.

Did someone already report this bug upstream?

Summary:
Kernels 3.9.11, 3.10.2 ang 3.11-rc2 *vanila* get stuck at "smpboot: Booting Node 0, Processors #1"
All kernels were compiled with make oldconfig on a ubuntu 13.04 except for the 3.11-rc2 for which I have tried the to add "CONFIG_X86_INTEL_LPSS=y" on top of make oldconfig.

With acpi=off, it crashes most of the time (read "always" this evening...) in clockevents_config as reported in comment #7.
Sometimes the trace includes "smp_sanity_check" between native_smp_prepare_cpus and APIC_init_uniprocessor.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

Changed in linux (Ubuntu Precise):
status: Confirmed → Triaged
Changed in linux (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in linux (Ubuntu Raring):
status: Confirmed → Triaged
Changed in linux (Ubuntu Saucy):
status: Confirmed → Triaged
tags: added: kernel-bug-exits-upstream

Reported on <email address hidden> .

Orm-Ancalagon (sam-attwell) wrote :

Hi there,

I have a MacBook Air 6,2 that fails to boot normally.
Intel Core i7-4650U 1.7Ghz
8GB RAM
128GB SSD

Boot is halted similarly at: smpboot Booting Node 0, Processorts #1 - see screenshot attached.

Appending nosmp allows successful boot.

Orm-Ancalagon (sam-attwell) wrote :

Additionally here is dmesg with nosmp.

Orm-Ancalagon (sam-attwell) wrote :

And here's kern.log

Orm-Ancalagon (sam-attwell) wrote :

Lastly the output from fwts.

Ben Whitten (benwhitten) on 2013-08-09
tags: added: kernel-bug-reported-upstream
summary: - Ubuntu fails to properly boot on Macbook Air 2013 6,1
+ Ubuntu fails to properly boot on Macbook Air 2013 6,1 & 6,2
Tommy_CZ (t-kijas) wrote :

Ok here is my experience with Ubuntu and Macbook Air 6,2.:

Booting live USB:
EFI: 12.04.2 -> without problems
EFI: 13.04 -> without problems
amd64+mac: 12.04.2 -> cannot boot nor recognise Ubuntu USB installer
amd64+mac: 13.04 -> cannot boot nor recognise -||-

with special patch mac_setup.sh from "howto install ubuntu on macbookAir 4,2" (I can provide details) -> booting without using efi is OK with 12.04.2 and 13.04, no difference if "+mac" version or not. (but keep in mind this bypass and do not use EFI standard way)

Installation from live USB:
12.04.2 -> impossible (freezes when installing grub -> reboot is needed -> installation is not sucsessfull)
13.04 -> installation works

Booting installed Ubuntu:
12.04.2 -> impossible, because bug in installer (ubiquity?)
13.04 - without acpi=off option in grub -> freeze when booting as aforesaid
13.04 - with acpi=off option -> freeze when booting as aforesaid
13.04 - with nosmp option -> freeze while booting with initramfs shell (saying something about it could not find SSD with UUID)
13.04 - with nosmp option + with change of root=/dev/sdaX -> first boot usualy is without problems
                                                                                                              -> next boots hangs with SAME settings (only updated but SAME kernel) at "error: sparse file not allowed" (not serious nor related bug) or "Loading initial ramdisk" screen (depending on whether you installed efi or no-efi way).

Usage of vanilla - installed Ubuntu:
13.04 - with nosmp option + with change of root=/dev/sdaX -> strange color gamut (16bit depth?) + non working wireless.
-> suspend-to-RAM works without problems.

Wireless ( bcm4360 / 43a0 ):
13.04 - with nosmp option + with change of root=/dev/sdaX -> installation of bcmwl-kernel-source from proposed to saucy results in: A) wireless works and can see SSID of networks (2,4GHz + 5 GHz)
B) cannot keep connection for more than 3 or 4 seconds when is connected to wireless networks with wpa-psk or wpa 2.
C) wireless networks without security are OK.

I get the same even if I haven't tested all these options.

The priority is to solve this bug : https://bugzilla.kernel.org/show_bug.cgi?id=60635
Fell free to add any usefull info in the bugreport.

Orm-Ancalagon (sam-attwell) wrote :

There are several issues with the MacBook Air 6,2. Xavier is correct in that the SMP bug prevents boot in any way and is the concern of this bug report.

There is a separate issue with ata command timeouts that prevents boot some of the time on 13.04: https://bugzilla.kernel.org/show_bug.cgi?id=60731

Orm-Ancalagon (sam-attwell) wrote :

I should add that my system is currently stable running 3.11.0-rc4 with kernel parameters nosmp and libata.force=noncq added.

Anibal Avelar (aavelar) wrote :

Orm,
How you can run the kernel 3.11.0?

I could run the version 3.8 in 13.04 with the options nosmp libata.force=noncq
but I can't run with the kernel 3.11.0
I always get a kernel panic error.

I'm using Macbook Air 13" 6.2

Orm-Ancalagon (sam-attwell) wrote :

Hi Anibal,

I downloaded Kernel 3.11.0 from Linus' tree. I copied .config from kernel 3.8 (i.e. a configuration that let the Mac boot) to the directory with the new kernel makefiles and compiled from source.

With 3.11.0-rc5 I still have to append nosmp and libata.force=noncq but it's stable thereafter.

ok but you qre using only one core. That's not a decent solution.

Orm-Ancalagon (sam-attwell) wrote :

Xavier you are correct, though I did not suggest kernel boot parameters are a solution, this is a workaround only and will inevitably reduce performance.

Miek Gieben (miek) wrote :

Does anybody know of a kernel version that *does* boot without 'nosmp' ?

Sean V Kelley (t7v3-sean-lzh7) wrote :

As a point of reference:

Fedora 19's kernel boots fine out of the box and it is based on 3.10. I have Fedora 19 running on my Mac Book Air 6,2 and the primary issue is not booting but rather suspend resume with the back light.

See this blog

http://mattoncloud.org/2013/07/18/fedora-19-on-a-macbook-air-2013-model/

Sean V Kelley (t7v3-sean-lzh7) wrote :

On Fedora 19, using their current kernel on my MacBook Air 6,2:

seanvk@prairie ~$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.10.7-200.fc19.x86_64 root=UUID=20b0ee04-7a6e-4e24-8fe5-55185347f43d ro rootflags=subvol=root rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet libata.force=1:noncg LANG=en_US.UTF-8

seanvk@prairie ~$ uname -a -m
Linux prairie 3.10.7-200.fc19.x86_64 #1 SMP Thu Aug 15 23:19:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Obviously, there are a number of patches applied, you can get a list and the source of the patches via rpm sources for
from the fedora-project's repo. kernel-3.10.7-200.fc19.src.rpm

We ahve to be more precise :
**We see this bug on 11" i5 machines**.
It's now a bit confusing on the kernel bugzilla because we are talking about different hardware config.

Sean V Kelley : Do you have an 11" i5 ? (if it is the case then I puzzled). If you have a 13" or/and i7, have a look at comment #1 of this thread and try to figure out how much your hardware if different. Do you boot using EFI or the emulated bios method?

Imre Kaloz (kaloz) wrote :

I have a 13" i7, and it fails to boot with anything newer than 3.9, regardless of nosmp. I'm trying to bisect the change that causes it. What I was wondering is if those who are running 3.11-rc have the apple firmware updates applied or not?

Riaan (riaan-7) wrote :

Hello all, just some info to add, I too have a 13" Airbook 6.2 i5

Basically I can use Ubuntu 13.04 and most things work, like networking, mouse pad with 3 fingers, 3D affects etc.

Things that do not work: Wifi, Sound, SMP

Linux 3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

In /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="noapic nosmp reboot=\"bios\" acpi_osi=\"Linux\" libata.force=\"1:noncq\""
GRUB_DISABLE_LINUX_UUID=true

I did also try newer kernels, 3.10, 3.11 but they do not boot.

I have not applied any firmware updates yet.

The hardware is brand new so I anticipated some problems running Ubuntu, but it's lovely running Ubuntu on a Airbook, even in a half broken state.

Some good tips can be found here: https://bbs.archlinux.org/viewtopic.php?pid=1309137

Miek Gieben (miek) wrote :

Difference between MBA 6,1 and 6,2 are smallish, the CPU is the most important difference:

MacbookAir 6,1: http://www.everymac.com/systems/apple/macbook-air/specs/macbook-air-core-i5-1.3-11-mid-2013-specs.html
MacbookAir 6,2: http://www.everymac.com/systems/apple/macbook-air/specs/macbook-air-core-i7-1.7-11-mid-2013-specs.html

(If I'm not mistaken)

We should try to keep this bug report as clean as possible:

On mac books air 11" i5 and without any specific boot option, the boot process get stuck at:
"smpboot: Booting Node 0, Processors #1"
That *one* bug.

Do you see the *same* bug ( "it does not boot" is to vague. it recovery mode you can check if "it gets stuck at smpboot: Booting Node 0, Processors #1") on 13" and/or on mac book air equiped with i7?

Miek Gieben (miek) wrote :

I converted my Ubuntu install to EFI boot and now everything works (*), https://help.ubuntu.com/community/UEFI

(*) my function keys and touchpad are still not behaving.

Miek Gieben : Ok I have a dual boot mac OSX / ubuntu in legacy mode using rEFInd. Should I try to convert it to EFI like this :
https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_EFI_or_Legacy_mode or should a reset the mac back to factory settings and install ubuntu from scratch? I would like to keep the dual boot.

I have no experience with EFI.
Does the mac use secure boot?
It is possible/easy to install a new kernel without braking the EFI setup each time?

I'm trying to figure out if the EFI mode has drawbacks compare to the legacy mode.
If there is no significant drawback then https://bugzilla.kernel.org/show_bug.cgi?id=60635 should be clsoed as "wontfix" or something like that.
What do you think?

Sean V Kelley (t7v3-sean-lzh7) wrote :

Hi Xavier,

My recommendation is to resolve the kernel.org bug as won't fix and update the Ubuntu MacBook Air wiki on https://help.ubuntu.com/community/MacBookAir with details linking to use of UEFI install.

The Mac does not require secure boot. There is no loss of functionality. You will need to use rEFInd, and follow the instructions for EFI boot. Since you are already dual booting you should be able to boot into MacOS, this time reinstall rEFInd for EFI booting. Make your EFI based Ubuntu USB image and reinstall Ubuntu.

Sean

Hi Sean,

Ok! thanks at lot.
Apple has zero interest in fixing the legacy BIOS. Therefore I assume they will never do it. It's very unlikely that this is a bug in the kernel. It's even more unlikely that this problem exists with another hardware. I have updated the https://bugzilla.kernel.org/show_bug.cgi?id=60635 accordingly.

I won't have time test this week end but I'm going to do it asap :)
It would be great if someone with some EFI boot experience could update the wiki.

Xavier

Ok I have used boot-repair to convert it to EFI and reinstall rEFInd and I see 4 CPUs with a 3.9.11. Great!

For an unkown reason, the boot gets stuck at "Loading initial ramdisk" with a 3.11 rc but it must be something else (maybe a boot repair got confused...I'm going to check my grub config (I suppose grub-EFI config files are the same as the grug "legacy" ones).

Is it supposed to work automatically when a new kernel is apt-get installed or should we do some manual magic in /boot/efi or whatever else???
I'm asking because I only able to boot one kernel. All the other kernels are stuck at "Loading initial ramdisk".
My Boot Info Script : http://paste.ubuntu.com/6030209/

I know it's another bug but I want to make sure that it really works well in EFI mode before saying that I don't care about the failure in legacy bios mode.

Imre Kaloz (kaloz) wrote :

I've migrated to UEFI boot, too -- simply install the ext4 driver from the refind package, and it will "Just Work (tm)". As Xavier noted, 3.9 is still the last kernel that boots for me - I've bisected the issue I had with legacy booting, will check if the same commit causes the above issue with newer kernels, too.

@Imre Kaloz : ok so you think it's a real issue in the kernel (and not an issue in my grub config)?
I'm going to check it by installing a 3.8. If it's boots then yes it's an issue in the kernel.

I would be happy to help to debug this potential kernel issue but what can I do as the boot process get stuck as early as "Loading initial ramdisk"?
Is there any boot options related to UEFI we should try? (sorry I'm a fresh man when it comes to UEFI related issues).

Imre Kaloz (kaloz) wrote :

I'm booting both 3.8 and 3.9 via EFI stub from rEFInd, without GRUB. I'm also fresh to the EFI world - my guess is that the kernel panics before we get output on the framebuffer, hence we don't see anything useful.

ok I'm also booting 3.8 and 3.9 without issue using rEFIng + grub-EFI.
3.10 and 3.11 rc get stuck at "Loading initial ramdisk"
@kaloz : Tell us if you have a patch to be tested.

From http://kernel.ubuntu.com/~kernel-ppa/mainline/ :
3.9.11 is Ok.
3.10-rc1 is not.
I don't have a lot of time this week to try to bisect that.

Could someone confirm this finding and figure out where the pb could come from?
It looks like we have a real kernel bug here. However, I ahve no idea how to report it in a usefull way.
Do you know how to make-kpkg compile a kernel with pr_debug enable??

According to http://phoronix.com/forums/showthread.php?83754-Linux-Can-Work-On-The-2013-MacBook-Air/page2
3.11.0-rc5 and 3.10 boot on a mac book air 13" (i7 ?)

Ok it's not the same as the 11" i5 but still...could it be that there is a bug somewhere in the ubuntu boot chain of 13.10 alpha and not in the kernel?? firmware incompatibility, modules compiled with on version of gcc and whatever else with another or I don't know what.

Did you try 3.1x on fedora, archlinux or whatever?
Did you try to boot a vanilla 3.11-rc7 wiht a minimal .config ? (I'm going to try that asap).

Before starting a long biscet process between 3.9.11 (ok) and 3.10-rc1 (no boot) I would like ot be sure it's a bug in the kernel (and not in grub EFI or whatever else I'm not familiar with).

Imre Kaloz (kaloz) wrote :

I have 3.11-rc7 up and running -- I'll upload packages later today or tomorrow, and probably describe the whole install process, too. I hope I'll get the internal speakers working as well by then.

Ho great! I'm eager to know where the bug was.

Miek Gieben (miek) wrote :

For some reason the ubuntu ppa kernel package hung for me too, I just built my own kernel from a pristine linus git tree. (Make a .deb & installed that). Now running 3.11-rc6 with a custom patch for touchpad and keyboard

I did the same with the current vanilla git (3.11-rc7) but it is still stuck at "loadig initial ramdisk".
I did a make odlconfig. could be that there is on option missing somewhere and/or my EFI install is buggy.
Imre Kaloz is going to tell us what's going on :)

Imre Kaloz (kaloz) wrote :

Patch released and submitted upstream: http://marc.info/?l=linux-acpi&m=137811792007887&w=2

tags: added: patch

Great! I'm going to test that asap.
With this patch, is it suppose to boot without extra option? or do we still need acpi=off or whatever else?

Imre Kaloz (kaloz) wrote :

Nope, ACPI works flawlessly. You still need to pass libata.force=noncq as that is a separate issue.

It works. Thanks.
This patch should find its way in 3.11.X or at least in the ubuntu kernel before 13.10 release.

To sum up for newcomers
The patch of #54 allows to boot in EFI mode without any special grub option and it just works.
If you boot in legac bios mode, you still need the "nosmp" option to boot.

I'm not quite sure about the simplest way to install (k)ubuntu direclty in EFI mode.
It would be nice if someone could update the wiki to explain that.

Imre Kaloz (kaloz) wrote :

The patch will be part of 3.12, and will find it's way to stable kernels as well. Ubuntu maintainers should take care of it being merged as soon as possible.

I'll resize my partitions so will do a factory reset and write up a howto about the whole process - just waiting for further info for fixing up audio. Legacy bios mode has a few other issues as well, it should be avoided. EFI booting still needs "libata.force=noncq" for now to avoid random pauses.

Do we have an open kernel bug on the audio issue?

Imre Kaloz (kaloz) wrote :
Changed in linux (Ubuntu Saucy):
status: Triaged → Fix Committed

Set to "Fix Committed" according to http://marc.info/?l=linux-kernel&m=137811791207884&w=2 but I'm not sure if it is correct : we have patch upstream to be committed in 3.12.
However, I not quite sure about the process to have this patch applied in 3.11.X Stable and in the ubuntu default kernel for 13.10.

Imre Kaloz (kaloz) wrote :

Erm, "Fix Commited" should be set when it hit an ubuntu kernel IIRC. If you recheck that post, it clearly says "Cc: <email address hidden> # 3.10+" so it will become part of those series -- in the meantime, Ubuntu should pick it up, specially as this can affect other boards as well, not just the MBA 6,X.

Stefan Bader (smb) on 2013-09-09
Changed in linux (Ubuntu Saucy):
status: Fix Committed → Triaged
Andy Whitcroft (apw) wrote :

If this is properly coming via stable we should expect to get these fixes via stable before release. That said I do not see this fix in Linus' tree as yet.

It looks like it will be too late to get in 13.10 :(

Maybe we should setup a wiki but let me ask a side question here:
How do you get the wifi up and running on a 3.12-rc1??
I have tried to install bcmwl-kernel-source and/or to follow the instructions of http://uli-heller.github.io/blog/2013/06/24/macbook-air/
Whatever I do, I see my wifi network but it does not connect (wpa/wpa2 personnal).
Any ideas?

My wifi router was configured in b+g+n mode.
It looks like the broadcom driver does not like the n mode (or my router does not fully "n" compliant).
Anyway, it works in b+g mode. I haven't tried yet in a+n mode.

Is the "n" mode (much faster) supposed to be supported by the broadcom driver?

Where is the best place to collect all our knowledge about "installing ubuntu on a macbook air 2013"?

Andy Whitcroft (apw) wrote :

Ok this fix seems to have hit v3.11.2 and is now applied to and uploaded in saucy. @kaloz indicates it can be closed there.

Changed in linux (Ubuntu Saucy):
status: Triaged → Fix Released

Yes indeed : kubuntu saucy is now installable without any extra option.
All the other issues (sound and touchpad) are solved in 3.12-rc3 except the libata.force=noncq story.
Thanks.

HP (ejcspii) wrote :

Hi, is there a reasonably step-by-step description of how to install 13.10 on the MBA 2013 without messing up the existing OS X installation? It is very confusing to try to find the best practices among possibly outdated pieces of information. Is rEFInd the recommended way, or can you get along without it? Can I just ask the current 13.10 Mac install image to install the system? Is it going to mess up the boot sequence? Any pointers appreciated.

Marc Thomas (jazzyflute) wrote :

HP,

Check out this link. I used it as a reference to get myself up and running.

http://ubuntuforums.org/showthread.php?t=2156747&page=2

I didn't need to go through all the steps there though, mine were much more condensed. Here is what I did.

1.) Using Mac OS Disk Utility, Partition hard drive to desired size.
2.) Using a bootable thumbdrive with Ubuntu installed, boot from drive and install like normal.
3.) After installation is complete, reboot into Mac OS, install refind.
4.) Reboot, select /efi/grubx64.efi (First Option)
5.) Grub will appear, select Ubuntu
6.) Enjoy.

spezimass (spezimass) wrote :

I like to confirm that booting into EFI-Mode with Saucy either installed or from Live-CD is no problem anymore.
Booting in Compatibility Mode (hdbios) does NOT work out of the box.
To whom it may concern a description on how to dual boot can be found on https://help.ubuntu.com/community/MacBookAir6-2/Saucy

Yuan Chao (yuanchao) wrote :

On my Macbook air 6,2 (2013), Ubuntu 12.04.3 fails to boot and spils "blkid timeout" errors. It works better with 12.04.4, but the installation crashes on grub-efi-amd64-signed package. However, the audio is fine on 12.04.4, since the kernel is 3.11. Installing broadcom propertary driver will got stuck. Also that 13.10 solves most of the problems, but key "`~" maps to something else which makes it still unusable to me.

Yuan Chao (yuanchao) wrote :

By passing libata.force=noncq to kernel in grub, the blkid timeout problem on 12.04.3 liveusb is gone. Also this seems to solve a random lock up problem on installed 13.10.

serj (sj-sr) wrote :

Solution: install syslinux instead grug2. Works fine without nosmp option.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.