mei_me resets spamming dmesg

Bug #1196155 reported by Herb McNew on 2013-06-29
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Andy Whitcroft

Bug Description

As you can see from the dmesg attached I'm getting the following every 5-10 seconds:
[11332.456035] mei_me 0000:00:03.0: reset: connect/disconnect timeout.
[11332.456044] mei_me 0000:00:03.0: unexpected reset: dev_state = RESETTING

This was happening with raring but I blacklisted the mei module. With saucy it seems mei is included directly and is no longer loaded as a module.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.10.0-1-generic 3.10.0-1.8
ProcVersionSignature: Ubuntu 3.10.0-1.8-generic 3.10.0-rc7
Uname: Linux 3.10.0-1-generic x86_64
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
 /dev/snd/controlC1: herb 2330 F.... pulseaudio
 /dev/snd/controlC0: herb 2330 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Sat Jun 29 18:57:30 2013
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=878dad1b-8d2b-4879-8dea-862befaf67b9
InstallationDate: Installed on 2013-01-23 (157 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Hewlett-Packard HP Compaq dc7700p Convertible Minitower
MarkForUpload: True
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.10.0-1-generic root=UUID=bcaf6352-17f6-4fa2-af31-127c04f60e6e ro quiet splash vt.handoff=7
 linux-restricted-modules-3.10.0-1-generic N/A
 linux-backports-modules-3.10.0-1-generic N/A
 linux-firmware 1.110

SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-06-29 (0 days ago) 08/14/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786E1 v03.03 0A58h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: 2UA741121G
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786E1v03.03:bd08/14/2007:svnHewlett-Packard:pnHPCompaqdc7700pConvertibleMinitower:pvr:rvnHewlett-Packard:rn0A58h:rvr:cvnHewlett-Packard:ct6:cvr: HP Compaq dc7700p Convertible Minitower
dmi.sys.vendor: Hewlett-Packard

Herb McNew (herb) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I confirm that the option is no longer a module, but built into the kernel for Saucy:

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Joseph Salisbury (jsalisbury) wrote :

This is also causing suspend/resume issues, which are being discussed upstream:

Andy Whitcroft (apw) wrote :

This seems to have been picked up when turning on the INTEL_MEI_ME option on during the rebase to v3.10-rc2, it does not appear to have been a deliberate act as such. For now I will shove it back to and M and see if anyone notices.

Andy Whitcroft (apw) on 2013-07-02
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.10.0-2.10

linux (3.10.0-2.10) saucy; urgency=low

  [ Andy Whitcroft ]

  * [Config] CONFIG_INTEL_MEI*=m
    - LP: #1196155
  * [Config] CONFIG_DEBUG_INFO=y

  [ Stephen Warren ]

  * [Config] fix Calxeda xgmac module filename

  [ Upstream Kernel Changes ]

  * Revert "serial: 8250_pci: add support for another kind of NetMos
    Technology PCI 9835 Multi-I/O Controller"
    - LP: #1190967
  * mfd: lpc_ich: Add support for Intel Avoton SoC
    - LP: #1196658
 -- Andy Whitcroft <email address hidden> Fri, 05 Jul 2013 18:08:02 +0100

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Rayan (sudo-rayan) wrote :

how can I apply the fix on my machine? please help

Christian S. (christian-stein2) wrote :

Its happen again

[ 111.128181] mei_me 0000:00:03.0: unexpected reset: dev_state = RESETTING
[ 117.140090] mei_me 0000:00:03.0: reset: connect/disconnect timeout.
[ 117.140111] mei_me 0000:00:03.0: unexpected reset: dev_state = RESETTING
[ 123.152100] mei_me 0000:00:03.0: reset: connect/disconnect timeout.
[ 123.152119] mei_me 0000:00:03.0: unexpected reset: dev_state = RESETTING
christian@t61-ubuntu:~$ uname -a
Linux t61-ubuntu 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Kees Cook (kees) wrote :

"sudo rmmod mei_me mei" should stop the messages. Usually means AMT has been disabled in the BIOS.

I got rid of the startup error message by blacklisting the mei_me driver. To do that, you can add the following two lines at the end of the blacklist.conf file located in /etc/modprobe.d. Here are the steps just in case:

1. Open terminal
2. Type sudo gedit /etc/modprobe.d/blacklist.conf
3. Scroll to the bottom of the file and add the following two lines:
# Intel VPRO remote access technology driver
blacklist mei_me

4. Save the file
5. Restart the computer
--> Now, you should not get the error messages anymore on startup of the computer.

Alvin (alvind) wrote :

What about Trusty?

mei_me 0000:00:03.0: timer: connect/disconnect timeout.
mei_me 0000:00:03.0: unexpected reset: dev_state = ENABLED

Cedric Bhihe (cedric-bhihe) wrote :

Yes, what about Trusty ?
I am affected by this as well on a Intel T9300 Core Duo with :
Linux XXX 3.13.0-27-generic #50-Ubuntu SMP Thu May 15 18:06:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
As you can see my install is recent.

Tim Gardner (timg-tpi) wrote :

The quickest way to stop the log spamming is to blacklist the drivers since your platform obviously doesn't need them. I have a server with the same problem.

echo "blacklist mei" | sudo tee -a /etc/modprobe.d/mei.conf
echo "blacklist mei_me" | sudo tee -a /etc/modprobe.d/mei.conf

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers