Quantal update to 3.5.7.14 stable release

Bug #1191905 reported by Steve Conklin on 2013-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.5.7.14 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://kernel.ubuntu.com/ubuntu/linux.git

    TEST CASE: TBD

       The following patches are in the 3.5.7.14 stable release:

* Linux 3.5.7.14
* xen-netfront: frags -> slots in log message
* xen-netfront: frags -> slots in xennet_get_responses
* xen-netfront: remove unused variable `extra'
* xen-netback: better names for thresholds
* xen-netback: avoid allocating variable size array on stack
* xen-netback: remove redundent parameter in netbk_count_requests
* xen-netback: don't disconnect frontend when seeing oversize packet
* xen-netback: coalesce slots in TX path and fix regressions
* xen-netback: fix sparse warning
* xen-netback: remove skb in xen_netbk_alloc_page
* reiserfs: fix spurious multiple-fill in reiserfs_readdir_dentry
* reiserfs: fix problems with chowning setuid file w/ xattrs
* reiserfs: fix deadlock with nfs racing on create/lookup
* xfs: kill suid/sgid through the truncate path.
* NFSv4: Fix a thinko in nfs4_try_open_cached
* drm/radeon: fix card_posted check for newer asics
* drm/radeon: fix typo in cu_per_sh on verde
* ASoC: cs42l52: fix default value for MASTERA_VOL.
* cifs: fix potential buffer overrun when composing a new options string
* jfs: fix a couple races
* ipvs: ip_vs_sip_fill_param() BUG: bad check of return value
* sched/debug: Fix sd->*_idx limit range avoiding overflow
* sched/debug: Limit sd->*_idx range on sysctl
* mm: mmu_notifier: re-fix freed page still mapped in secondary MMU
* ACPI / video: Add "Asus UL30A" to ACPI video detect blacklist
* ACPI / video: Add "Asus UL30VT" to ACPI video detect blacklist
* acpi/video_detect: blacklist samsung x360
* tg3: Skip powering down function 0 on certain serdes devices
* dm bufio: avoid a possible __vmalloc deadlock
* mwifiex: fix memory leak issue when driver unload
* staging:iio:light:tsl2x7x: fix the error handling in tsl2x7x_probe()
* mm/pagewalk.c: walk_page_range should avoid VM_PFNMAP areas
* ocfs2: goto out_unlock if ocfs2_get_clusters_nocache() failed in ocfs2_fiemap()
* random: fix accounting race condition with lockless irq entropy_count update
* nilfs2: fix issue of nilfs_set_page_dirty() for page at EOF boundary
* drivers/block/brd.c: fix brd_lookup_page() race
* drivers/leds/leds-ot200.c: fix error caused by shifted mask
* mm/THP: use pmd_populate() to update the pmd with pgtable_t pointer
* mm compaction: fix of improper cache flush in migration code
* rapidio/tsi721: fix bug in MSI interrupt handling
* wait: fix false timeouts when using wait_event_timeout()
* fat: fix possible overflow for fat_clusters
* perf: net_dropmonitor: Fix symbol-relative addresses
* perf: net_dropmonitor: Fix trace parameter order
* SUNRPC: Prevent an rpc_task wakeup race
* sunrpc: clarify comments on rpc_make_runnable
* ARM: plat-orion: Fix num_resources and id for ge10 and ge11
* mac80211: fix AP-mode frame matching
* Kirkwood: Enable PCIe port 1 on QNAP TS-11x/TS-21x
* cifs: only set ops for inodes in I_NEW state
* TTY: Fix tty miss restart after we turn off flow-control
* USB: cxacru: potential underflow in cxacru_cm_get_array()
* USB: ftdi_sio: Add support for Newport CONEX motor drivers
* USB: option: add device IDs for Dell 5804 (Novatel E371) WWAN card
* USB: Blacklisted Cinterion's PLxx WWAN Interface
* usb: option: Add Telewell TW-LTE 4G
* USB: reset resume quirk needed by a hub
* USB: UHCI: fix for suspend of virtual HP controller
* USB: xHCI: override bogus bulk wMaxPacketSize values
* staging: vt6656: use free_netdev instead of kfree
* Input: egalax_ts - ABS_MT_POSITION_Y not reported well
* virtio_console: fix uapi header
* avr32: fix relocation check for signed 18-bit offset
* mantis: fix silly crash case
* drm/radeon: Fix VRAM size calculation for VRAM >= 4GB
* btrfs: don't stop searching after encountering the wrong item
* i2c: designware: always clear interrupts before enabling them
* i2c: designware: fix RX FIFO overrun
* hwmon: fix error return code in abituguru_probe()

Steve Conklin (sconklin) on 2013-06-17
tags: added: kernel-stable-tracking-bug
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (6.2 KiB)

This bug was fixed in the package linux - 3.5.0-36.57

---------------
linux (3.5.0-36.57) quantal; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1192590

  [ Timo Aaltonen ]

  * SAUCE: i915_hsw: revert to old drm_mm function names
    - LP: #1188305
  * SAUCE: i915_hsw: drm/i915: Adding more reserved PCI IDs for Haswell.
    - LP: #1175533

linux (3.5.0-35.56) quantal; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1192206

  [ Dave Chiluk ]

  * SAUCE: ncpfs: fix rmdir returns Device or resource busy
    - LP: #1035226

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Timo Aaltonen ]

  * SAUCE: Update i915_hsw to 3.8.13
    - LP: #1188305
  * SAUCE: i915_hsw: Add new definitions
    - LP: #1188305
  * SAUCE: i915_hsw: Revert "drm/i915: use drm_send_vblank_event() helper"
    - LP: #1188305
  * SAUCE: i915_hsw: Revert "drm/i915: set the VIC of the mode on the AVI
    InfoFrame"
    - LP: #1188305

  [ Upstream Kernel Changes ]

  * hwmon: fix error return code in abituguru_probe()
    - LP: #1191905
  * i2c: designware: fix RX FIFO overrun
    - LP: #1191905
  * i2c: designware: always clear interrupts before enabling them
    - LP: #1191905
  * btrfs: don't stop searching after encountering the wrong item
    - LP: #1191905
  * drm/radeon: Fix VRAM size calculation for VRAM >= 4GB
    - LP: #1191905
  * mantis: fix silly crash case
    - LP: #1191905
  * avr32: fix relocation check for signed 18-bit offset
    - LP: #1191905
  * virtio_console: fix uapi header
    - LP: #1191905
  * Input: egalax_ts - ABS_MT_POSITION_Y not reported well
    - LP: #1191905
  * staging: vt6656: use free_netdev instead of kfree
    - LP: #1191905
  * USB: xHCI: override bogus bulk wMaxPacketSize values
    - LP: #1191905
  * USB: UHCI: fix for suspend of virtual HP controller
    - LP: #1191905
  * USB: reset resume quirk needed by a hub
    - LP: #1191905
  * usb: option: Add Telewell TW-LTE 4G
    - LP: #1191905
  * USB: Blacklisted Cinterion's PLxx WWAN Interface
    - LP: #1191905
  * USB: option: add device IDs for Dell 5804 (Novatel E371) WWAN card
    - LP: #1191905
  * USB: ftdi_sio: Add support for Newport CONEX motor drivers
    - LP: #1191905
  * USB: cxacru: potential underflow in cxacru_cm_get_array()
    - LP: #1191905
  * TTY: Fix tty miss restart after we turn off flow-control
    - LP: #1191905
  * cifs: only set ops for inodes in I_NEW state
    - LP: #1191905
  * Kirkwood: Enable PCIe port 1 on QNAP TS-11x/TS-21x
    - LP: #1191905
  * mac80211: fix AP-mode frame matching
    - LP: #1191905
  * ARM: plat-orion: Fix num_resources and id for ge10 and ge11
    - LP: #1191905
  * sunrpc: clarify comments on rpc_make_runnable
    - LP: #1191905
  * SUNRPC: Prevent an rpc_task wakeup race
    - LP: #1191905
  * perf: net_dropmonitor: Fix trace parameter order
    - LP: #1191905
  * perf: net_dropmonitor: Fix symbol-relative addresses
    - LP: #1191905
  * fat: fix possible overflow for fat_clusters
    - LP: #1191905
  * wait: fix false timeouts when using wait_event_timeout()
    - LP: #1191905
  * rapidio/tsi721: fix bug in MSI interrupt handling
    - LP: #1191905
...

Read more...

Changed in linux (Ubuntu Quantal):
status: New → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in linux (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers