dm-snapshot should be in the installer environment

Bug #1191726 reported by Stefan Bader on 2013-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Stefan Bader
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

When using snapshots there is one special situation when using "lvconvert --merge" on a snapshot when its origin is still in use (the merge subcommand is in lvconvert since Precise/12.04 at least). In that case the merge request is noted in the meta-data and it will get done the next time the volume group gets activated.

One case where this should be supported as well would be the rescue environment we offer on server images. For this the dm-snapshot module needs to get listed in the d-i lists (Actually there could the the theoretical situation where someone had initiated a merge and the next thing done is an install into the same volume group).

SRU Justification:

Impact: Without this, the installer and rescue environment will produce an error and hide the origin to be merged (as well as the snapshot) making it impossible to access the origin.

Fix: Just an additional module for the d-i.

Testcase: Initiate a merge on a mounted origin. Then boot into the rescue system and try to activate the VG.

Stefan Bader (smb) on 2013-06-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.9.0-6.14

---------------
linux (3.9.0-6.14) saucy; urgency=low

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Tim Gardner ]

  * SAUCE: Updated lttng to 5ca7b8a36c04e0733b6661d519343eb586d75a51
  * [Config] d-i: Add calxedaxgmac to nic-modules
    - LP: #1192358
  * Release Tracking Bug
    - LP: #1192633

  [ Upstream Kernel Changes ]

  * alx: add a simple AR816x/AR817x device driver
    cherry-picked from linux-next, replaces ubuntu/alx. upstream
    merge expected in 3.11
 -- Tim Gardner <email address hidden> Wed, 19 Jun 2013 08:59:51 -0600

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-precise
Stefan Bader (smb) wrote :

Verified that the md-modules udeb contains dm-snapshot for current Precise and Quantal -proposed.

tags: added: verification-done-precise verification-done-quantal
removed: verification-needed-precise verification-needed-quantal
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
Changed in linux (Ubuntu Quantal):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.2 KiB)

This bug was fixed in the package linux - 3.5.0-36.57

---------------
linux (3.5.0-36.57) quantal; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1192590

  [ Timo Aaltonen ]

  * SAUCE: i915_hsw: revert to old drm_mm function names
    - LP: #1188305
  * SAUCE: i915_hsw: drm/i915: Adding more reserved PCI IDs for Haswell.
    - LP: #1175533

linux (3.5.0-35.56) quantal; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1192206

  [ Dave Chiluk ]

  * SAUCE: ncpfs: fix rmdir returns Device or resource busy
    - LP: #1035226

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Timo Aaltonen ]

  * SAUCE: Update i915_hsw to 3.8.13
    - LP: #1188305
  * SAUCE: i915_hsw: Add new definitions
    - LP: #1188305
  * SAUCE: i915_hsw: Revert "drm/i915: use drm_send_vblank_event() helper"
    - LP: #1188305
  * SAUCE: i915_hsw: Revert "drm/i915: set the VIC of the mode on the AVI
    InfoFrame"
    - LP: #1188305

  [ Upstream Kernel Changes ]

  * hwmon: fix error return code in abituguru_probe()
    - LP: #1191905
  * i2c: designware: fix RX FIFO overrun
    - LP: #1191905
  * i2c: designware: always clear interrupts before enabling them
    - LP: #1191905
  * btrfs: don't stop searching after encountering the wrong item
    - LP: #1191905
  * drm/radeon: Fix VRAM size calculation for VRAM >= 4GB
    - LP: #1191905
  * mantis: fix silly crash case
    - LP: #1191905
  * avr32: fix relocation check for signed 18-bit offset
    - LP: #1191905
  * virtio_console: fix uapi header
    - LP: #1191905
  * Input: egalax_ts - ABS_MT_POSITION_Y not reported well
    - LP: #1191905
  * staging: vt6656: use free_netdev instead of kfree
    - LP: #1191905
  * USB: xHCI: override bogus bulk wMaxPacketSize values
    - LP: #1191905
  * USB: UHCI: fix for suspend of virtual HP controller
    - LP: #1191905
  * USB: reset resume quirk needed by a hub
    - LP: #1191905
  * usb: option: Add Telewell TW-LTE 4G
    - LP: #1191905
  * USB: Blacklisted Cinterion's PLxx WWAN Interface
    - LP: #1191905
  * USB: option: add device IDs for Dell 5804 (Novatel E371) WWAN card
    - LP: #1191905
  * USB: ftdi_sio: Add support for Newport CONEX motor drivers
    - LP: #1191905
  * USB: cxacru: potential underflow in cxacru_cm_get_array()
    - LP: #1191905
  * TTY: Fix tty miss restart after we turn off flow-control
    - LP: #1191905
  * cifs: only set ops for inodes in I_NEW state
    - LP: #1191905
  * Kirkwood: Enable PCIe port 1 on QNAP TS-11x/TS-21x
    - LP: #1191905
  * mac80211: fix AP-mode frame matching
    - LP: #1191905
  * ARM: plat-orion: Fix num_resources and id for ge10 and ge11
    - LP: #1191905
  * sunrpc: clarify comments on rpc_make_runnable
    - LP: #1191905
  * SUNRPC: Prevent an rpc_task wakeup race
    - LP: #1191905
  * perf: net_dropmonitor: Fix trace parameter order
    - LP: #1191905
  * perf: net_dropmonitor: Fix symbol-relative addresses
    - LP: #1191905
  * fat: fix possible overflow for fat_clusters
    - LP: #1191905
  * wait: fix false timeouts when using wait_event_timeout()
    - LP: #1191905
  * rapidio/tsi721: fix bug in MSI interrupt handling
    - LP: #1191905
...

Read more...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.2.0-49.75

---------------
linux (3.2.0-49.75) precise; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1192253

  [ Dave Chiluk ]

  * SAUCE: ncpfs: fix rmdir returns Device or resource busy
    - LP: #1035226

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726
 -- Steve Conklin <email address hidden> Tue, 18 Jun 2013 12:12:44 -0500

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Stefan Bader (smb) wrote :

The md-modules udeb for 3.8.0-27.40 contains dm-snapshot.ko (amd64 and i386).

tags: added: verification-done-raring
removed: verification-needed-raring
Launchpad Janitor (janitor) wrote :
Download full text (15.4 KiB)

This bug was fixed in the package linux - 3.8.0-27.40

---------------
linux (3.8.0-27.40) raring; urgency=low

  [Brad Figg]

  * UBUNTU: [Config] CONFIG_ARM_ERRATA_643719=y

linux (3.8.0-27.39) raring; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #1199128

  [ Brad Figg ]

  * [Config] CONFIG_ATH9K_LEGACY_RATE_CONTROL=y

  [ Seth Forshee ]

  * SAUCE: Work around broken ACPI backlight on ThinkPad T430
    - LP: #1183856

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Tim Gardner ]

  * [Config] CONFIG_SUNRPC_DEBUG=y
    - LP: #1127319

  [ Upstream Kernel Changes ]

  * Revert "ath9k_hw: Update rx gain initval to improve rx sensitivity"
    - LP: #1193126
  * Revert "serial: 8250_pci: add support for another kind of NetMos
    Technology PCI 9835 Multi-I/O Controller"
    - LP: #1190967
  * mac80211: close AP_VLAN interfaces before unregistering all
    - LP: #1193126
  * ath9k: use correct OTP register offsets for AR9550
    - LP: #1193126
  * regulator: palmas: Fix "enable_reg" to point to the correct reg for
    SMPS10
    - LP: #1193126
  * net: can: kvaser_usb: fix reception on "USBcan Pro" and "USBcan R" type
    hardware.
    - LP: #1193126
  * tg3: Add read dma workaround for 5720
    - LP: #1193126
  * xhci-mem: init list heads at the beginning of init
    - LP: #1193126
  * xhci: fix list access before init
    - LP: #1193126
  * xhci - correct comp_mode_recovery_timer on return from hibernate
    - LP: #1193126
  * xhci: Disable D3cold for buggy TI redrivers.
    - LP: #1193126
  * usb: dwc3: pci: PHY should be deleted later than dwc3 core
    - LP: #1193126
  * usb: dwc3: gadget: free trb pool only from epnum 2
    - LP: #1193126
  * usb: musb: make use_sg flag URB specific
    - LP: #1193126
  * USB: revert periodic scheduling bugfix
    - LP: #1193126
  * USB: serial: fix Treo/Kyocera interrrupt-in urb context
    - LP: #1193126
  * USB: visor: fix initialisation of Treo/Kyocera devices
    - LP: #1193126
  * USB: mos7720: fix DMA to stack
    - LP: #1193126
  * USB: mos7840: fix DMA to stack
    - LP: #1193126
  * USB: ark3116: fix control-message timeout
    - LP: #1193126
  * USB: iuu_phoenix: fix bulk-message timeout
    - LP: #1193126
  * USB: mos7720: fix message timeouts
    - LP: #1193126
  * USB: zte_ev: fix control-message timeouts
    - LP: #1193126
  * USB: Serial: cypress_M8: Enable FRWD Dongle hidcom device
    - LP: #1193126
  * USB: serial: Add Option GTM681W to qcserial device table.
    - LP: #1193126
  * USB: zte_ev: fix broken open
    - LP: #1193126
  * USB: keyspan: fix bogus array index
    - LP: #1193126
  * USB: mos7720: fix hardware flow control
    - LP: #1193126
  * x86/PCI: Map PCI setup data with ioremap() so it can be in highmem
    - LP: #1193126
  * USB: whiteheat: fix broken port configuration
    - LP: #1193126
  * USB: option: blacklist network interface on Huawei E1820
    - LP: #1193126
  * USB: option,zte_ev: move most ZTE CDMA devices to zte_ev
    - LP: #1193126
  * ecryptfs: fixed msync to flush data
    - LP: #1193126
  * dmaengine: ste_dma40: fix pm runtime ref counting
    - LP: #1193126
  * cifs: fix off-by-one bug in build_unc...

Changed in linux (Ubuntu Raring):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers