Brightness control on Lenovo ThinkPad T430 does not work.

Bug #1183856 reported by Felix on 2013-05-24
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Seth Forshee
Raring
Undecided
Unassigned
Saucy
Medium
Seth Forshee

Bug Description

== Raring SRU Justification ==

Impact: A bug in the ACPI tables causes the ACPI backlight interface to fail to apply brightness changes with kernels claiming Windows 8 compatibility. This interface is generally the first choice of userspace, and users are unable to adjust the brightness using GUI tools.

Fix: Quirk the affected model to disable Windows 8 compatibility. This causes the AML to fall back to the pre-Win8 behavior, which functions correctly.

Test case: Verify on an affected machine. Verified on LP #1183856.

---

FN-Keys don't work for me on my ThinkPad T430.

When i'm on battery mode the screen does not dim down to save power, even not with the workaround.

The problem exists since the release of Ubuntu 13.04

My actual Kernel: 3.8.0-22-generic

For the T430s the problem seems to be fixed: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1098216

WORKAROUND:

Add to /etc/default/grub
in the variable "GRUB_CMDLINE_LINUX_DEFAULT":

acpi_osi=\"!Windows 2012\"

e.g:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\""

Then run "sudo update-grub".

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-22-generic 3.8.0-22.33
ProcVersionSignature: Ubuntu 3.8.0-22.33-generic 3.8.11
Uname: Linux 3.8.0-22-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: felix 2436 F.... pulseaudio
 /dev/snd/controlC0: felix 2436 F.... pulseaudio
 /dev/snd/controlC1: felix 2436 F.... pulseaudio
Date: Fri May 24 17:05:25 2013
HibernationDevice: RESUME=UUID=a3e1a0e4-da74-4961-a4df-d5a5ccae333d
InstallationDate: Installed on 2013-05-22 (1 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: LENOVO 2349D17
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-22-generic root=UUID=c3662fb4-16b3-4a1d-808d-9530ba42ab52 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-22-generic N/A
 linux-backports-modules-3.8.0-22-generic N/A
 linux-firmware 1.106
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/22/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: G1ET94WW (2.54 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2349D17
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG1ET94WW(2.54):bd04/22/2013:svnLENOVO:pn2349D17:pvrThinkPadT430:rvnLENOVO:rn2349D17:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2349D17
dmi.product.version: ThinkPad T430
dmi.sys.vendor: LENOVO

CVE References

Felix (cebor) wrote :
Felix (cebor) on 2013-05-24
summary: - Brightness control on Lenovo T430 does not work.
+ Brightness control on Lenovo ThinkPadT430 does not work.
description: updated
summary: - Brightness control on Lenovo ThinkPadT430 does not work.
+ Brightness control on Lenovo ThinkPad T430 does not work.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Felix (cebor) on 2013-05-26
tags: added: regression-update
description: updated
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
  • DSDT.dat Edit (63.6 KiB, application/x-ns-proxy-autoconfig)
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Felix (cebor) wrote :
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.10 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc3-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Felix (cebor) wrote :

uname -r
3.10.0-031000rc3-generic

diming works a little bit more, but only every 5th pressing "FN+F8", bar at the top-right goes down correctly but the brightness goes only down every 5th step.

tags: added: kernel-bug-exists-upstream
Felix (cebor) wrote :

uname -r
3.8.0-23-generic

bug still exists

Felix (cebor) wrote :

uname -r
3.8.0-25-generic

bug still exists

Seth Forshee (sforshee) wrote :

Please test the kernel at the link below and see if it fixes your issue.

http://people.canonical.com/~sforshee/lp1183856/linux-3.8.0-25-generic_3.8.0-25.37~lp1183856v201306170745/

Felix (cebor) wrote :

uname -a
Linux ThinkPad 3.8.0-25-generic #37~lp1183856v201306170745 SMP Mon Jun 17 14:34:34 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

bug seems to be fixed.

Thank you!

Seth Forshee (sforshee) on 2013-06-18
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
status: Incomplete → In Progress
Seth Forshee (sforshee) on 2013-06-18
description: updated
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Felix (cebor) wrote :

uname -r
3.8.0-27-generic

Bug seems to be fixed in the proposed kernel, brightness control works fine,

but unfortunately "Dim screen to save power" - function still does not work.

tags: added: verification-done-raring
removed: verification-needed-raring
Olivier Bilodeau (plaxx) wrote :

Same problem exists on thinkpad t431s.

$ uname -a
Linux urquell 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Attached result of acpidump. Note that when doing the dump this printed on STDERR:

Wrong checksum for FADT!

Olivier Bilodeau (plaxx) wrote :

Just tested the raring-proposed kernel and brightness controls still don't work there.

$ uname -a
Linux urquell 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:17:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Can the fix be easily ported to T431s?

Launchpad Janitor (janitor) wrote :
Download full text (15.4 KiB)

This bug was fixed in the package linux - 3.8.0-27.40

---------------
linux (3.8.0-27.40) raring; urgency=low

  [Brad Figg]

  * UBUNTU: [Config] CONFIG_ARM_ERRATA_643719=y

linux (3.8.0-27.39) raring; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #1199128

  [ Brad Figg ]

  * [Config] CONFIG_ATH9K_LEGACY_RATE_CONTROL=y

  [ Seth Forshee ]

  * SAUCE: Work around broken ACPI backlight on ThinkPad T430
    - LP: #1183856

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Tim Gardner ]

  * [Config] CONFIG_SUNRPC_DEBUG=y
    - LP: #1127319

  [ Upstream Kernel Changes ]

  * Revert "ath9k_hw: Update rx gain initval to improve rx sensitivity"
    - LP: #1193126
  * Revert "serial: 8250_pci: add support for another kind of NetMos
    Technology PCI 9835 Multi-I/O Controller"
    - LP: #1190967
  * mac80211: close AP_VLAN interfaces before unregistering all
    - LP: #1193126
  * ath9k: use correct OTP register offsets for AR9550
    - LP: #1193126
  * regulator: palmas: Fix "enable_reg" to point to the correct reg for
    SMPS10
    - LP: #1193126
  * net: can: kvaser_usb: fix reception on "USBcan Pro" and "USBcan R" type
    hardware.
    - LP: #1193126
  * tg3: Add read dma workaround for 5720
    - LP: #1193126
  * xhci-mem: init list heads at the beginning of init
    - LP: #1193126
  * xhci: fix list access before init
    - LP: #1193126
  * xhci - correct comp_mode_recovery_timer on return from hibernate
    - LP: #1193126
  * xhci: Disable D3cold for buggy TI redrivers.
    - LP: #1193126
  * usb: dwc3: pci: PHY should be deleted later than dwc3 core
    - LP: #1193126
  * usb: dwc3: gadget: free trb pool only from epnum 2
    - LP: #1193126
  * usb: musb: make use_sg flag URB specific
    - LP: #1193126
  * USB: revert periodic scheduling bugfix
    - LP: #1193126
  * USB: serial: fix Treo/Kyocera interrrupt-in urb context
    - LP: #1193126
  * USB: visor: fix initialisation of Treo/Kyocera devices
    - LP: #1193126
  * USB: mos7720: fix DMA to stack
    - LP: #1193126
  * USB: mos7840: fix DMA to stack
    - LP: #1193126
  * USB: ark3116: fix control-message timeout
    - LP: #1193126
  * USB: iuu_phoenix: fix bulk-message timeout
    - LP: #1193126
  * USB: mos7720: fix message timeouts
    - LP: #1193126
  * USB: zte_ev: fix control-message timeouts
    - LP: #1193126
  * USB: Serial: cypress_M8: Enable FRWD Dongle hidcom device
    - LP: #1193126
  * USB: serial: Add Option GTM681W to qcserial device table.
    - LP: #1193126
  * USB: zte_ev: fix broken open
    - LP: #1193126
  * USB: keyspan: fix bogus array index
    - LP: #1193126
  * USB: mos7720: fix hardware flow control
    - LP: #1193126
  * x86/PCI: Map PCI setup data with ioremap() so it can be in highmem
    - LP: #1193126
  * USB: whiteheat: fix broken port configuration
    - LP: #1193126
  * USB: option: blacklist network interface on Huawei E1820
    - LP: #1193126
  * USB: option,zte_ev: move most ZTE CDMA devices to zte_ev
    - LP: #1193126
  * ecryptfs: fixed msync to flush data
    - LP: #1193126
  * dmaengine: ste_dma40: fix pm runtime ref counting
    - LP: #1193126
  * cifs: fix off-by-one bug in build_unc...

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Tim Gardner (timg-tpi) on 2013-09-20
Changed in linux (Ubuntu Saucy):
status: Fix Released → Fix Committed
Felix (cebor) on 2013-09-20
Changed in linux (Ubuntu Raring):
status: New → Fix Committed
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.11.0-9.16

---------------
linux (3.11.0-9.16) saucy; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as preferring READ
    CAPACITY (16) at SPC-2"
  * Revert "SAUCE: (no-up) scsi: hyper-v storage -- mark as VPD capable at
    SPC-2"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request READ
    CAPACITY (16) be preferred"
  * Revert "SAUCE: (no-up) scsi: add scsi device flag to request VPD pages
    be used at SPC-2"

  [ Seth Forshee ]

  * SAUCE: (no-up) ACPI: Disable Windows 8 compatibility for some Lenovo
    ThinkPads
    - LP: #1183856

  [ Tim Gardner ]

  * [Config] CONFIG_CRYPTO_CRCT10DIF=y, CONFIG_CRYPTO_CRCT10DIF_PCLMUL=m
  * [packaging] Bump ABI for every new release
  * rebase to v3.11.2
  * Release tracker
    - LP: #1231999

  [ Upstream Kernel Changes ]

  * scsi: hyper-v storsvc switch up to SPC-3
  * perf/x86: Add Silvermont (22nm Atom) support
    - LP: #1091539
  * perf/x86/intel: Fix Silvermont offcore masks
    - LP: #1091539
  * modules: add support for soft module dependencies
    - LP: #1188010
  * Reinstate "crypto: crct10dif - Wrap crc_t10dif function all to use
    crypto transform framework"
    - LP: #1188010
  * skge: fix broken driver
    - LP: #1216745
  * Input: cypress_ps2 - Return zero finger count if palm is detected.
    - LP: #1229361
  * udf: Standardize return values in mount sequence
    - LP: #1228751
  * udf: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * rebase to v3.11.2
 -- Tim Gardner <email address hidden> Mon, 23 Sep 2013 07:41:07 -0600

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers