check_ide_smart fails with i/o error

Bug #1182247 reported by Fjodor on 2013-05-20
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Dave Chiluk

Bug Description

SRU Justification:

Impact: Smart monitoring tools such as smartd and nagios's check_ide_smart fail with i/o error.

Fix: Fix comes from upstream b7b2ee88b4c8d3326d144a051252d78bded93557. I have built and tested this fix and verified that it resolves the issue.

Testcase:
In the broken case)
$ sudo /usr/lib/nagios/plugins/check_ide_smart -d /dev/sda -i -n
CRITICAL - SMART_ENABLE: Input/output error
CRITICAL - SMART_CMD_ENABLE

After patch)
/usr/lib/nagios/plugins/check_ide_smart -n -d /dev/sda
OK - Operational (15/15 tests passed)

It would seem that check_ide_smart is defunct on my server, giving the following results when run manually:

sune@jadis:~$ sudo /usr/lib/nagios/plugins/check_ide_smart -d /dev/sda -i -n
CRITICAL - SMART_ENABLE: Input/output error
CRITICAL - SMART_CMD_ENABLE

Normal SMART commands via smartctl show no problems.

As for the list:

1) sune@jadis:~$ lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

2) sune@jadis:~$ apt-cache policy nagios-plugins
nagios-plugins:
  Installed: 1.4.16-1ubuntu3
  Candidate: 1.4.16-1ubuntu3
  Version table:
 *** 1.4.16-1ubuntu3 0
        500 http://dk.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

3) Correct SMART status output

4) What I started by writing.

I shall be happy to answer any and all questions and to try out any and all patches.

Best regards,

Sune Mølgaard

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Please could you check the latest upstream version of nagios-plugins to see if this is a bug in Ubuntu or in the upstream project itself? If it turns out to be upstream, this bug would best be submitted and addressed upstream first.

If you do end up filing a bug upstream, please link to it here. Thanks!

Changed in nagios-plugins (Ubuntu):
importance: Undecided → Medium

Am 21.05.2013 09:55, schrieb Robie Basak:
> Please could you check the latest upstream version of
> nagios-plugins

sorry, but which "latest upstream version" are you talking about?!?
Recent upstream version is 1.4.16, same as in Ubuntu and Debian!

Anyways .. I would have a look into the options "--debug" and
"--interface" (which needs an argument). For me it smells like local
configurations problem.

Cheers, Jan.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nagios-plugins (Ubuntu):
status: New → Confirmed
Jan Wagner (waja) on 2013-06-05
Changed in nagios-plugins (Ubuntu):
status: Confirmed → Incomplete
Peter Matulis (petermatulis) wrote :

This appears to be a kernel problem. The command works in Precise and Quantal but not Raring. I tested this on Precise using the HWE stack [1].

$ sudo /usr/lib/nagios/plugins/check_ide_smart -n -d /dev/sda

OK - Operational (7/7 tests passed)

Output after changing to the Raring kernel:

CRITICAL - SMART_ENABLE: Input/output error
CRITICAL - SMART_CMD_ENABLE

[1]:
sudo apt-get install linux-image-generic-lts-quantal
sudo apt-get install linux-image-generic-lts-raring

Changed in nagios-plugins (Ubuntu):
status: Incomplete → New
Peter Matulis (petermatulis) wrote :

I tried the mainline 3.8.1 kernel [1] on Precise and the command works. This suggests that there is something in the Ubuntu-distributed kernel that is causing the problem.

[1]: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.1-raring/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: nagios-plugins (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
Dave Chiluk (chiluk) on 2013-08-04
description: updated
Dave Chiluk (chiluk) on 2013-08-04
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Dave Chiluk (chiluk) on 2013-08-04
description: updated
Dave Chiluk (chiluk) wrote :

The fix for this was committed via 48f81bd7c and has now been pushed to raring-proposed with 3.8.0.30.48.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
assignee: nobody → Dave Chiluk (chiluk)
Dave Chiluk (chiluk) on 2013-08-23
tags: added: verification-needed
Dave Chiluk (chiluk) wrote :

Can anyone on this bug please verify that the kernel in raring-proposed has resolved this issue and change the verification-needed tag to verification-done.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Peter Matulis (petermatulis) wrote :

Looks good.

===
$ uname -r
3.8.0-30-generic

$ apt-cache policy linux-image
linux-image:
  Installed: 3.8.0.30.48
  Candidate: 3.8.0.30.48
  Version table:
 *** 3.8.0.30.48 0
        500 http://archive.ubuntu.com/ubuntu/ raring-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.8.0.29.47 0
        500 http://archive.ubuntu.com/ubuntu/ raring-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ raring-security/main amd64 Packages
     3.8.0.19.35 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

$ sudo /usr/lib/nagios/plugins/check_ide_smart -n -d /dev/sda
[sudo] password for ubuntu:
OK - Operational (7/7 tests passed)
===

tags: added: verification-done
removed: verification-needed
Dave Chiluk (chiluk) on 2013-08-26
tags: removed: verification-needed-raring
tags: added: verification-done-raring
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers