HP ProBook 5320m crashes after suspend

Bug #1182223 reported by Matej Kovacic on 2013-05-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have HP ProBook 5320m, which was working with Ubuntu 12.10 just fine. I am using LUKS encryption of the whole hard disk (except /boot partition, of course) and additional /home user encryption.

However, I upgraded to 13.04 and after suspend laptop crashes (when I try to power it up again).

Here is the screenschoot of what happens:
http://matthai.owca.info/13-04_suspend_HP_ProBook5320m_bug.jpg

It says something about being unable to handle NULL pointer dereference, and the it seems there is an error/crash in iwconfig. Any idea what could be wrong?
---
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: matej 3228 F.... pulseaudio
DistroRelease: Ubuntu 13.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=b13c5ba7-5be9-4101-97e6-faef5be64124
InstallationDate: Installed on 2011-10-21 (601 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
MachineType: Hewlett-Packard HP ProBook 5320m
MarkForUpload: True
NonfreeKernelModules: wl
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-25-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-25.37-generic 3.8.13
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-25-generic N/A
 linux-backports-modules-3.8.0-25-generic N/A
 linux-firmware 1.106
Tags: raring
Uname: Linux 3.8.0-25-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-05-20 (24 days ago)
UserGroups: adm admin audio cdrom debian-tor dialout kismet libvirtd lpadmin plugdev sambashare vboxusers
dmi.bios.date: 06/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68AFU Ver. F.02
dmi.board.name: 149B
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 82.10
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68AFUVer.F.02:bd06/25/2010:svnHewlett-Packard:pnHPProBook5320m:pvr:rvnHewlett-Packard:rn149B:rvrKBCVersion82.10:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 5320m
dmi.sys.vendor: Hewlett-Packard

Matej Kovacic (matej-kovacic) wrote :

It seems it is a kernel problem. Under default 13.04 kernel (3.8.0-22) going back from suspend doesn't work, but under 3.5.0-31 suspend works perfectly.

Any idea what exactly in kernel is a problem? Wireless drivers?

affects: software-properties (Ubuntu) → linux-meta (Ubuntu)
Brad Figg (brad-figg) on 2013-06-08
affects: linux-meta (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1182223

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.10 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc5-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: raring regression-update

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Matej Kovacic (matej-kovacic) wrote :

Problem still exists with the lattest kernel: 3.8.0-25-generic #37-Ubuntu SMP Thu Jun 6 20:47:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Tag: kernel-bug-exists-upstream

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Matej Kovacic, as per http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=4222535&prodTypeId=321957&prodSeriesId=4222577&swLang=13&taskId=135&swEnvOID=2020 an update is available for your BIOS (F.20). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

tags: added: bios-outdated-f.20 kernel-bug-exists-upstream-v3.10-rc5 needs-upstream-testing regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Matej Kovacic (matej-kovacic) wrote :

I updated BIOS to F.22, but it is the same. I also tried kernel 3.8.0-28 (with old and new BIOS), and it is almost the same.

The only difference is, that when I press ctrl-alt-F7, I came back to "GUI" console, but network is completely down (disabled), I cannot enable it in Network Manager.

BTW: sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
says:

68AFU Ver. F.22
06/14/2012

Matej Kovacic, thank you for updating your BIOS. Could you please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.11-rc3-saucy/ ?

tags: added: latest-bios-f.22
removed: bios-outdated-f.20
Matej Kovacic (matej-kovacic) wrote :

I installed it with:

sudo dpkg -i linux-image-3.11.0-031100rc3-generic_3.11.0-031100rc3.201307290035_amd64.deb linux-headers-3.11.0-031100rc3-generic_3.11.0-031100rc3.201307290035_amd64.deb linux-headers-3.11.0-031100rc3_3.11.0-031100rc3.201307290035_all.deb

But I got an error:
bcmwl-kernel-source 6.20.155.1+bdcom-0ubuntu6: bcmwl kernel module failed to build (this bug is already in Launchpad).

In console there was this text (among the others)
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169

Now I will try to boot in a new kernel anyway...

Matej Kovacic (matej-kovacic) wrote :

Well, I tried, and it is still not working.

First of all, it boots into a new kernel (uname -a says Linux cryptopia 3.11.0-031100rc3-generic #201307290035 SMP Mon Jul 29 04:36:40 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux), but there is no wireless network and just after the boot I have got an arror "There was an error during installing bcmwl-kernel-source".

I tried to suspend, and it does not suspend at all (it just logoff when I close the laptop). So when I go back from "suspend" (when I open laptop again), it is working (it shows login screen). But I am pretty sure it is working only because there is no wireless modules. It seems wireless modules are really source of troubles.

Meanwhile... I noticed, that when I am at my office's wireless network (we have Ruckus wi-fi), wireless (under working kernel) is working just fine for me, but all others get a lot of dropped packets. It seems my wireless card (firmware actually) is causing some real troubles. It was not the case wit some older Ubuntu (11.x). Just for a notice.

Matej Kovacic, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Matej Kovacic (matej-kovacic) wrote :

Damn, now I boot back into the old kernel (3.5.0-31), but it seems suspend is not working anymore. I close the laptop, it seems it is in suspend mode, but after few hours battery is completely drained...

I just removed 3.11 kernel (sudo apt-get remove --purge linux-headers-3.11.0-031100rc3 linux-headers-3.11.0-031100rc3-generic linux-image-3.11.0-031100rc3-generic)... will se how it will work now.

BTW, when booting into old kernel, I get two errors, one is connected with suspend and other with ubuntu-one sync tool (I was not paying too much attention on details).

Will try to reboot after 3.11 kernel was removed and see if it is working... Will also try new ISO in a few days.

Matej Kovacic (matej-kovacic) wrote :

Damn, damn, damn. I found one what is the problem now. Laptop says battery is not present. It seems BIOS after update (to F.22) does not recognize a battery anymore! That is the reason why looked like suspend was not working.

I understand this is not a kernel prob,em anymore, but is there any suggestion what to do? On a HP website it was stated that when you upgrade BIOS to newer version, you cannot downgrade anymore...

tags: added: kernel-bug-exists-upstream-v3.10-rc4
removed: kernel-bug-exists-upstream-v3.10-rc5
tags: removed: needs-upstream-testing
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers