056a:00d6 [Asus V-P5G45] Bamboo Pen and Touch - Buttons not working and Touch Unusable

Bug #1181166 reported by Phill on 2013-05-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Clean installation of Ubuntu 13.04 with latest updates. I'm sure that this all worked perfectly under 12.04 without any tweaks. I'm not sure which package this is in as the code is spread between kernel modules and an X11 driver.

Using Wacom Bamboo Pen and Touch, the buttons don't work and the touch motion is so excessive that it goes from edge-to-edge over about a third of the touch area. Note that touch motion is independent of settings for the pen, it is always relative in recent releases.

Pointer movement is unpredictable with small movements producing both large 10+pixel step changes and small 5-pixel step changes for no apparent reason. Buttons work on the log-in page only.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-19-generic 3.8.0-19.30
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: phill 2043 F.... pulseaudio
 /dev/snd/controlC0: phill 2043 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Fri May 17 10:50:59 2013
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=7438ed9e-5099-4d5f-a0c4-a2acf41e41b3
InstallationDate: Installed on 2013-05-03 (13 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
IwConfig:
 eth2 no wireless extensions.

 lo no wireless extensions.
MachineType: System manufacturer V-P5G45
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=1fb8697a-7ed6-41e1-9a44-8c3728862ad7 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-19-generic N/A
 linux-backports-modules-3.8.0-19-generic N/A
 linux-firmware 1.106
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 12/10/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0311
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: V-P5G45
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0311:bd12/10/2008:svnSystemmanufacturer:pnV-P5G45:pvrSystemVersion:rvnASUSTeKComputerINC.:rnV-P5G45:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: V-P5G45
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Phill (phill.l) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.10 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc1-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Phill (phill.l) wrote :

It'll be Monday/Tuesday before I'm able to risk losing by machine for any stretch of time, but yes I'll try it.

Phill (phill.l) wrote :

Tested with linux-image-3.10.0-031000rc4-generic_3.10.0-031000rc4.201306020443_amd64.deb. Still exists.

Noticed that the buttons work on the log-in page, but not once you're logged in. I've updated the description to include this and to clarify the pointer movement issue.

tags: added: kernel-bug-exists-upstream
description: updated
Phill (phill.l) wrote :

I done a little more testing. If you "cat /dev/input/wacom-touch" clicking the buttons does dump some output to the console, so it's getting that far. Hope that helps. Let me know if I can do anything productive to help fix this.

tags: added: bios-outdated-405
summary: - Bamboo Pen and Touch - Buttons not working and Touch Unusable
+ 056a:00d6 [Asus V-P5G45] Bamboo Pen and Touch - Buttons not working and
+ Touch Unusable
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Phill (phill.l) wrote :

I just updated the BIOS and it had no effect, the behaviour is the same.

Phill (phill.l) wrote :

Just to help confirm/refute the BIOS/motherboard hypothesis I tried the device on my laptop also running 13.04. Exactly same faults (unusable precision using touch and buttons not working, the pen works fine). If you like I could boot 12.04 to re-confirm it's a regression and try 12.10 to help narrow it down?

Base Board Information
 Manufacturer: Micro-Star International
 Product Name: To be filled by O.E.M.
 Version: Ver.001
 Serial Number: FFFFFFFF
 Asset Tag: To be filled by O.E.M.
 Features:
  Board is a hosting board
  Board is replaceable
 Location In Chassis: To be filled by O.E.M.
 Chassis Handle: 0x0003
 Type: Motherboard
 Contained Object Handles: 0

BIOS Information
 Vendor: American Megatrends Inc.
 Version: E1681IG6 VER.109
 Release Date: 07/21/2010
 Address: 0xF0000
 Runtime Size: 64 kB
 ROM Size: 2048 kB
 BIOS Revision: 4.6

Phill (phill.l) wrote :

Here's the command output from my desktop that you asked for:

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
0405
05/18/2009
$

I don't understand what "Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful" means.

Thanks for looking into it. Sorry about multiple posts, kept forgetting things.

tags: added: latest-bios-405
removed: bios-outdated-405

Phill, thank you for updating the BIOS, and checking against another hardware platform. BIOS updates are requested, both to rule out fault of outdated and buggy BIOS, and collateral damage avoidance.

>"If you like I could boot 12.04 to re-confirm it's a regression and try 12.10 to help narrow it down?"

That would be very helpful. Could you please re-test Precise and Quantal and advise on the results via http://releases.ubuntu.com/ ?

>"I don't understand what "Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful" means."

This was put into my request statement because too many folks who didn't read carefully/understand would just post the information on the old BIOS, and I would have to send another follow e-mail advising on this.

>"Thanks for looking into it. Sorry about multiple posts, kept forgetting things."

Thank you for your patience and understanding.

tags: added: kernel-bug-exists-upstream-v3.10-rc1
removed: kernel-bug-exists-upstream
Phill (phill.l) wrote :

I can confirm that the device works perfectly on 12.10 (live usb).

Sorry for the delay, I thought I'd updated this. Just re-ran the test to be sure too.

Phill, thank you for testing Quantal. Could you please test Trusty, and advise if this is still reproducible via http://cdimage.ubuntu.com/daily-live/current/ ?

Phill (phill.l) wrote :

Just tried Trusty.

The pen seemed to work as it does in other version (including the rocker button on the pen - thought I'd clarify as I don't think I have before, it's only the buttons on the pad that don't work).

Touch movement appears to have improved, but it's still not as good as the precision that I used to get or what you'd expect on a touch pad - it's not jumping 10-20 pixels like in previous versions but you don't get that pixel precision you'd normally get by rolling your finger slightly.

The on-pad buttons still don't work, however, I noticed that they did work on the start-up screen of the live USB when choosing between Try Ubuntu and Install Ubuntu (or whatever those options are), but when you click Try Ubuntu and get the normal desktop the buttons stop working.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Phill (phill.l) wrote :

This bug is fixed in the 3.17 upstream kernel.

I installed the latest upstream kernel to check on another issue, but gave this a try at the same time and it works fine.

Wasn't sure if I should change the tags as it already had an upstream related tag on there.

I used http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-rc1-utopic/

Phill, the next step is to fully reverse commit bisect the kernel in order to identify the fix commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Phill (phill.l) wrote :
Download full text (3.2 KiB)

I hope I've done this right as it's taken ages.
Of the re-built kernels I narrowed it down to 3.16.3 which didn't work and 3.17-rc1 which worked.

Here's the git bisect log, good and bad being reversed as in the instructions. The final commit has working buttons, however, on many of the builds between 3.16 and 3.17-rc1 the desktop failed to show, but it was still possible to test the buttons working. , On some the tablet didn't work at all, but I just marked these as 'good' (meaning bad) and continued. This is the case for the winning commit at the end.

# good: [19583ca584d6f574384e17fe7613dfaeadcdc4a6] Linux 3.16
git bisect good 19583ca584d6f574384e17fe7613dfaeadcdc4a6
# bad: [7d1311b93e58ed55f3a31cc8f94c4b8fe988a2b9] Linux 3.17-rc1
git bisect bad 7d1311b93e58ed55f3a31cc8f94c4b8fe988a2b9
# good: [ae045e2455429c418a418a3376301a9e5753a0a8] Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net-next
git bisect good ae045e2455429c418a418a3376301a9e5753a0a8
# good: [44c916d58b9ef1f2c4aec2def57fa8289c716a60] Merge tag 'cleanup-for-3.17' of git://git.kernel.org/pub/scm/linux/kernel/git/arm/arm-soc
git bisect good 44c916d58b9ef1f2c4aec2def57fa8289c716a60
# bad: [023f78b02c729070116fa3a7ebd4107a032d3f5c] Merge branch 'for-next' of git://git.samba.org/sfrench/cifs-2.6
git bisect bad 023f78b02c729070116fa3a7ebd4107a032d3f5c
# good: [d4e1f5a14e17d4f0e8034c0967511884bcb12fba] Merge tag 'dt-for-3.17' of git://git.kernel.org/pub/scm/linux/kernel/git/arm/arm-soc
git bisect good d4e1f5a14e17d4f0e8034c0967511884bcb12fba
# good: [8065be8d032f38da25b54bf077a05a30d9ce9f2a] Merge branch 'akpm' (second patchbomb from Andrew Morton)
git bisect good 8065be8d032f38da25b54bf077a05a30d9ce9f2a
# bad: [9e9ac896667a55ae9a3df119611ee5322abe2890] Merge tag 'fbdev-3.17' of git://git.kernel.org/pub/scm/linux/kernel/git/tomba/linux
git bisect bad 9e9ac896667a55ae9a3df119611ee5322abe2890
# bad: [fc8104bc5a3f6f49d79f45f2706f79f77a9fb2ae] Merge branch 'wacom' into next
git bisect bad fc8104bc5a3f6f49d79f45f2706f79f77a9fb2ae
# good: [f048615efc34035e217af148ebdde8ce6efd8af9] ARM: dts: am437x-gp-evm: Update binding for touchscreen size
git bisect good f048615efc34035e217af148ebdde8ce6efd8af9
# good: [471d17148c8b4174ac5f5283a73316d12c4379bc] Input: wacom - move the USB (now hid) Wacom driver in drivers/hid
git bisect good 471d17148c8b4174ac5f5283a73316d12c4379bc
# good: [1c3c52354046bae6d2b596d3ae9ff67be4e78250] Input: wacom - add copyright note and bump version to 2.0
git bisect good 1c3c52354046bae6d2b596d3ae9ff67be4e78250
# good: [4b080e3b2fda181817059dde10622e7cb4f85b02] Input: jornada720_ts - switch to using managed resources
git bisect good 4b080e3b2fda181817059dde10622e7cb4f85b02
# good: [62238f3aadc9bc56da70100e19ec61b9f8d72a5f] Input: hyperv-keyboard - register as a wakeup source
git bisect good 62238f3aadc9bc56da70100e19ec61b9f8d72a5f
# bad: [f2e0a7d4a0b94b4274e3b7e15bf650d45a866f3c] Input: wacom - only register once the MODULE_* macros
git bisect bad f2e0a7d4a0b94b4274e3b7e15bf650d45a866f3c
# bad: [7403a6a448c3ed96221bb46c9da75254fd87b520] Input: HID - remove hid-wacom Bluetooth driver
git bisect bad 7403a6a448c3ed96221bb46c9da75254fd87b520
# first bad commit: [7...

Read more...

tags: added: cherry-pick reverse-bisect-done
tags: added: trusty
Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: kernel-fixed-upstream kernel-fixed-upstream-3.17-rc1
removed: kernel-bug-exists-upstream-v3.10-rc1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers