OmniVision Webcam not being detected

Bug #1180409 reported by Mike Hayes on 2013-05-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury

Bug Description

Webcam on my dell monitor is not detected.
Problem is identical to Bug #1168430

This is a fresh install of Ubuntu 13.04 and camera never worked.

[ 2.374452] uvcvideo: Found UVC 1.00 device Monitor Webcam (SP2208WFP) (05a9:2643)
[ 2.374626] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[ 2.375008] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
[ 2.375064] uvcvideo: Failed to initialize the device (-5).
[ 2.375103] usbcore: registered new interface driver uvcvideo

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-19-generic 3.8.0-19.30
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: tony 2074 F.... pulseaudio
 /dev/snd/controlC0: tony 2074 F.... pulseaudio
 /dev/snd/controlC1: tony 2074 F.... pulseaudio
Date: Wed May 15 10:26:53 2013
HibernationDevice: RESUME=UUID=162511de-dddb-4375-83b9-b38ee3bc9fa2
InstallationDate: Installed on 2013-05-07 (8 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Alienware Alienware X51
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=304b74f8-a5bb-4d2b-acfa-91a1137c197c ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-19-generic N/A
 linux-backports-modules-3.8.0-19-generic N/A
 linux-firmware 1.106
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:
 May 15 08:07:07 K7 wpa_supplicant[1033]: wlan0: WPA: Group rekeying completed with 00:0f:66:b0:ea:a4 [GTK=TKIP]
 May 15 09:07:09 K7 wpa_supplicant[1033]: wlan0: WPA: Group rekeying completed with 00:0f:66:b0:ea:a4 [GTK=TKIP]
 May 15 09:24:52 K7 kernel: [ 6696.541168] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 May 15 10:07:05 K7 wpa_supplicant[1033]: wlan0: WPA: Group rekeying completed with 00:0f:66:b0:ea:a4 [GTK=TKIP]
dmi.bios.date: 12/27/2012
dmi.bios.vendor: Alienware
dmi.bios.version: A11
dmi.board.name: 06G6JW
dmi.board.vendor: Alienware
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Alienware
dmi.chassis.version: 00
dmi.modalias: dmi:bvnAlienware:bvrA11:bd12/27/2012:svnAlienware:pnAlienwareX51:pvr00:rvnAlienware:rn06G6JW:rvrA00:cvnAlienware:ct3:cvr00:
dmi.product.name: Alienware X51
dmi.product.version: 00
dmi.sys.vendor: Alienware

Mike Hayes (mhnj77) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this camera work with prior releases?

Joseph Salisbury (jsalisbury) wrote :

I'll create a patch and build a test kernel with a quirk for idProduct=2643

Changed in linux (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Confirmed → In Progress
Joseph Salisbury (jsalisbury) wrote :

I created a test kernel with a quirk for idProduct=2643. The kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1180409/

This is the mainline kernel that has been patched, so the patch can be sent upstream if it fixes this bug.

Can you test this kernel and post back if it resolves this bug?

Thanks in advance!

Mike Hayes (mhnj77) wrote :

I can't comment on prior releases as this is the first time I've used this monitor with Ubuntu.

The patch has resolved the issue and I used cheese to confirm it's working.

dmesg | grep uvc
[ 3.508962] uvcvideo: Found UVC 1.00 device Monitor Webcam (SP2208WFP) (05a9:2643)
[ 3.509641] usbcore: registered new interface driver uvcvideo

Mike Hayes (mhnj77) wrote :

Oh....and thanks for such promt action on this bug.
I'm very impressed with the Ubuntu team.

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing, Mike. I'll send this patch upstream and a SRU request for inclusion in Raring.

Thanks again

Joseph Salisbury (jsalisbury) wrote :

Hi Mike,

The upstream maintainer would like some additional information from your system. Can you run the following command and post the ouput?

sudo lsusb -v -d 05a9:2643

Thanks in advance!

Mike Hayes (mhnj77) wrote :
Download full text (29.4 KiB)

sudo lsusb -v -d 05a9:2643

Bus 001 Device 007: ID 05a9:2643 OmniVision Technologies, Inc. Monitor Webcam
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 239 Miscellaneous Device
  bDeviceSubClass 2 ?
  bDeviceProtocol 1 Interface Association
  bMaxPacketSize0 64
  idVendor 0x05a9 OmniVision Technologies, Inc.
  idProduct 0x2643 Monitor Webcam
  bcdDevice 1.00
  iManufacturer 1
  iProduct 2
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 1051
    bNumInterfaces 4
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0x80
      (Bus Powered)
    MaxPower 500mA
    Interface Association:
      bLength 8
      bDescriptorType 11
      bFirstInterface 0
      bInterfaceCount 2
      bFunctionClass 14 Video
      bFunctionSubClass 3 Video Interface Collection
      bFunctionProtocol 0
      iFunction 2 Monitor Webcam (SP2208WFP)
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 14 Video
      bInterfaceSubClass 1 Video Control
      bInterfaceProtocol 0
      iInterface 2 Monitor Webcam (SP2208WFP)
      VideoControl Interface Descriptor:
        bLength 13
        bDescriptorType 36
        bDescriptorSubtype 1 (HEADER)
        bcdUVC 1.00
        wTotalLength 109
        dwClockFrequency 30.000000MHz
        bInCollection 1
        baInterfaceNr( 0) 1
      VideoControl Interface Descriptor:
        bLength 17
        bDescriptorType 36
        bDescriptorSubtype 2 (INPUT_TERMINAL)
        bTerminalID 1
        wTerminalType 0x0201 Camera Sensor
        bAssocTerminal 0
        iTerminal 0
        wObjectiveFocalLengthMin 0
        wObjectiveFocalLengthMax 0
        wOcularFocalLength 0
        bControlSize 2
        bmControls 0x00000a00
          Zoom (Absolute)
          PanTilt (Absolute)
      VideoControl Interface Descriptor:
        bLength 9
        bDescriptorType 36
        bDescriptorSubtype 3 (OUTPUT_TERMINAL)
        bTerminalID 3
        wTerminalType 0x0101 USB Streaming
        bAssocTerminal 0
        bSourceID 5
        iTerminal 0
      VideoControl Interface Descriptor:
        bLength 7
        bDescriptorType 36
        bDescriptorSubtype 4 (SELECTOR_UNIT)
        bUnitID 4
        bNrInPins 1
        baSource( 0) 1
        iSelector 0
      VideoControl Interface Descriptor:
        bLen...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.9.0-2.7

---------------
linux (3.9.0-2.7) saucy; urgency=low

  [ Joseph Salisbury ]

  * SAUCE: uvcvideo: quirk PROBE_DEF for Alienware X51 OmniVision webcam
    - LP: #1180409

  [ Tim Gardner ]

  * rebase to v3.9.3
 -- Tim Gardner <email address hidden> Thu, 16 May 2013 14:11:56 -0400

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Mike Hayes (mhnj77) wrote :

I have confirmed the webcam works fine with the kernel in proposed.

tags: added: verification-done-raring
removed: verification-needed-raring

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers