Raring update to 3.8.13 stable release

Bug #1179514 reported by Steve Conklin on 2013-05-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.8.13 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.8.13 stable release:

* Linux 3.8.13
* x86/mm: account for PGDIR_SIZE alignment
* kernel/audit_tree.c: tree will leak memory when failure occurs in audit_trim_trees()
* NFSv4.x: Fix handling of partially delegated locks
* EDAC: Don't give write permission to read-only files
* Btrfs: fix extent logging with O_DIRECT into prealloc
* Btrfs: compare relevant parts of delayed tree refs
* tracing: Fix ftrace_dump()
* drm/radeon: fix handling of v6 power tables
* drm/radeon: add new richland pci ids
* drm/radeon: fix possible segfault when parsing pm tables
* drm/radeon: fix endian bugs in atom_allocate_fb_scratch()
* drm/radeon: disable the crtcs in mc_stop (r5xx-r7xx) (v2)
* drm/radeon: Always flush the VM
* drm/radeon: fix typo in si_select_se_sh()
* drm/radeon: fix hdmi mode enable on RS600/RS690/RS740
* drm/radeon: cleanup properly if mmio mapping fails
* drm/radeon/evergreen+: don't enable HPD interrupts on eDP/LVDS
* drm/radeon: add some new SI PCI ids
* drm/radeon: disable the crtcs in mc_stop (evergreen+) (v2)
* drm/radeon: update wait_for_vblank for r1xx-r4xx
* drm/radeon: properly lock disp in mc_stop/resume for r5xx-r7xx
* drm/radeon: properly lock disp in mc_stop/resume for evergreen+
* drm/radeon: update wait_for_vblank for evergreen+
* drm/radeon: update wait_for_vblank for r5xx-r7xx
* drm/radeon/dce6: add missing display reg for tiling setup
* drm/radeon: fix typo in rv515_mc_resume()
* drm/radeon: use frac fb div on RS780/RS880
* drm/radeon: don't use get_engine_clock() on APUs
* drm/i915: Fall back to bit banging mode for DVO transmitter detection
* drm/i915: Fixup Oops in the pipe config computation
* drm/i915: ensure single initialization and cleanup of backlight device
* drm/i915: set CPT FDI RX polarity bits based on VBT
* drm/i915: Use MLC (l3$) for context objects
* drm/i915: Workaround incoherence between fences and LLC across multiple CPUs
* drm/i915: Fix SDVO connector and encoder get_hw_state functions
* drm/i915: Add no-lvds quirk for Fujitsu Esprimo Q900
* drm/i915: Fix sdvo connector get_hw_state function
* drm/i915: Fix detection of base of stolen memory
* drm/ast: deal with bo reserve fail in dirty update path
* drm/prime: keep a reference from the handle to exported dma-buf (v6)
* drm/gma500: fix backlight hotkeys behaviour on netbooks
* drm/mgag200: deal with bo reserve fail in dirty update path
* drm/cirrus: deal with bo reserve fail in dirty update path
* block: fix max discard sectors limit
* arm64: Ignore the 'write' ESR flag on cache maintenance faults
* RDMA/cxgb4: Fix SQ allocation when on-chip SQ is disabled
* r8169: fix 8168evl frame padding.
* ext4: add check for inodes_count overflow in new resize ioctl
* netfilter: ip6t_NPT: Fix translation for non-multiple of 32 prefix lengths
* netfilter: xt_rpfilter: skip locally generated broadcast/multicast, too
* netfilter: ctnetlink: don't permit ct creation with random tuple
* netfilter: nf_ct_helper: don't discard helper if it is actually the same
* netfilter: ipset: "Directory not empty" error message
* netfilter: nf_ct_sip: don't drop packets with offsets pointing outside the packet
* netfilter: ipset: list:set: fix reference counter update
* netfilter: nf_nat: fix race when unloading protocol modules
* ipvs: ip_vs_sip_fill_param() BUG: bad check of return value
* xhci: Don't warn on empty ring for suspended devices.
* e1000e: fix accessing to suspended device
* e1000e: fix runtime power management transitions
* PCI/PM: Clear state_saved during suspend
* perf/x86/intel/lbr: Demand proper privileges for PERF_SAMPLE_BRANCH_KERNEL
* perf/x86/intel/lbr: Fix LBR filter
* perf/x86/intel: Fix unintended variable name reuse
* perf/x86/intel: Add support for IvyBridge model 58 Uncore
* net/eth/ibmveth: Fixup retrieval of MAC address
* iommu/amd: Properly initialize irq-table lock
* hugetlbfs: fix mmap failure in unaligned size request
* autofs - remove autofs dentry mount check
* pwm: spear: Fix checking return value of clk_enable() and clk_prepare()
* powerpc: fix numa distance for form0 device tree
* powerpc: Emulate non privileged DSCR read and write
* xen/arm: actually pass a non-NULL percpu pointer to request_percpu_irq

Steve Conklin (sconklin) on 2013-05-13
tags: added: kernel-stable-tracking-bug
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Raring):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg) on 2013-05-22
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers