My Dell Dimension desktop shows purple/green and distorted Flash video unless acceleration method is changed

Bug #1178982 reported by LaunchpadAccount on 2013-05-11
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

1. Lubuntu 13.04 / Linux 3.8.0.-19-generic
2. I do not know and can not check as the computer in question is no longer in my possession

Flash does not play movies properly, resulting in a purple/green screen that is completely out of proportion.

Happens mainly on Dell Dimension computers with an Intel chipset:
http://ubuntuforums.org/showthread.php?t=2132368&p=12641898#post12641898

One user reported falling back to an older Kernel as a workaround

"I did find the following workaround. When booting, I choose the Advanced Ubuntu options and pick either Linux 3.5.0-27-generic or Linux 3.2.0-40-generic. With either, the video/flash is fine. The default kernel is Linux 3.8.0-19-generic, and that is the version where it does not work"

LaunchpadAccount (unfo) wrote :

User reported a work-around:

Edit (or create) /etc/X11/xorg.conf as follows: (ugh, can't format, should be a tab before each line except the first and the last).

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

Restart X (reboot, restart your display manager, whatever). Colors are back to the way they used to be and flash works.

LaunchpadAccount (unfo) on 2013-05-18
affects: gvfs (Ubuntu) → linux (Ubuntu)
summary: - Flash plug-in displays Purple / green and malformed screen in Firefox
- (Lubunt 13.04)
+ Flash on Dell Inspiron-series with Intel integrated graphics causes
+ purple/green and distorted image unless acceleration method is changed
LaunchpadAccount (unfo) on 2013-05-18
summary: - Flash on Dell Inspiron-series with Intel integrated graphics causes
+ Flash on Dell Dimension-series with Intel integrated graphics causes
purple/green and distorted image unless acceleration method is changed

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1178982

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal

ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gecko 1154 F.... lxpanel
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=30891768-9369-462d-9322-89fb3f9d95a7
InstallationDate: Installed on 2013-05-19 (0 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release i386 (20130423.1)
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=6f30cd7c-0385-44a2-be2b-8264cf319dce ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-19-generic N/A
 linux-backports-modules-3.8.0-19-generic N/A
 linux-firmware 1.106
RfKill:

StagingDrivers: r8712u
Tags: raring staging
Uname: Linux 3.8.0-19-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/05/2002
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: i845G-W83627HF
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd12/05/2002:svn:pn:pvr:rvn:rni845G-W83627HF:rvr:cvn:ct3:cvr:

tags: added: apport-collected raring staging

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Had the same issue, workaround above fixed it. I've submitted my own apport info.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.10 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc2-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Kevin (kvn-brn) wrote :

Added tag kernel-bug-exists-upstream. Issue present under 3.10:
$ uname -a
Linux xyz 3.10.0-031000rc2-generic #201305201835 SMP Mon May 20 22:42:48 UTC 2013 i686 i686 i686 GNU/Linux

tags: added: kernel-bug-exists-upstream
LaunchpadAccount (unfo) on 2013-05-24
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

bug affects me too.

Lubuntu 13.04 32 bits with fake-pae:
https://help.ubuntu.com/community/Lubuntu-fake-PAE

kernel: 3.8.0-23-generic
adobe flash version: 11.2 r202

bug affects firefox 21 and chromium-browser 25.

workaround from comment #1 worked for me. tks!

graphics: intel 82852/855GM Integrated Graphics Device

output from sudo lshw
: Display controller
             produto: 82852/855GM Integrated Graphics Device
             fabricante: Intel Corporation
             ID físico: 2.1
             informações do barramento: pci@0000:00:02.1
             versão: 02
             largura: 32 bits
             clock: 33MHz
             capacidades: pm bus_master cap_list
             configuração: latency=0
             recursos: memória:e8000000-efffffff memória:faf00000-faf7ffff

cheers,
iberê

ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ibere 2002 F.... pulseaudio
CRDA: Error: [Errno 2] Arquivo ou diretório não encontrado
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=b79e6531-bda4-4f27-b4a5-c07f9a3c1718
InstallationDate: Installed on 2013-05-31 (1 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release i386 (20130423.1)
Lsusb:
 Bus 003 Device 002: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. Latitude D505
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-23-generic root=UUID=2447e4c9-b05b-462c-9be7-8b678288452b ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-23.34-generic 3.8.11
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-23-generic N/A
 linux-backports-modules-3.8.0-23-generic N/A
 linux-firmware 1.106
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: raring
Uname: Linux 3.8.0-23-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin netdev plugdev sambashare sudo video
dmi.bios.date: 02/17/2004
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0H2049
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd02/17/2004:svnDellInc.:pnLatitudeD505:pvr:rvnDellInc.:rn0H2049:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D505
dmi.sys.vendor: Dell Inc.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Tim, this bug report is being closed due to your Bug Description noting you don't have possession of the hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Jackflap / Kevin / ibere fernandes, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

tags: removed: 13.04 apport-collected firefox flash kernel-bug-exists-upstream quantal staging
summary: - Flash on Dell Dimension-series with Intel integrated graphics causes
- purple/green and distorted image unless acceleration method is changed
+ My Dell Dimension desktop shows purple/green and distorted Flash video
+ unless acceleration method is changed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
UlfZibis (ulf-zibis) wrote :

My Computer is:
Lenovo Thinkpad T500 with Intel GMA 4500MHD.
xxx:~$ lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
 Subsystem: Lenovo Device [17aa:20e4]
 Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
 Subsystem: Lenovo Device [17aa:20e4]
00:03.0 Communication controller [0780]: Intel Corporation Mobile 4 Series Chipset MEI Controller [8086:2a44] (rev 07)

I see the distortion in Mozilla Thunderbird and also Forefox, see attached screen shot

The workaround from comment 1 seems to help, but I should test for some more days.

UlfZibis (ulf-zibis) wrote :

I want to add 2 things:
1.) the file /etc/X11/xorg.conf was not existent on my system, I had to create it new. Is that correct?

2.) xxx:~$ sudo lshw | grep "VGA\|Display" -A10
             Beschreibung: VGA compatible controller
             Produkt: Mobile 4 Series Chipset Integrated Graphics Controller
             Hersteller: Intel Corporation
             Physische ID: 2
             Bus-Informationen: pci@0000:00:02.0
             Version: 07
             Breite: 64 bits
             Takt: 33MHz
             Fähigkeiten: msi pm vga_controller bus_master cap_list rom
             Konfiguration: driver=i915 latency=0
             Ressourcen: irq:49 memory:f4400000-f47fffff memory:d0000000-dfffffff ioport:1800(Größe=8)
--
             Beschreibung: Display controller
             Produkt: Mobile 4 Series Chipset Integrated Graphics Controller
             Hersteller: Intel Corporation
             Physische ID: 2.1
             Bus-Informationen: pci@0000:00:02.1
             Version: 07
             Breite: 64 bits
             Takt: 33MHz
             Fähigkeiten: pm bus_master cap_list
             Konfiguration: latency=0
             Ressourcen: memory:f4200000-f42fffff

UlfZibis, as per the top of this report, it is Status Invalid, and considered closed. For more on this, please see https://wiki.ubuntu.com/Bugs/Status .

If you want an issue solved in Ubuntu, please file a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Changed in linux (Ubuntu):
importance: Medium → Undecided
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers