Ubuntu

amd64: "Fixing recursive fault but reboot is needed!"

Reported by Alexander Röhnsch on 2013-05-06
82
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After the completed Raring Ringtail amd64 installation every boot ends in the following statement "Fixing recursive fault but reboot is needed!". No terminal, no gui, no logs at this point. Others say they can boot after about 10 tries every time, but I can not. Maybe someone can provide logs from a successful boot, but mine are all empty. I attach lscpu, lshw and lspci output acquired from the Raring Ringtail amd64 live CD. The live mode works fine, the problem arises upon installation.

I can not boot the Raring installation at all.

Several people experiencing this bug, including me, reported it over at bug #1066435, but I was told that, although both bugs share the same behaviour, they probably originate from different problems. Also, bug #1175660 has a similar error message, but seems able to boot properly.

Alexander Röhnsch (roehnsch) wrote :
Alexander Röhnsch (roehnsch) wrote :
Alexander Röhnsch (roehnsch) wrote :
tags: added: amd64 raring

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1177086

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
description: updated
description: updated
Alexander Röhnsch (roehnsch) wrote :

Logs not available at this point. I searched in the partition's /var/log for any usable information, but found none.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
antoine (antoine-) wrote :

The same problem on my amd64 system.

chisao (michayc) wrote :

I also had this bug. I tried a few things and what worked was to boot at first with acpi=off and nomodeset. Then I rebooted but this time only with acpi=off. Unity was REALLY slow because I had no 3d acceleration. Then I rebooted with no options and everything was OK (nouveau driver in use). When I managed to boot for the first time (and the second) I couldn't connect with my wireless so I switched my dlink usb receiver with a cisco one. I m just telling you this because I don't know if switching the dongles had anything to do with it (power management or something). Everything else failed for me at the beginning. Hope this helps out someone...

Alexander Röhnsch (roehnsch) wrote :

I was not able to test the kernel on Raring directly. The Raring boot dies early, and I therefore can not install a new kernel. I tried UCK to build a Raring live cd with the suggested 3.9 kernel, following directions from [1]. But the resulting image would not boot.

However, I installed the current daily saucy build [2]. Comes with this kernel:

Linux ubuntu 3.9.0-0-generic #4-Ubuntu SMP Thu May 2 21:43:59 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Installing that build fixed the problem. I seem to be able to boot properly now. I'm therefore adding tag 'kernel-fixed-upstream' and mark the bug as 'Confirmed'.

[1] http://ubuntuforums.org/showthread.php?t=1951153
[2] http://cdimage.ubuntu.com/daily-live/20130510/

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
The Bright Side (me-knowingme) wrote :

Affected as well. I installed Ubuntu 13.04 64-bit yesterday night on my self-assembled desktop PC and have seen the issue a few times since. I would say in 80% of all attempts, Ubuntu 13.04 boots fine for me.

It seems like it usually happens the first time after I turn on my PC, but not when I reboot from within Ubuntu. When I reboot from my Windows partition, the issue occurs as well.

I will keep an eye on it and report on any other patterns I see.

I am running Ubuntu with the proprietary NVidia graphics drivers and heard they could be involved in the issue, so I will look for a way to safely remove them completely and revert to Nouveau.

I will also attach the outputs of lspci, lscpu and lshw later tonight.

Florian W. (florian-will) wrote :

I've upgraded from Quantal to Raring on release day and have encountered this issue on 3 occasions since then (booted at least once a day, so it fails ~15% of the time). Rebooting after the error message is shown works fine for me. It never happened on Quantal or earlier.

My desktop PC is self-assembled as well, but my GPU is made by AMD, and I have fglrx installed.

See attachment for ls{cpu,hw,pci} output.

Patrick Then (patrickthen) wrote :

I have the same issue in Linux Mint (obviously as it's using the same Kernel as Raring).
AMD Phenom II x4 965 CPU - so far all the people affected seem to have AMD CPUs?

antoine (antoine-) wrote :

I have also an AMD CPU
AMD Phenom(tm) II X4 955 Processor

Yuri Bardashev (bardashev) wrote :

same problem in 13.04 x64, success boot only in 30%. In 11.10 all ok.
AMD X2 5000+, GA-MA-770-DS3, nVidia GT220.

Luis Henriques (henrix) wrote :

Any chances of getting the complete logs for this bug? Please follow the instructions described in comment #4 (at least a dmesg would be useful). Also, does this occur with the latest kernel?

Alexander Röhnsch (roehnsch) wrote :

Could anyone capable of occasionally booting please provide the dmesg output? Even better, run 'apport-collect 1177086' ?

@Luis: When I reinstall Ubuntu, does it download the latest kernel during installation? It doesn't boot at all for me, therefore I cannot run the updater. I could and would, however, reinstall.

Albert Pool (albertpool) wrote :

I have just helped somebody in the Linux Mint chat with this problem.
Mara's reply here suggested it could be a driver problem: https://www.linuxquestions.org/questions/programming-9/fixing-recursive-fault-but-reboot-is-needed-601372/
So I told the person to upgrade his NVIDIA driver to nvidia-313-updates (313.30) from the Raring repository (he was on 310 from the repository) and that fixed it for him. But I see many of you aren't running the NVIDIA driver so this isn't a fix for everybody.

Karol F. (monsieurfop) wrote :

Good evening everyone.

I've been fighting with this problem for a week now, and about two minutes ago I've managed to successfully log into my Ubuntu 12.04!

First I thought I'd show you all how my boot process looked like and made a video of a boot with parameter "delay_boot" and then normal boot: http://www.youtube.com/watch?v=SdHR1XP0EKU&feature=youtu.be

Then I managed to read Luis' comment #18 and tried to update my kernel:
1. get onto a live CD version of ubuntu
2. use this tutorial to mount your ubuntu partition: http://askubuntu.com/questions/87273/have-installed-ubuntu-but-when-i-restart-computer-it-only-goes-to-grub-ubun

My mounting commands:
sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo mount --bind /dev/pts /mnt/dev/pts
sudo chroot /mnt

2. then do this: http://linuxg.net/how-to-install-3-9-kernel-on-ubuntu-13-04-12-10-12-04-and-linux-mint-15-14-13/
CAUTION: do not write "sudo" before the last two commands, it isn't necessary.
You have to have the internet connection, or copy the files onto your partition while having it mounted.

After updating my kernel to 3.9.0 everything went fine! If you need any advice, just write me a message and I'll try and help you make the workaround work.

Hope my video of a failed boot helps you. Do you need my apport-collect 1177086 from a successfull boot after updating kernel?

Alexander Röhnsch (roehnsch) wrote :

Yes, please apport-collect.

Alexander Röhnsch, did you need a backport to a release prior to Saucy or may we close this as Status Invalid?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Christopher, I decided to skip Raring and try again when Saucy is
released, because Raring did not work at all for me. Therefore, I do not
need a backport. But I can not speak for others.

Apparently there are quite a few who can use Raring. But they need to
annoyingly boot it several times before success. They would certainly
benefit from a backport.

Are there resources for doing a backport anyway? Out of interest, would
the whole saucy kernel be backported?

Am 21.07.2013 19:00, schrieb Christopher M. Penalver:
> Alexander Röhnsch, did you need a backport to a release prior to Saucy
> or may we close this as Status Invalid?
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>

Alexander Röhnsch, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1177086/comments/24 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. As well, information on backporting may be found at https://wiki.ubuntu.com/StableReleaseUpdates . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

antoine / chisao / The Bright Side / Florian W. / Patrick Then / Yuri Bardashev / Karol F., if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions