Ubuntu 13.04 can detect wi-fi but can't connect

Bug #1173759 reported by AJT Santos on 2013-04-27
198
This bug affects 43 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

HP Pavilion laptop with Ralink RT5390 wireless interface

1. Can detect home wi-fi signal but can't connect. Keeps asking for password then "disconnects" over and over again.

2. All other computers, tablets, and smartphones at home can connect to the wi-fi without any trouble at all.

3. HP Pavilion laptop can connect to the internet if tethered to my smartphone (used as a portable wi-fi hotspot).

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1173759/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Roman Kouzmenko (roman-kouzma) wrote :

Installing a 3.9 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc8-raring/ solves the problem for me.

robkeeney (robkeeney) wrote :

RAlink RT5390 Wireless 802.11n 1T/1R PCIe in a Compaq Presario CQ56. It had Windows 7 on it orginally. The wireless worked fine. I installed Kubuntu 12.10 amd64 and it still worked fine. The OS offered to upgrade to 13.04 and I let it. That's when the wireless quit working right.

It connects fine if the computer is within 2 or 3 feet of the wireless router. Any further than that and it loses the connection. It can see the network but won't get an IP address.

robkeeney (robkeeney) wrote :

That's with kernel 3.8.0.19.35

Aaron (aaronuk5) wrote :

Yes I can also confirm this, (ASUS X54c) Ralink 5390

also
Ubuntu 13.04 , Kernel 3.8.0-19

Drivers that came with linux-firmware does not connect with AP but driver is there.

I've tried the offical drivers http://www.mediatek.com/_en/07_downl...il.php?sn=5001 , but I get build error and is unable to continue.

Ndiswrapper 1.58 from http://sourceforge.net/projects/ndiswrapper/ , module loads but I get a "loadndisdriver: load_driver(364): couldn't load driver netr28x." error

compate-wireless gives me the same build error as the official driver,

Demersus (demersus) wrote :

Same problems here. HP m6-1225dx with ralink rt5390 installed.

I tried using kernel 3.9. Still the same problems. Also: The wifi disable/enable button does not work.

The only way I can get it to work reliably is to use the 3.5 kernel that came with ubuntu 12.10. It works fine with this kernel, and so does the wifi disable/enable button. Weird. Aren't new kernels supposed to improve, not degrade existing functionality?

Demersus (demersus) wrote :

Same problems here. HP m6-1225dx with ralink rt5390 installed.

I tried using kernel 3.9. Still the same problems. Also: The wifi disable/enable button does not work.

The only way I can get it to work reliably is to use the 3.5 kernel that came with ubuntu 12.10. It works fine with this kernel, and so does the wifi disable/enable button. Weird. Aren't new kernels supposed to improve, not degrade existing functionality?

thatismatt (thatismatt) wrote :

Same problem here, on a HP dm1 with Ralink RT5390.

Let me know if there are other details that would be useful.

Aaron (aaronuk5) wrote :

Possible fix that worked for me. http://packages.debian.org/search?keywords=firmware-ralink

I installed the experimental (rc-buggy)
I get same signal strenght but I manage to connect to a WPA/WPA2 connection

Aaron (aaronuk5) wrote :

This bug is comming from package Linux-Firmware 1.106 https://launchpad.net/ubuntu/+source/linux-firmware

Aaron workaround worked for me ( https://bugs.launchpad.net/ubuntu/+bug/1173759/comments/11 ).

I had to force overwriting of the he linux-Firmware 1.106 package :
sudo dpkg --force overwrite -i firmware-ralink_0.37_all.deb

Aaron (aaronuk5) wrote :

Ralink linux driver fix - (stronger signal and faster connection)

1. download driver http://www.mediatek.com/_en/07_downl...il.php?sn=5001
2 tar -xvf /home/ukbeast/USERNAME/Downloads/2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_v2. bz2.bz2
3 cd 2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO
4 download patch http://gridlox.net/diff/rt5592sta_fix_64bit_3.8.patch
5 patch -p1 <rt5592sta_fix_64bit_3.8.patch (if asks for directory point it to pci_main_dev.c)
6 make sure /os/linux/config.mk reads HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
7 make
8 sudo make install
9 modprobe rt5390sta

Demersus (demersus) wrote :

The link included for the MediaTek/RaLink download is broken. If you search their site for the linux driver, the file they provide is some kind of binary file. I can't make heads or tails of it.

Aaron (aaronuk5) wrote :

I applogise,

link is www.ralinktech.com , then click download drivers and look for linux on left hand side

Demersus (demersus) wrote :

Installing the rc-buggy package from: http://packages.debian.org/search?keywords=firmware-ralink fixed the instability issues for me. (dropped connection, asking for password repeatedly).

However, It did not fix my issue with the wif enable/disable button. I cannot use the button to turn the wifi on or off. It's one of those function key buttons. -- It all works fine, if I use the 3.5 kernel from Ubuntu 12.10 though.

markofealing (mark-ferns16) wrote :

Just downloaded kernel update 3.8.0-19-generic from the Ubuntu repository and installed on Kubuntu 13.04.

This seems to have fixed my Ralink RT5390 wireless connection issues.

Jason Smith (marinecomm) wrote :

When I issue the command "make" from post #14, I get three error messages. They just say ERROR 1 and ERROR 2.

Post #17 - I don't see an rc-buggy package when I click on that link.

How do I install a different kernel or kernel update?

Stephen Helfen (steve-helfen) wrote :

Same problem. HP Pavilion dv6t-7000 running 13.04 Wifi may connect or may not depending on the router and (I believe) whether the wireless signal is g or n. Running kernel 3.8.0-23-generic and no joy. Connections obtained drop frequently.

- Device: wlan1 ----------------------------------------------------------------
  Type: 802.11 WiFi
  Driver: rt2800pci
  State: disconnected
  Default: no
  HW Address: 1C:3E:84:9B:FD:C0

  Capabilities:

  Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

  Wireless Access Points
    XXXXXXX: Infra, 00:06:B1:12:9C:6A, Freq 2412 MHz, Rate 54 Mb/s, Strength 39 WPA WPA2
    XXXXXXX: Infra, 00:13:19:CF:DF:00, Freq 2447 MHz, Rate 54 Mb/s, Strength 29 WPA
    XXXXXXX: Infra, 00:06:B1:18:ED:59, Freq 2462 MHz, Rate 54 Mb/s, Strength 22 WPA WPA2

If I follow the procedure in #14, I can build the driver, but when I

sudo modprobe -r rt2800pci

my connection goes down as expected. I then

modprobe rt5390sta

and I get nothing...wireless does not even come up.

I also have the problem with the wifi enable/disable button. I cannot use the button to turn the wifi on or off. It's one of those function key buttons (F12).

ndefontenay (n-de-fontenay) wrote :

I'm experiencing the same problem on my Dell Inspiron One all-in-one PC.
My chipset is broadcom BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

I can see the connections, but it's not accepting any passwords.

Jean-Marie Comets (jm-comets) wrote :

I also have the same problem on my Asus X301A laptop. I solution on post #14 and after restarting it seems to have worked.
I did have to run make as superuser and install the linux headers though.

Wifi is now stable and at an acceptable speed.

alpha1 (wmstrome) wrote :

I have the same (or similar) problem with my Acer Aspire one D270-1895. The problem started shortly after upgrading to XUbuntu 13.04 (not the initial upgrade, but one or two updates after that) and has continued through all updates since. Since where I am now located I cannot conveniently report this bug from the LINUX on my system, I am doing so from the Windows partition so cannot see which version of the kernel, but it is the one included in the latest updates -- I think it is 3.9. I can connect to non-secure networks without problems, and I have successfully connected to WPA networks, but cannot do so if the connection is to networks using WEP. Since I use this computer while travelling and trying to connect at the homes of friends or relatives, I cannot change anything in the router.

I am hoping that this bug will be fixed soon so that I do not have to resort to booting in Windows in order to connect to the internet!!!!

alpha1 (wmstrome) wrote :

I was able to find this additional information about my XUbuntu installation and the Wireless controller:
The kernel is 3.8.0-27-generic, which is the latest in the repository and the Wireless LAN Controller is:
Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

K-2052 (k-5) wrote :

I had the same problem. The driver seems to be a bit fickle in what it doesn't like. I was able to get it to connect periodically by changing channels and going back and forth from N to G. I don't know much about drivers but perhaps this was causing the drive to reload? If you don't have a Ethernet cable handy I'd try restarting your router with a few different settings to get it (the card) to connect long enough to apply a fix.

I was able to resolve the issues by installing an unstable build of [firmware-ralink](http://packages.debian.org/sid/firmware-ralink)

Note: If you are reading this in the far off future the updated firmware will probably be available in the [linux-firmware ppa](https://launchpad.net/ubuntu/+source/linux-firmware). I'd check there before following my solution. At the time of this writing it was at *1.106* which did not contain the fixed ralink firmware

Here are the steps I went through;

1. Added "deb http://http.us.debian.org/debian unstable main contrib non-free"
to my apt sources (/etc/apt/sources.list)

I just wanted the deb file for firmware-ralink but I was too lazy to google and figure out how to pull the deb directly. You will need to make sure you REMOVE this line from your sources.list immediately after installing or you risk conflicting packages in the future. There is nothing worse than a conflicting kernel update.

2. Ran
 $ sudo apt-get update
 $ sudo apt-get -t unstable install firmware-ralink

3. At this point I got an error

"
Errors were encountered while processing:
 /var/cache/apt/archives/firmware-ralink_0.39_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
"

4. So I forced the install by running:

$ sudo dpkg --force overwrite -i /var/cache/apt/archives/firmware-ralink_0.39_all.deb

5. After that I removed the line from sources.list and ran $ sudo apt-get update to clear the cache of
debian packages.

Everything seems resolved now.

Csaba (eesdil) wrote :

Also not working, which is a bit annoying as I cannot use at work the pc...

My card is:
Intel(R) Centrino(R) Advanced-N 6200 AGN

ojc (ocrawford) wrote :

Also affected 13.04 Zoostorm W251ELRealtek RTL/8168

Any feedback welcome.

alpha1 (wmstrome) wrote :

Is there any estimate as to when this bug might be assigned to someone and to get it fixed? My netbook has been unusable as a portable device anywhere that the WiFi link is secure (works fine in lots of airports with free access and in many hotels). This is the kind of problem that will deter the average user from adopting LINUX in general and Ubuntu in particular.

ojc (ocrawford) wrote :

Re my own comment #27
I've got this working by changing my wireless network to unsecured. It connected. I then returned the wireless to secured and it's worked fine since. That's just a couple of hours so I'll see how it goes. Throughout this fiasco my XP desktop and Android phone have behaved perfectly.

I don't know if I'll have the problem on other wireless networks though.

twakatpw (tpwmisc) wrote :

Seems there's a sudden revival of interest in this problem - and alpha 1's comment (#28) really chimes with me (I'm a web designer up through sass to php). After about a year wondering whether to try Linux on an NC10 Samsung netbook because Microsoft are abandoning support for Windows XP, I finally wiped the hard drive after USB-booting with several distros - with wifi fine on both live and persistence sessions.
But I cannot now, after a full install and one whole, wasted day of trying every suggested MAC trick, driver quest and manual config, get a wifi connection - I can piggy-back unsecured networks but, so what? I could do that with Windows.
I was happy to spend time delving through a (largely undocumented) Linux new world but if it can't get a simple wifi connection sorted without a computer studies then it's overrated. Like alpha 1 I'm left with an unusable netbook (I'll buy a non-Linux tablet instead) and wondering if Windows didn't at least get one thing right.

ojc (ocrawford) wrote :

Re #28.

The computer's been asleep overnight. When it woke up it had the same symptoms. Repeated password requests and no connection.

I used my smartphone to change the wireless on my TP-Link_42DE2E to Open. The Ubuntu machine connected. I then reverted the wireless to WPA2-Personal. I went to Edit Connections and deleted both TP-Link_42DE2E instances. I restarted the Ubuntu machine and attempted to connect to TP-Link_42DE2E . This time it connected.

Next time it happens I'm going to try just deleting the TP-Link_42DE2E without changing the network type to open.

This is a new problem for me. I've been with Ubuntu since 2009. I've had 13.04 since April and it's just started being a problem.
I don't know it any of this is any help to anyone. I'd like to think there's someone working on this. There appear to be a number of similar threads about it. It's a deal breaker for anyone. Wireless connection just has to work.

ojc (ocrawford) wrote :

Re #27 A few days on and the Ubuntu machine is still connecting when it reawakes.

alpha1 (wmstrome) wrote :

I just "upgraded" from XUbuntu 13.04 to 13.10 Beta and now the wireless works with my encrypted router (WEP). The kernel is now 3.11.0-04generic

I have rebooted a few times, and the wireless connection has worked immediately for me without having to re-enter the key.

The update went very smoothly, and a few other minor problems that I experienced with 12.04, 12.10 and 13.04 have also disappeared now.

Canonical does not advise installing 13.04 Beta on a production system. However, I normally use this computer only when travelling, and I have no trips planned for a few months, so I decided to try it. There are a LOT of programs that have to be reloaded, but other than that, so far, it looks great.

Graham Thomas (gthomas33) wrote :

Symptoms and kit similar to original bug
HP pavillion g6 laptop, pre-installed windows 8 with dual boot Linux Mint 15, originally with kernel 3.8.0.3
Wireless works fine with good signal strength but drops out, requests new sign ins with weaker signal (works OK and reliably if booted in windows8)

Tried installing driver & patch as per #14 - still drops out
Adding blacklisting rt2800pci in etc/modprobe.d/blacklist.conf, as suggested in various forums, causes total wireless failure

Upgrading to kernel 3.11.0.03 - still get drop outs, no improvement

Doug James (douglasdouglasj-g) wrote :

My situation is similar, with an HP 2000 Notebook. However, Ive been able to connect to the router just fine, but have very intermittent speeds, ranging to 0k to maybe 5k, when I have a 1MB line. I piggyback via ethernet from my System76, and get a perfect signal on that notebook and perfect speed on the HP. I don't wanna delve into adding patches that are gonna be borked every kernel update, as this notebook doesent belong to me, not to mention I don't have all that much time to further break this thing. I'll try the prop. drivers and see if any improvement. It seems to me that there are various fixes and hexes for this issue, but not a universal fix.

zufar h (just-testing94) wrote :

Same problems here. Asus X45U with ralink rt5390 installed.

I tried using kernel 3.9. Still the same problems. Also: The wifi disable/enable button does not work.

i dont know about the package but my os is ubuntu 13.04, I installed it on my lenovo G580 laptop, it is showing the wireless networks but not getting connected, it is again and again asking to connect but not connecting, i have also installed additional drivers they r working. but is not getting to the wifi networks.

Zoli (janosizoli) wrote :

This bug also happens to me, but it was fine in 13.04, its happeing on 13.10. I have packard bell tk81 with realtek 8192se wifi chip.

jan2ary (jan2ary) wrote :

The same issue on 13.10, kernel 3.11.0.12

$ lspci | grep -i wi
03:00.0 Network controller: Intel Corporation WiFi Link 5100
86:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 06)

ojc (ocrawford) wrote :

Seems to be behaving on 13.10.

matteo cafarotti (bugman80) wrote :

Solved for me following this link:

http://blog.nerdyweekly.com/posts/fix-rmit-wifi-issue-in-ubuntu-13-04-and-variants/

seems that the network configuration GUI doesn't change the configuration file for the ca-certificate connection setting.

Hope this can help.

maadarchod harami ki aulad... teri maaaa ki choot.. maderbhagat.. mera 3G udgaya tum raandi baajzo ke chakar me.. sab chutiya banate hai.. Saale tum log gadhe ke gaand se ulte nikle hue aulaad...

A.K.Karthikeyan (mindaslab) wrote :

I use lenovo idea pad Z580 (with Ubuntu in it) and Dlink modem N300. All other devices in my home can connect with Wifi, but not this laptop :( hope it gets fixed soon.

And comment #42 contain filthy words (in hindi)

A.K.Karthikeyan (mindaslab) wrote :

To add to comment #43, I run Ubuntu 13.10

Shunzei (sub-fromtheshadow) wrote :

I had similar problem just after upgrading to ubuntu 13.10, and recent update in ubuntu, which upgraded kernel used to 3.11.0-15, solved this issue for me.

I know this is an old thread, but it seem this problem still exists on Ubuntu 14.04. I recently did an install on an affected computer and I documented the process so I could make this instruction for the benefit of anyone else having the same issue:
https://github.com/agerwick/RT28XX-RT539X-Linux-driver
This repo also contains the driver itself, as it seems Ralink/Mediatek keeps moving it around so some users have trouble finding it.

Joe (joejthomas) wrote :

I am new to Ubuntu and recently put in Ubuntu 14.04 LTS into my Lenovo Ideapad yoga 13 ultrabook. Installation went fine but for some reason I was not able to detect wifi. I already had windows 8 on the ultra book and wifi worked fine on windows.
I was able to solve the issue after updating the kernel to 3.14.4 .

Following this I dowloaded the driver files for realtek rtl8723ae-bt wifi card. (here is the link: http://www.mediafire.com/download/sanq19s3vv1d9c9/RTL8723AS-VAU+linux+driver.zip)

Then I found this really useful video on youtube which gives a step by step explanation as to how we can install these driver files.
(link: https://www.youtube.com/watch?v=H3WdsSHo5Sw)

NOTE: THE STEPS IN THE VIDEO WILL NOT WORK UNLESS THE KERNEL IS UPDATED.

Would rather prefer the ubuntu software coming with the 3.14.4 kernel as default. Such issues will only aid in discouraging new users from trying out the software

I recently installed Lubuntu 14.04 LTS in my HP Mini -110-3500 Netbook.
I was able to set nm-applet for startup & it detects a very strong signal of my home wi-fi [D-Link].
It prompts me to enter password but irrespective of correct or wrong password I enter it fails to connect and keep asking for password again and again. Though ethernet through same router works well.

PS: I had earlier worked on Ubuntu 12.04 LTS, but then I didn't had any wi-fi router.

AJT Santos, thank you for reporting this bug to Ubuntu. Raring reached EOL on January 27, 2014.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Is this an issue in a supported release? If so, could you please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1173759

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
thomas (thomas-heuer) wrote :

Please re-open that bug, as it still affects Ubuntu 14.04 on older hardware (+2005).

thomas, it would help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Alejandro (alevidalr) wrote :

In Ubuntu 14.04 and kernel 3.13.0-46-generic in a HP Paviliong g6 with a Ralink RT5390. I have the problem that the wireless sometimes connects for several minutes and then it just disconnects. By restarting the card or the computer (several times) the connection is reestablished, sometimes.
I have tried different drivers and updates for this card but the problems persists since I installed Ubuntu 5 months ago.

Alejandro, it would help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

oussama (oussama-rial) wrote :

I have the same problem in Ubuntu 14.04 lts !!!!!
How is the solution?

oussama, it would help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

poko (pokopt) wrote :

Experienced same problems (iwlwifi) - was not able to connect using wicd or wpa_supplicant directly.
wpa_supplicant gave errors:

Successfully initialized wpa_supplicant
wlan0: SME: Trying to authenticate with XX:XX:XX:XX:XX:XX (SSID='ssid' freq=2422 MHz)
wlan0: Trying to associate with XX:XX:XX:XX:XX:XX (SSID='ssid' freq=2422 MHz)
wlan0: Associated with XX:XX:XX:XX:XX:XX
wlan0: CTRL-EVENT-DISCONNECTED bssid=XX:XX:XX:XX:XX:XX reason=3 locally_generated=1
wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="ssid" auth_failures=1 duration=10 reason=WRONG_KEY
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="ssid"

I found out I'm able to connect using nm (nm-tui). Uninstalling network-manager (apt-get autoremove network-manager) did the trick and I can use wicd (wpa_supplicant) again.

poko, as this report is about a realtek chipset (not Intel), it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

wunaitian (zpsbit) wrote :

I am using HP Pavilion g4 with ralink rt5390. After I installed the ubuntu 14.04 with 3.19 kernel, the wifi didn`t work and also the wifi disable/enable button didn`t work. Then I remove the "acpi=off" in /etc/default/grub and run "update-grub", and reboot. I don`t why but it really works. And maybe it can help you.

Saim Thomus (saimthomus) wrote :

Wi-Fi association issues are very baffling. Perhaps it's simply me, however, they ordinarily occur at the very least conceivable time, when you have to check something on the web, compose an imperative email, et cetera. In case you're having issues associating your Android cell phone to a Wi-Fi organize, you're not the only one. This is a typical issue that, lamentably, plenty of clients encounter every now and then. In this post, we'll investigate a couple of fixes that could very well settle your availability issue and get you back on the web if your telephone won't interface with Wi-Fi. How about we make a plunge.
http://telstra.technicalhelpaustralia.com/blog/how-to-connect-telstra-wifi/

Jack Richer (richerjack660) wrote :

In reality, it is a typical issue with Broadcom arrange connectors in Ubuntu. An alleviation is that Ubuntu gives extra drivers explicitly to Broadcom connectors. Be that as it may, the issue is that to introduce extra drivers in Ubuntu you will require a system association. On the off chance that you have a wired association, it will be anything but difficult to introduce the extra drivers. Yet, in the event that you are limited to the remote system just, you'll need to search for exchange techniques.
https://technicalhelplineaustralia.com/apple-repair-centre.php

A standout amongst the most well-known issues looked in the wake of introducing Ubuntu is the system issue. A few times you will have no remote system in Ubuntu and a few times moderate remote association and at some point it will change among quick and moderate. On the off chance that you are fortunate, it could be fixed by introducing legitimacy drivers in Ubuntu however for the most part, you will be left raging, reviling over moderate or no WiFi association.
http://jaisalmerchiragdesertcamp.com/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers