Raring update to v3.8.9 stable release

Bug #1173170 reported by Tim Gardner on 2013-04-26
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The v3.8.9 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the v3.8.9 stable release:

powerpc: add a missing label in resume_kernel
kvm/powerpc/e500mc: fix tlb invalidation on cpu migration
ARM: Do 15e0d9e37c (ARM: pm: let platforms select cpu_suspend support) properly
kthread: Prevent unpark race which puts threads on the wrong cpu
hrtimer: Don't reinitialize a cpu_base lock on CPU_UP
can: mcp251x: add missing IRQF_ONESHOT to request_threaded_irq
can: sja1000: fix handling on dt properties on little endian systems
hugetlbfs: stop setting VM_DONTDUMP in initializing vma(VM_HUGETLB)
hugetlbfs: add swap entry check in follow_hugetlb_page()
fs/binfmt_elf.c: fix hugetlb memory check in vma_dump_size()
kernel/signal.c: stop info leak via the tkill and the tgkill syscalls
hfsplus: fix potential overflow in hfsplus_file_truncate()
md: raid1,10: Handle REQ_WRITE_SAME flag in write bios
KVM: Allow cross page reads and writes from cached translations.
ARM: i.MX35: enable MAX clock
ARM: clk-imx35: Bugfix iomux clock
sched: Convert BUG_ON()s in try_to_wake_up_local() to WARN_ON_ONCE()s
sched/debug: Fix sd->*_idx limit range avoiding overflow
ARM: 7696/1: Fix kexec by setting outer_cache.inv_all for Feroceon
ARM: 7698/1: perf: fix group validation when using enable_on_exec
ath9k_htc: accept 1.x firmware newer than 1.3
ath9k_hw: change AR9580 initvals to fix a stability issue
mac80211: fix cfg80211 interaction on auth/assoc request
ssb: implement spurious tone avoidance
crypto: algif - suppress sending source address information in recvmsg
perf: Treat attr.config as u64 in perf_swevent_init()
perf/x86: Fix offcore_rsp valid mask for SNB/IVB
userns: Don't let unprivileged users trick privileged users into setting the id_map
userns: Check uid_map's opener's fsuid, not the current fsuid
userns: Changing any namespace id mappings should require privileges
vm: add vm_iomap_memory() helper function
vm: convert snd_pcm_lib_mmap_iomem() to vm_iomap_memory() helper
vm: convert fb_mmap to vm_iomap_memory() helper
vm: convert HPET mmap to vm_iomap_memory() helper
vm: convert mtdchar mmap to vm_iomap_memory() helper
Btrfs: make sure nbytes are right after log replay
s390: move dummy io_remap_pfn_range() to asm/pgtable.h
Revert "MIPS: page.h: Provide more readable definition for PAGE_MASK."
Linux 3.8.9

Tim Gardner (timg-tpi) on 2013-04-26
tags: added: kernel-stable-tracking-bug
Tim Gardner (timg-tpi) on 2013-04-26
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Raring):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Brad Figg (brad-figg) on 2013-05-15
Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers