linux-tools-<ver> not built for armhf

Bug #1171580 reported by dann frazier on 2013-04-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Raring
Medium
Tim Gardner

Bug Description

ubuntu@c14:~$ sudo perf
perf_3.8.0-19 not found
You may need to install linux-tools-3.8.0-19
ubuntu@c14:~$ sudo apt-get install linux-tools-3.8.0-19
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-tools-3.8.0-19
E: Couldn't find any package by regex 'linux-tools-3.8.0-19'

The control file lists armhf as a valid arch for this package, but the buildlog reported:
dpkg-genchanges: warning: package linux-tools-3.8.0-19 in control file but not in files list

linux-tools-3.5.0-28 was available in quantal on armhf, so this appears to be a regression.

dann frazier (dannf) on 2013-04-22
tags: added: bot-stop-nagging

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1171580

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
dann frazier (dannf) on 2013-04-22
tags: removed: bot-stop-nagging
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key raring
Tim Gardner (timg-tpi) on 2013-04-24
Changed in linux (Ubuntu Raring):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
dann frazier (dannf) wrote :

ubuntu@c07:~$ dpkg -l | grep linux-tools
ii linux-tools-3.8.0-20 3.8.0-20.31 armhf Linux kernel version specific tools for version 3.8.0-20
ii linux-tools-common 3.8.0-20.31 all Linux kernel version specific tools for version 3.8.0
ubuntu@c07:~$ sudo perf --help

 usage: perf [--version] [--help] COMMAND [ARGS]

 The most commonly used perf commands are:
   annotate Read perf.data (created by perf record) and display annotated code
   archive Create archive with object files with build-ids found in perf.data file
   bench General framework for benchmark suites
   buildid-cache Manage build-id cache.
   buildid-list List the buildids in a perf.data file
   diff Read two perf.data files and display the differential profile
   evlist List the event names in a perf.data file
   inject Filter to augment the events stream with additional information
   kmem Tool to trace/measure kernel memory(slab) properties
   kvm Tool to trace/measure kvm guest os
   list List all symbolic event types
   lock Analyze lock events
   record Run a command and record its profile into perf.data
   report Read perf.data (created by perf record) and display the profile
   sched Tool to trace/measure scheduler properties (latencies)
   script Read perf.data (created by perf record) and display trace output
   stat Run a command and gather performance counter statistics
   test Runs sanity tests.
   timechart Tool to visualize total system behavior during a workload
   top System profiling tool.
   trace strace inspired tool
   probe Define new dynamic tracepoints

 See 'perf help COMMAND' for more information on a specific command.

ubuntu@c07:~$

tags: added: verification-done
removed: verification-needed-raring

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Released with 3.8.0-22.33.

Changed in linux (Ubuntu Raring):
status: In Progress → Fix Released
Julian Wiedmann (jwiedmann) wrote :

Fixed in 3.10.0-0.6 with

commit f479ff7a8b66d58945d999c18f6b0e3f066db13a
Author: Tim Gardner <email address hidden>
Date: Thu Jun 20 15:03:28 2013 +0000

    UBUNTU: [Config] Enable perf for armhf

Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers