DVD not detected on some HP Haswell platforms

Bug #1170797 reported by Leann Ogasawara on 2013-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Medium
Leann Ogasawara

Bug Description

== Quantal SRU Justification ==

The DVD drive attached to an HP Gen8+ platform can not be detected running Ubuntu 12.04 and 12.10. The issue is also seen on the platform running SuSe. A patch has landed upstream and been CC'd to upstream stable. The fix landed in Raring when we pulled in the v3.8.7 upstream stable patch set.

== Fix ==
~/linux$ git describe --contains b55f84e2d527182e7c611d466cd0bb6ddce201de
v3.9-rc7~41^2~2

commit b55f84e2d527182e7c611d466cd0bb6ddce201de
Author: Youquan Song <email address hidden>
Date: Wed Mar 6 10:49:05 2013 -0500

    ata_piix: Fix DVD not dectected at some Haswell platforms

== Test Case ==

Boot a kernel without this patch and confirm the DVD drive is not recognized. Reboot into a kernel with this patch and the DVD drive is recognized.

description: updated
Changed in linux (Ubuntu):
status: New → Fix Released
Changed in linux (Ubuntu Precise):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Quantal):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress

Invalidating the Precise nomination since we really just need this included in the Quantal kernel which will also be made available within the Quantal HWE kernel in Precise.

Changed in linux (Ubuntu Precise):
assignee: Leann Ogasawara (leannogasawara) → nobody
importance: Medium → Undecided
status: In Progress → Invalid
description: updated
description: updated

Submitted to the Ubuntu kernel-team mailing list for SRU:

https://lists.ubuntu.com/archives/kernel-team/2013-April/027819.html

Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Released with 3.5.0-31.52.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers