highbank: reboot doesn't work reliably

Bug #1169956 reported by Paolo Pisati on 2013-04-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Paolo Pisati
Raring
Medium
Paolo Pisati

Bug Description

ubuntu@c13:~$ uname -a
Linux c13 3.8.0-18-generic #29~nopl330 SMP Wed Apr 17 08:46:07 UTC 2013 armv7l armv7l armv7l GNU/Linux

ubuntu@c13:~$ sudo reboot

Broadcast message from ubuntu@c13
        (/dev/pts/0) at 9:16 ...

The system is going down for reboot NOW!

on the serial console:

Ubuntu 12.10 c13 ttyAMA0

c13 login: * Asking all remaining processes to terminate... [ OK ]
                                                                         [ OK ] * All processes ended within 1 seconds....
                                                                         [ OK ] * Deactivating swap...
                                                                         [ OK ] * Unmounting local filesystems...
                                                                                * Will now restart
<HANGS HERE>

only way to make it reboot is to pull the plug.
---
Architecture: armhf
DistroRelease: Ubuntu 12.10
MarkForUpload: True
Package: linux (not installed)
Uname: Linux 3.8.0-18-generic armv7l
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Paolo Pisati (p-pisati) wrote :

3.9-rc7 kernel, multiplatform support with highbank and imx6 selected, highbank
node -> reboot doesn't work (actually it works 1 out of 10 times)

And playing around with the config i was able to track it down to
PL310_ERRATA_769419.

Same issue happens on 3.8.

tags: added: highbank raring

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1169956

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Paolo Pisati (p-pisati) wrote :
tags: added: apport-collected
description: updated

apport information

Paolo Pisati (p-pisati) on 2013-04-17
Changed in linux (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
Paolo Pisati (p-pisati) wrote :

ok, scrap the previous patch, here is the correct one.

tags: added: patch
Changed in linux (Ubuntu Raring):
importance: Undecided → Medium

The attachment "0001-UBUNTU-SAUCE-Config-disable-PL310_ERRATA_769419.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package linux - 3.8.0-19.29

---------------
linux (3.8.0-19.29) raring; urgency=low

  [ Paolo Pisati ]

  * UBUNTU: [Config] disable PL330_DMA
    - LP: #1168039

  [ Rob Herring ]

  * UBUNTU: SAUCE: (no-up) ARM: highbank: fix cache flush ordering for cpu hotplug
    - LP: #1169956

  [ <email address hidden> ]

  * SAUCE: (no-up) x86: reboot: Make Dell Optiplex 390 use reboot=pci
    - LP: #800660

  [ Kamal Mostafa ]

  * SAUCE: [media] uvcvideo: quirk PROBE_DEF for Dell Studio / OmniVision
    webcam
    - LP: #1168430

  [ Upstream Kernel Changes ]

  * Revert "drivers/rtc/rtc-at91rm9200.c: use a variable for storing IMR"
    - LP: #1168506
  * Revert "PCI/ACPI: Request _OSC control before scanning PCI root bus"
    - LP: #1168506
  * Revert "tty/8250_pnp: serial port detection regression since v3.7"
    - LP: #1168506
  * ALSA: hda - fixup D3 pin and right channel mute on Haswell HDMI audio
    - LP: #1167270
  * ASoC: imx-ssi: Fix occasional AC97 reset failure
    - LP: #1168506
  * ASoC: dma-sh7760: Fix compile error
    - LP: #1168506
  * ASoC: spear_pcm: Update to new pcm_new() API
    - LP: #1168506
  * regmap: Initialize `map->debugfs' before regcache
    - LP: #1168506
  * regmap: cache Fix regcache-rbtree sync
    - LP: #1168506
  * MIPS: Fix logic errors in bitops.c
    - LP: #1168506
  * HID: magicmouse: fix race between input_register() and probe()
    - LP: #1168506
  * spi/s3c64xx: modified error interrupt handling and init
    - LP: #1168506
  * spi/mpc512x-psc: optionally keep PSC SS asserted across xfer segmensts
    - LP: #1168506
  * gpio: stmpe: pass DT node to irqdomain
    - LP: #1168506
  * UBIFS: make space fixup work in the remount case
    - LP: #1168506
  * reiserfs: Fix warning and inode leak when deleting inode with xattrs
    - LP: #1168506
  * ALSA: hda - bug fix on return value when getting HDMI ELD info
    - LP: #1168506
  * ALSA: hda - Enabling Realtek ALC 671 codec
    - LP: #1168506
  * ALSA: hda - fix typo in proc output
    - LP: #1168506
  * drm/nouveau: fix handling empty channel list in ioctl's
    - LP: #1168506
  * drm/i915: Be sure to turn hsync/vsync back on at crt enable (v2)
    - LP: #1168506
  * drm: correctly restore mappings if drm_open fails
    - LP: #1168506
  * mm: prevent mmap_cache race in find_vma()
    - LP: #1168506
  * EISA/PCI: Init EISA early, before PNP
    - LP: #1168506
  * EISA/PCI: Fix bus res reference
    - LP: #1168506
  * ixgbe: fix registration order of driver and DCA nofitication
    - LP: #1168506
  * libata: Use integer return value for atapi_command_packet_set
    - LP: #1168506
  * libata: Set max sector to 65535 for Slimtype DVD A DS8A8SH drive
    - LP: #1168506
  * MIPS: Unbreak function tracer for 64-bit kernel.
    - LP: #1168506
  * alpha: Add irongate_io to PCI bus resources
    - LP: #1168506
  * PCI/ACPI: Always resume devices on ACPI wakeup notifications
    - LP: #1168506
  * PCI/PM: Disable runtime PM of PCIe ports
    - LP: #1168506
  * ata_piix: Fix DVD not dectected at some Haswell platforms
    - LP: #1168506
  * ftrace: Consistently restore trace function on sysctl enabling
    - LP: #1168506
  * powerpc: pS...

Read more...

Changed in linux (Ubuntu Raring):
status: Incomplete → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments