Ubuntu

3.8.0-18 Kernel causes HDMI Audio to stop working

Reported by Mike Loebl on 2013-04-16
494
This bug affects 100 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Was using Raring 13.04 with kernel 3.8.0-17 with NVIDIA HDMI Audio via the NVIDIA 319.12 drivers. When upgrading to 3.8.0-18, HDMI is no longer listed within Sound Settings or pavucontrol (only item listed with Dummy.) Switched over to the ubuntu nividia-current driver, same problem. Rolled back to 3.8.0-17 and HDMI audio again works correctly. What files should I attach to assist with this? I can roll back/fourth between the two to get anything required.
---
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/hwC0D2', '/dev/snd/hwC0D3', '/dev/snd/pcmC0D3p', '/dev/snd/pcmC0D7p', '/dev/snd/pcmC0D8p', '/dev/snd/pcmC0D9p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDmesg:
 Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
 dmesg: write failed: Broken pipe
DistroRelease: Ubuntu 13.04
InstallationDate: Installed on 2012-12-18 (119 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
MarkForUpload: True
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-18-generic root=UUID=9ec63a8c-080e-49d3-ab11-50cb155d48c3 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
Tags: raring
Uname: Linux 3.8.0-18-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-03-16 (31 days ago)
UserGroups: lpadmin sudo
WifiSyslog:

dmi.bios.date: 09/03/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F11
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z77X-UP5 TH-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF11:bd09/03/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ77X-UP5TH-CF:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
---
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D1', '/dev/snd/hwC0D2', '/dev/snd/hwC0D3', '/dev/snd/pcmC0D3p', '/dev/snd/pcmC0D7p', '/dev/snd/pcmC0D8p', '/dev/snd/pcmC0D9p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=68018cdf-d176-4c0f-8b23-3b62b4e09b5d
InstallationDate: Installed on 2012-12-18 (119 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
MarkForUpload: True
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-18-generic root=UUID=9ec63a8c-080e-49d3-ab11-50cb155d48c3 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-18-generic N/A
 linux-backports-modules-3.8.0-18-generic N/A
 linux-firmware 1.105
Tags: raring
Uname: Linux 3.8.0-18-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-03-16 (31 days ago)
UserGroups: pkcs11
dmi.bios.date: 09/03/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F11
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z77X-UP5 TH-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF11:bd09/03/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ77X-UP5TH-CF:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1169761

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected raring
description: updated
Mike Loebl (mloebl) wrote : CRDA.txt

apport information

apport information

apport information

apport information

Mike Loebl (mloebl) wrote : Lspci.txt

apport information

Mike Loebl (mloebl) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

Mike Loebl (mloebl) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0]. You will need to install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc7-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: regression-update

I confirmed this report since I seem to have the same problem caused by the same kernel upgrade, although my sound hardware is integrated Intel, not nvidia

http://ubuntuforums.org/showthread.php?t=2136303

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Mike Loebl (mloebl) wrote :

Confirmed 3.9 resolves problem, tag added. I was unable to test with the new NVIDIA 319.12 driver, but reverted to nvidia-current and it worked fine.

tags: added: kernel-fixed-upstream
Mike Loebl (mloebl) on 2013-04-18
tags: removed: nvidia

rolling back to 3.8.0-17 worked for me which confirms which kernel update introduced the problem.

I was hoping that 3.8.0-19 would fix this problem, It did not. Rolling back to 3.8.0.17 did fix the problem.
My sound card is HDA Intel PCH. Chip Intel CougarPoint HDMI.

How do I upgrade to 3.9?

I should have read more. I know how to try 3.9 but when is likely to make it xubuntu 13.04?

Øyvind Stegard (oyvinst) wrote :

I had to blacklist kernel module 'snd-hda-codec-hdmi' due to kernel BUG on boot somewhere in this module's code. Happened on two very different computers, both using nvidia proprietary driver (310- or 313-series). Started after upgrading to Ubuntu 13.04, first kernel used was 3.8.0-18 (now on 3.8.0-19). Booting fails miserably if the bug triggers.

Balint Deak (dbalint) wrote :

I have the same bug. I can confirm that the 3.9 RC 7 kernel downloaded from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc7-raring/ does fix the bug. Using this kernel now and HDMI audio works as before.

# uname -a
Linux universe 3.9.0-030900rc7-generic #201304171402 SMP Wed Apr 17 18:04:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

# pact list
[...]
        Profiles:
                input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority. 60)
                output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority. 6000)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority. 6060)
                output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority. 5400)
                output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (sinks: 1, sources: 1, priority. 5460)
                off: Off (sinks: 0, sources: 0, priority. 0)

bdeak@universe:~$ cat /proc/asound/card0/codec*|grep Codec
Codec: Conexant CX20590
Codec: Intel PantherPoint HDMI

Thanks for the tip, Joseph!

Gacrux (ewen-cumming) wrote :

This also affects me with the radeon driver.

Introduced in 3.8.0-18 and still present in 3.8.0-19.

Konstigt (konstigt) wrote :

This kernel also fixes the problem:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.8-raring/

Better than 3.9 because it won't break applications that is missing support for 3.9, for example VirtualBox.

Mike Loebl (mloebl) wrote :

Thanks for the tip on 3.8.8, I'll have to try that tonight. I was unable to install the latest NVidia drivers on 3.9.

Thanks ThomasNovin.

I did the following from your link. Downloaded:
hari@hari-PORTEGE-R835:~/Desktop$ ls -lt *.deb
-rw-rw-r-- 1 hari hari 31013124 Apr 22 13:50 linux-image-extra-3.8.8-030808-generic_3.8.8-030808.201304170248_i386.deb
-rw-rw-r-- 1 hari hari 13022298 Apr 22 13:50 linux-image-3.8.8-030808-generic_3.8.8-030808.201304170248_i386.deb
-rw-rw-r-- 1 hari hari 973744 Apr 22 13:50 linux-headers-3.8.8-030808-generic_3.8.8-030808.201304170248_i386.deb

sudo dpkg -i *.deb
sudo upgrade-grub

There was an error about linuxheader 3.8.8-030808
However, HDMI audio worked.
update-manager wanted to remove it. When I allowed the "Partial Upgrade" it did remove whatever was offending.
I did that and re-booted.
No more error from update-manager.
hari@hari-PORTEGE-R835:~/Desktop$ uname -a
Linux hari-PORTEGE-R835 3.8.8-030808-generic #201304170248 SMP Wed Apr 17 06:58:01 UTC 2013 i686 i686 i686 GNU/Linux
HDMI audio is fine.

hari@hari-PORTEGE-R835:~/Desktop$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Hope I did the right thing. I should also thank Mike Loebl. When is 3.9 going to make it to Ubuntu?

Mike Loebl (mloebl) wrote :

Upgraded to 3.8.8 and HDMI audio is working fine.

If using the NVIDIA downloaded drivers with Raring and the 3.8.8 kernel, you may need to:
export IGNORE_CC_MISMATCH=1
or else it may complain of a GCC mismatch.

Fabrizio Narni (shiba89) wrote :

Dumping what I know, hoping it will help.
Additions were made to sound/pci/hda/patch_hdmi.c in 3.8.0-18, and removing them solves the problem. As I can see, they are based on 3.9-rc*, but it seems that upstream some other additions were made.
I added a patch to better illustrate what's causing the problem, it's not meant to be a solution.

Fabrizio Narni (shiba89) wrote :

PS: it's a reverse patch (3.8.0-18 → 3.8.0-17), I forgot to mention.

tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

The upstream v3.8.8 updates have been applied to the 3.8.0-19 Ubuntu kernel. Can you upgrade to this latest kernel and report back if it fixes this bug? If it does, please change the bug to 'Fix Released'.

Now that I updated to 3.8.8-030808, is there a good reason to roll back to 3.8.0-19?

If so, how do I get an update? Link please.

Fabrizio Narni (shiba89) wrote :

Not solved for me.

Mike Loebl (mloebl) wrote :

 3.8.0-19 is not working for me either unless there is another update that hasn't come down yet or another download is required.

aplay -l
aplay: device_list:252: no soundcards found...

uname -a
Linux mike 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

madbiologist (me-again) wrote :

As well the NVIDIA and Intel ASICs described above, this is also happening on ATI/AMD Radeon hardware - see bug #897008 from comment #33 onwards. The Ubuntu mainline kernel builds 3.8.0, 3.8.1, 3.8.2, 3.8.6, and 3.8.8 all work fine for HDMI audio, as does Ubuntu 3.8.0-17-generic. Ubuntu 3.8.0-18 or Ubuntu 3.8.0-19 do not have working HDMI audio.

madbiologist (me-again) wrote :

Could someone please attach the output of "pacmd ls" and an alsa-info according to https://wiki.ubuntu.com/Audio/AlsaInfo ?

Gizmo Chicken (gizmochicken) wrote :

I've also been having the same problem (no HDMI audio) with a Radeon HD 6670 beginning with the Ubuntu 3.8.0-18 kernel. I can confirm that HDMI audio DOES work in Ubuntu 13.04 with my Radeon HD 6670 in combination with the following mainline kernels: 3.8.0, 3.8.1, 3.8.2, 3.8.6, and 3.8.8.

Interesting to note that HDMI audio works with mainline 3.8.6 and mainline 3.8.8, but not with Ubuntu 3.8.0-18 or Ubuntu 3.8.0-19, which are based on mainline 3.8.6 and mainline 3.8.8, respectively. See http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html

I'll also add that, at least for me, lots of other problems (including inability to mirror monitors) are present with 3.8.1, 3.8.2, 3.8.6, and 3.8.8. See https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1167301 But most everything seems to be working well with mainline 3.8.0 and Ubuntu 3.8.0-7. So for me, mainline 3.8.0 and Ubuntu 3.8.0-7 are my only current options.

madbiologist (me-again) wrote :

Unless I am mistaken this is caused by one of the SAUCE patches or config changes listed at https://launchpad.net/ubuntu/raring/+source/linux/3.8.0-18.28

'alsa-info' and 'pacmd ls' output attached. I've included both 3.8.0-19 (where HDMI sound outputs are not working) and 3.9.0-rc8 (where HDMI sound is working).

Mike Loebl (mloebl) wrote :

Attached my output as well with 3.8.0-19

Giannis (karzisss) wrote :

Xubuntu 13.04 with 3.8.0.19 kernel - NO HDMI output (pulseaudio does not even recognize any HDMI output)
Xubuntu 13.04 with 3.5.0.27 kernel (from 12.10) - HDMI output OK!

GPU Radeon RV630 running opensource drivers

molecule-eye (niburu1) wrote :

I lost HDMI upgrading to 13.04, running kernel 3.8.0-19-generic and Catalyst 13.4 stable. But aplay -l does return the following:

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

So why doesn't pulseaudio give me access to card 0? Is aplay just reading an old file which listed HDMI among audio sources, though it is no longer *really* available? Actually, HDMI is listed in alsamixer too, as card 0.

Maxim (mekatum) wrote :

I have Kubuntu 13.04 on my ASUS 1225B (HD 6320) with xserver-xorg-video-radeon ver. 7.1.0. I solve problem with sound over HDMI on kernel 3.8.8-030808-generic from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.8-raring/

On kernel 3.8.0-19-generic HDMI out in "Sound Settings" was not active.

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice №0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice №0: subdevice #0

lspci | grep Audio
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)

Giuseppe Pennisi (giupenni78) wrote :

Same problem with GT430 after upgrade from Ubuntu 12.10 to 13.04

ZillaVilla (zillavilla) wrote :

I have the same problem, cannot get ATI HDMI [Cedar] to display as an option in sound settings. I don't have audio cables or I'd test the analog card on the computer, but I'd rather be using digital output to my amp anyhow. before upgrading from 12.10 to 13.04 it would go missing after the display went to sleep or the amplifier was turned off for an extended period of time.. Now after upgrade to 13.04 I cannot get it to come back. aplay -l listed below, is there any more information I can provide to help?

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 3: ALC888 Digital [ALC888 Digital]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Finally it is working with no need to nstall a new Kernal, what you need to do is simply download and install the lates version of this audio Package: oem-audio-hda

1- Download & Install this Package: https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages, then Reboot
2- Go to "Sound Settings", you should now see your hdmi device listed, select it and your done.

Thats about it, Enjoy your day (:

Thank you very much worked without problems :)

Jonybat (jonybat26) wrote :

I confirm that the above solution fixes the problem.
Using Xubuntu 13.04 with 3.8.0-19

Consumology (hgms72-4oneway) wrote :

Also works for me on Ubuntu 13.04 with 3.8.0-19, thanx!

Leon Anavi (leon-x) wrote :

I also confirm that the above solution proposed by Saleh Abdulazzi Abdulawal (saleh-awal) works fine on Ubuntu 13.04 with ATI Mobility Radeon HD 5430.

sithlord48 (sithlord48) wrote :

I can Also Confirm this the solution proprosed above by Saleh Abdulazzi Addulawal (asaleh-awal) is working for my Radeon HD6670. I am using the open source radeon driver.

Sergey Mitrichev (for-serg) wrote :

No, the solution of Saleh Abdulazzi Abdulawal (saleh-awal) with oem-audio-hda DOES NOT help with my Radeon 6450A with X.org radeon driver on Ububntu 13.04. Still no HDMI sound.

When I installed oem-audio-hda
on xubuntu 13.04 3.8.0.19 initially I did not see HDMI but on an update of 3.8.0.19 restricted synpatic update,
I got HDMI audio.
uname -a
Linux hari-PORTEGE-R835 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:36:13 UTC 2013 i686 i686 i686 GNU/Linux
hari@hari-PORTEGE-R835:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Rich.T. (rich.t.) wrote :

Hi, I have a Nvidia GT430 with GF108 Controller on a Zotac Z68ITX-B-E and have not had HDMI sound since I upgraded from Precise. Dummy Audio only available.

~$ uname -a
Linux **** 3.8.0-21-generic #32-Ubuntu SMP Tue May 14 22:16:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

After following saleh-awal's advice (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1169984/comments/16), The problem is now fixed.

Steps performed:

~$ sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
~$ sudo apt-get update
~$ sudo apt-get install oem-audio-hda-daily-dkms

Reboot.
Thanks.

Bjorn Madsen (bjorn-madsen) wrote :

#70 did not work on
Linux EEEbox 3.8.0-27-generic #40-Ubuntu SMP Tue Jul 9 00:17:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.