3.2.0-40-generic hanging Lenovo T420 on boot

Bug #1169304 reported by Chrisrjensen
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
High
Steve Conklin

Bug Description

Hi

I recently updated my Precise desktop to linux-image-3.2.0-40-generic on my Lenovo T420 and I am experiencing hangs on boot.
It doesn't always happen - probably 80% of the time or more.

If I go back and book with 3.2.0-39-generic or older , I do not see this issue (it will boot every time).
the screen goes black and there is no disk activity. Only lights on the T420 are the power and bluetooth light

The T420 runs an Intel i& vPro processor

some addl info:
lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [Quadro NVS 4200M] (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
0d:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 08)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: chris 2111 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf3920000 irq 48'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa21ce,00100002 HDA:14f12c06,17aa2122,00100000'
   Controls : 9
   Simple ctrls : 6
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=78d03763-4810-4c4f-8374-8a2392875881
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: LENOVO 42365H2
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-40-generic root=UUID=5fbf7a33-6947-408f-a3d4-71bf459b63c5 ro quiet splash
ProcVersionSignature: Ubuntu 3.2.0-40.64-generic 3.2.40
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-40-generic N/A
 linux-backports-modules-3.2.0-40-generic N/A
 linux-firmware 1.79.1
StagingDrivers: mei
Tags: precise running-unity staging
Uname: Linux 3.2.0-40-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 11/28/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 83ET67WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 42365H2
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: 474556
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr83ET67WW(1.37):bd11/28/2011:svnLENOVO:pn42365H2:pvrThinkPadT420:rvnLENOVO:rn42365H2:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 42365H2
dmi.product.version: ThinkPad T420
dmi.sys.vendor: LENOVO

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1169304

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream stable kernel? Please test the latest v3.2 stable kernel[0] and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.43-precise/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key
Revision history for this message
Chrisrjensen (chrisrjensen) wrote : AcpiTables.txt

apport information

tags: added: apport-collected
description: updated
Revision history for this message
Chrisrjensen (chrisrjensen) wrote : AlsaDevices.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : BootDmesg.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : CRDA.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : Card0.Amixer.values.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : Card0.Codecs.codec.0.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : Card0.Codecs.codec.1.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : IwConfig.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : Lspci.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : Lsusb.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : PciMultimedia.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : ProcModules.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : PulseList.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : RfKill.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : UdevDb.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : UdevLog.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote : WifiSyslog.txt

apport information

Revision history for this message
Chrisrjensen (chrisrjensen) wrote :

Hi - this is what I tried - is this correct?

from: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.43-precise/

I downloaded and installed
linux-image-3.2.43-030243-generic_3.2.43-030243.201304092335_amd64.deb

as per Joseph's comment I tried to install extras using:
linux-image-extra-3.2.43-030243-virtual_3.2.43-030243.201304092335_amd64.deb
but that wouldn't install because it was asking for :
linux-image-3.2.43-030243-virtual_3.2.43

>> I wasn't sure if virtual should have been installed - but I decided to try it

so I installed
linux-image-3.2.43-030243-virtual_3.2.43-030243.201304092335_amd64.deb
and then
linux-image-extra-3.2.43-030243-virtual_3.2.43-030243.201304092335_amd64.deb

rebooted and experienced same problem.

rebooted and selected old kernel 3.2.0-39 and it started normal

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Steve Conklin (sconklin) wrote :

Please test this bisection kernel built from the Ubuntu kernel source:
linux-image-3.2.0-40-generic_3.2.0-40.63~spcbisect01_amd64.deb

Found here:
http://people.canonical.com/~sconklin/precise-bisection/

For future reference:
# bad: [985689ad1c3211f4f3a9ce0e2371847320ba873f] UBUNTU: Ubuntu-3.2.0-40.64
# good: [ba89d2a7ca8233e29c9fdeabefb7fdbb6775626e] UBUNTU: Ubuntu-3.2.0-39.62
git bisect start 'Ubuntu-3.2.0-40.64' 'Ubuntu-3.2.0-39.62'

Please report results here, thanks.

Revision history for this message
Henrik Holst (millihenrik) wrote :

I have the very same problem with a Lenovo W500 using the Intel GPU (do however get a black screen 100% of the time), and I've tested the bisection kernel and it did not work.

Revision history for this message
Brad Figg (brad-figg) wrote :

@ henrik,

It's impossible to tell at this point if your bug is the same or not. You have a different system with different graphics. Please file a new bug.

Revision history for this message
Steve Conklin (sconklin) wrote :

There are 3.2.0 bisection kernels we're using in an attempt to locate this problem, located here:

http://people.canonical.com/~sconklin/precise-bisection/

The most recent one is in the top directory, and all older ones are in the old/ directory.

Please test them in order, and report in this bug for each one whether you still have the problem or not. Include the kernel version in the report.

Thanks, this testing is valuable.

Steve Conklin (sconklin)
Changed in linux (Ubuntu):
assignee: nobody → Steve Conklin (sconklin)
Revision history for this message
Steve Conklin (sconklin) wrote :

A patch has been identified which is known to cause problems in both precise and quantal kernels. Since people running both series are piling onto this bug, I'm posting the links for each.

Please test the appropriate kernel for you installation, and report whether you still have the problem. This is important, as there are some indications that we may be chasing multiple problems with these bugs.

Please report both success and failure, and include youe kernel version when you make your report.

Precise test kernels are located here:

http://people.canonical.com/~sconklin/precise-revert-4c443ec/

Quantal test kernels are located here:

http://people.canonical.com/~sconklin/quantal-revert-4c443ec/

Thank you for your help!

Revision history for this message
Chrisrjensen (chrisrjensen) wrote :

Been travelling and haven't been able to update this.

I wanted to help troubleshoot this - but I ended up upgrading to 12.10 and that solve the issue I was having. (I had to have other people use the machine - and the boot issue was causing a problem with that)

booting to 12.10 with 3.5.0-17-generic solved the issue I was experiencing.

do you want to close this then?

Revision history for this message
Steve Conklin (sconklin) wrote :

Chrisrjensen,

Thanks for the help.

We have other bugs open for what we think is the same problem, so I'm going to invalidate this one.

Steve

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Chrisrjensen (chrisrjensen) wrote :

ok so things worked in Quantal until my system updated last night

3.5.0-17-generic -> boots fine
3.5.0-27-generic -> hangs to blank screen while booting

I tried the patch kernel posted by Steve Conklin (sconklin) above
http://people.canonical.com/~sconklin/quantal-revert-4c443ec/

3.5.0-28.47 -> still boots to blank screen

So this is still an issue with the Lenovo T420 with intel i7 processor

Steve - you mentioned this is open somewhere else, should I close this and join in with another bug?

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Brad Figg (brad-figg) wrote :

We have identified a possible, upstream fix for this issue. Please test the appropriate kernel for your system located at:

http://kernel.ubuntu.com/~bradf/lp1169380/upstream-01/

tags: removed: kernel-da-key
Revision history for this message
Chrisrjensen (chrisrjensen) wrote :

Hi Brad - that is the Precise kernel

I have upgraded to Quantal - so I need that one.

I looked in the folder location that you included and is this the upstream fix for Quantal?
http://kernel.ubuntu.com/~bradf/lp1167114/upstream-01/

I'm giving that a shot - and will post results

Revision history for this message
Chrisrjensen (chrisrjensen) wrote :

Good news!

I installed 3.5.0-28.48 and the system boots every time now.

Should I just continue using this fix for my normal operation now? Any issues with that?

Thanks for your help

Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Julian Wiedmann (jwiedmann) wrote :

Chrisrjensen,

could you please test the latest kernel in -updates (3.5.0-31.52) and confirm that this bug is fixed? Thanks.

Changed in linux (Ubuntu):
status: Fix Committed → Incomplete
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers