Linux kernel 3.2.0-40-generic update causes regression, does not boot anymore

Bug #1168961 reported by Fabian Köster on 2013-04-14
26
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
High
Steve Conklin

Bug Description

The latest kernel update caused a regression on my Samsung R60plus notebook.

The system refuses to boot like it did before, the screen just stays black after the bios messages.

Workaround: When I press Ctrl+Alt+Del the system does reboot and the Grub menu is shown, I can then just press Enter (booting the latest kernel 3.2.0-40-generic) and the system boots fine. It is just a problem with the instant booting without entering the grub menu before.

The problem also disappears when I manually set GRUB_DEFAULT=2 in /etc/default/grub, setting the standard kernel back to 3.2.0-39-generic.

Please let me know if you need more information

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-39-generic 3.2.0-39.62
ProcVersionSignature: Ubuntu 3.2.0-39.62-generic 3.2.39
Uname: Linux 3.2.0-39-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: steffie 1823 F.... xfce4-volumed
                      steffie 1898 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd0300000 irq 16'
   Mixer name : 'Realtek ALC262'
   Components : 'HDA:11c11040,2118144d,00100200 HDA:10ec0262,144dc034,00100002'
   Controls : 18
   Simple ctrls : 10
Date: Sun Apr 14 21:05:58 2013
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=1f85df16-4087-429d-8df2-fcb7a13c6196
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: SAMSUNG ELECTRONICS CO., LTD. R59P/R60P/R61P
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 EFI VGA
 1 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-39-generic root=UUID=e694d1ef-699c-423d-b4ab-4109e2db8f1e ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-39-generic N/A
 linux-backports-modules-3.2.0-39-generic N/A
 linux-firmware 1.79.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/29/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 00YI
dmi.board.name: R59P/R60P/R61P
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr00YI:bd06/29/2007:svnSAMSUNGELECTRONICSCO.,LTD.:pnR59P/R60P/R61P:pvr00YI:rvnSAMSUNGELECTRONICSCO.,LTD.:rnR59P/R60P/R61P:rvr:cvnSAMSUNGELECTRONICSCO.,LTD.:ct1:cvrN/A:
dmi.product.name: R59P/R60P/R61P
dmi.product.version: 00YI
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Fabian Köster (maestro-alubia) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream stable kernel? Please test the latest v3.2 stable kernel[0] and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.43-precise/

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
tags: added: kernel-da-key
Fabian Köster (maestro-alubia) wrote :

I have no access to the machine at the moment but I will follow your instructions as soon as I am back to it.

Steve Conklin (sconklin) wrote :

Instead, please test this bisection kernel built from the Ubuntu kernel source:
linux-image-3.2.0-40-generic_3.2.0-40.63~spcbisect01_amd64.deb

Found here:
http://people.canonical.com/~sconklin/precise-bisection/

For future reference:
# bad: [985689ad1c3211f4f3a9ce0e2371847320ba873f] UBUNTU: Ubuntu-3.2.0-40.64
# good: [ba89d2a7ca8233e29c9fdeabefb7fdbb6775626e] UBUNTU: Ubuntu-3.2.0-39.62
git bisect start 'Ubuntu-3.2.0-40.64' 'Ubuntu-3.2.0-39.62'

Please report results here, thanks.

Steve Conklin (sconklin) wrote :

There are 3.2.0 bisection kernels we're using in an attempt to locate this problem, located here:

http://people.canonical.com/~sconklin/precise-bisection/

The most recent one is in the top directory, and all older ones are in the old/ directory.

Please test them in order, and report in this bug for each one whether you still have the problem or not. Include the kernel version in the report.

Thanks, this testing is valuable.

Steve Conklin (sconklin) on 2013-04-18
Changed in linux (Ubuntu):
assignee: nobody → Steve Conklin (sconklin)
Commat (commat) wrote :

Same problem on my Dell Vostro 3350

Fabian Köster (maestro-alubia) wrote :

I tested the kernels like you said and here are the results:

From http://people.canonical.com/~sconklin/precise-bisection/:

3.2.0-40-generic_3.2.0-40.63~spcbisect03: GOOD
3.2.0-40-generic_3.2.0-40.63~spcbisect02: GOOD
3.2.0-40-generic_3.2.0-40.63~spcbisect01: BAD

From http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.43-precise/:

3.2.43-030243-generic_3.2.43-030243.201304092335: BAD

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Steve Conklin (sconklin) wrote :

Fabian, thanks, let me prepare another kernel for you.

Some people report that this problem does not happen on every boot, so if possible, please test each kernel multiple times and power the system down completely between boots.

I'll update this bug when I have new test kernels.

Steve Conklin (sconklin) wrote :

I've moved the bisection kernels for this bug to their own directory, since the bisection results are diverging from another bug.

The new location for test kernels for this bug is here:

http://people.canonical.com/~sconklin/lp-1167114/

The latest kernel to be tested is ~lp1168961spcbisect02a, and is available at that URL

Thank you for your continued help with this.

3.2.0-40-generic_3.2.0-40.63~lp1168961spcbisect02a is also BAD.

I tested the other kernels again and the problem is perfectly reproduciblewith the BAD versions on my machine.

reef2dive (reef2dive) wrote :

The same regression vmlinuz-3.2.0-40-generic is noticed on ACER 4830TG. The boot hangs. Nothing explicit is in the logs. Reversion to vmlinuz-3.2.0-39-generic works fine.

Steve Conklin (sconklin) wrote :

A patch has been identified which is known to cause problems in both precise and quantal kernels. Since people running both series are piling onto this bug, I'm posting the links for each.

Please test the appropriate kernel for you installation, and report whether you still have the problem. This is important, as there are some indications that we may be chasing multiple problems with these bugs.

Please report both success and failure, and include youe kernel version when you make your report.

Precise test kernels are located here:

http://people.canonical.com/~sconklin/precise-revert-4c443ec/

Quantal test kernels are located here:

http://people.canonical.com/~sconklin/quantal-revert-4c443ec/

Thank you for your help!

Brad Figg (brad-figg) wrote :

We have identified a possible, upstream fix for this issue. Please test the appropriate kernel for your system located at:

http://kernel.ubuntu.com/~bradf/lp1169380/upstream-01/

Thanks Steve and Brad for your work!

I currently again have no access to the machine until saturday. Can someone else please test this?

Brad Figg (brad-figg) on 2013-04-24
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (14.0 KiB)

This bug was fixed in the package linux - 3.2.0-41.66

---------------
linux (3.2.0-41.66) precise-proposed; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1172464

  [ Steve Conklin ]

  * Revert "drm/i915: GFX_MODE Flush TLB Invalidate Mode must be '1' for
    scanline waits"
    - LP: #1140716

  [ Upstream Kernel Changes ]

  * fbcon: fix locking harder
    - LP: #1168961, #1169380

linux (3.2.0-41.65) precise-proposed; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1167436

  [ John Johansen ]

  * SAUCE: (no-up) apparmor: Fix quieting of audit messages for network
    mediation
    - LP: #1163259

  [ Steve Conklin ]

  * SAUCE: Update configs for new efivars option
    - LP: #1164646

  [ Upstream Kernel Changes ]

  * Revert "powerpc/eeh: Fix crash when adding a device in a slot with DDW"
    - LP: #1164646
  * Input: cypress_ps2 - fix trackpadi found in Dell XPS12
    - LP: #1103594
  * btrfs: Init io_lock after cloning btrfs device struct
    - LP: #1164646
  * md: protect against crash upon fsync on ro array
    - LP: #1164646
  * NFS: Don't allow NFS silly-renamed files to be deleted, no signal
    - LP: #1164646
  * SUNRPC: Don't start the retransmission timer when out of socket space
    - LP: #1164646
  * storvsc: Initialize the sglist
    - LP: #1164646
  * dc395x: uninitialized variable in device_alloc()
    - LP: #1164646
  * ARM: VFP: fix emulation of second VFP instruction
    - LP: #1164646
  * ARM: fix scheduling while atomic warning in alignment handling code
    - LP: #1164646
  * md: fix two bugs when attempting to resize RAID0 array.
    - LP: #1164646
  * md: raid0: fix error return from create_stripe_zones.
    - LP: #1164646
  * proc connector: reject unprivileged listener bumps
    - LP: #1164646
  * ath9k: fix RSSI dummy marker value
    - LP: #1164646
  * ath9k_htc: fix signal strength handling issues
    - LP: #1164646
  * mwifiex: correct sleep delay counter
    - LP: #1164646
  * cifs: ensure that cifs_get_root() only traverses directories
    - LP: #1164646
  * xen/pci: We don't do multiple MSI's.
    - LP: #1164646
  * dm: fix truncated status strings
    - LP: #1164646
  * dm snapshot: add missing module aliases
    - LP: #1164646
  * drm/i915: Don't clobber crtc->fb when queue_flip fails
    - LP: #1164646
  * ARM: 7663/1: perf: fix ARMv7 EVTYPE_MASK to include NSH bit
    - LP: #1164646
  * hwmon: (pmbus/ltc2978) Fix peak attribute handling
    - LP: #1164646
  * hwmon: (pmbus/ltc2978) Use detected chip ID to select supported
    functionality
    - LP: #1164646
  * hwmon: (sht15) Check return value of regulator_enable()
    - LP: #1164646
  * hw_random: make buffer usable in scatterlist.
    - LP: #1164646
  * ALSA: vmaster: Fix slave change notification
    - LP: #1164646
  * drm/radeon: add primary dac adj quirk for R200 board
    - LP: #1164646
  * dmi_scan: fix missing check for _DMI_ signature in smbios_present()
    - LP: #1164646
  * iwlwifi: always copy first 16 bytes of commands
    - LP: #1164646
  * HID: add support for Sony RF receiver with USB product id 0x0374
    - LP: #1164646
  * HID: clean up quirk for Sony RF receivers
    - LP: #1164646
  * ...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released

I can confirm this bug is fixed in linux 3.2.0-41. Thank you very much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers