OmniVision webcam not detected (intermitent)

Bug #1168430 reported by Rick Spencer on 2013-04-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Kamal Mostafa
Raring
High
Kamal Mostafa

Bug Description

Steps:
1. Boot from 12.10 CD
2. open a terminal and run gstreamer-properties
3. Go to the video tab
4. in the input area, click test
Result: web cam works

5. boot into 13.04
6. repeat steps 2-4

Result: The web cam is not detected
(noted that once the webcam *was* available in the Device dropdown)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-17-generic 3.8.0-17.27
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
Uname: Linux 3.8.0-17-generic x86_64
ApportVersion: 2.9.2-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: rick 2470 F.... pulseaudio
 /dev/snd/controlC1: rick 2470 F.... pulseaudio
 /dev/snd/controlC0: rick 2470 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Fri Apr 12 07:37:18 2013
HibernationDevice: RESUME=UUID=e9efb8d0-009e-4647-a134-e13e15b3b1ed
InstallationDate: Installed on 2012-11-04 (158 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Dell Inc. Studio Hybrid 140g
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-17-generic root=UUID=e4eb06cb-d4ba-40c3-ac8f-7af8f0973b69 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-17-generic N/A
 linux-backports-modules-3.8.0-17-generic N/A
 linux-firmware 1.105
RfKill:

SourcePackage: linux
StagingDrivers: r8712u
UpgradeStatus: Upgraded to raring on 2013-02-05 (65 days ago)
dmi.bios.date: 09/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.6
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 0P096C
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: '01'
dmi.modalias: dmi:bvnDellInc.:bvr1.0.6:bd09/26/2008:svnDellInc.:pnStudioHybrid140g:pvr00:rvnDellInc.:rn0P096C:rvrA01:cvnDellInc.:ct3:cvr'01':
dmi.product.name: Studio Hybrid 140g
dmi.product.version: 00
dmi.sys.vendor: Dell Inc.

Related branches

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
Joseph Salisbury (jsalisbury) wrote :

may be a duplicate of bug 1163268

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

It looks like there are multiple web cams on the system. Do both cams fail to work under Raring? Also, did the cameras never work under Raring, or did this just start happening after a recent update?

The two web cams visible to the system:

[ 5798.028050] usb 6-1: new full-speed USB device number 2 using uhci_hcd
[ 5798.225074] usb 6-1: New USB device found, idVendor=0ac8, idProduct=307b
[ 5798.225083] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5798.225088] usb 6-1: Product: PC Camera
[ 5798.225092] usb 6-1: Manufacturer: Vimicro Corp.

[ 3.592147] usb 2-2.1: new high-speed USB device number 5 using ehci-pci
[ 3.690640] usb 2-2.1: New USB device found, idVendor=05a9, idProduct=264a
[ 3.690647] usb 2-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3.690652] usb 2-2.1: Product: Monitor Webcam
[ 3.690657] usb 2-2.1: Manufacturer: OmniVision Technologies, Inc.538-2640-08.04.23.2
[ 3.690661] usb 2-2.1: SerialNumber: CN01234D5432125A0001A00

Joseph Salisbury (jsalisbury) wrote :

Failure in dmesg for the OmniVision camera:

[ 15.852208] Linux video capture interface: v2.00
[ 15.862741] uvcvideo: Found UVC 1.00 device Monitor Webcam (05a9:264a)
[ 15.866534] r8712u: module is from the staging directory, the quality is unknown, you have been warned.
[ 15.875181] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[ 15.875777] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
[ 15.875782] uvcvideo: Failed to initialize the device (-5).

Seth Forshee (sforshee) wrote :

Yep, I think those messages explain why the camera isn't showing up.

I can't find any obvious problems with the changes since 12.10 that would account for this. Seems like maybe a bisect is in order.

@4:
This one:
[ 5798.225088] usb 6-1: Product: PC Camera
[ 5798.225092] usb 6-1: Manufacturer: Vimicro Corp.
is a web cam that I had lying around. I attached it. It was detected by the system, but only displayed a black box, thought I suspect this is due to the camera, not Ubuntu

This is the one that I had always used and the one I care about:
[ 3.690652] usb 2-2.1: Product: Monitor Webcam
[ 3.690657] usb 2-2.1: Manufacturer: OmniVision Technologies, Inc.538-2640-08.04.23.2

Note that the failure is system wide. If I reboot, the camera sometimes becomes available in gstream-properties, after which it is available system wide.

Just for completeness sake, Rick provided me the following additional details via IRC:

[07:42:52] <rickspencer3> I plugged in an external webcam to test
[07:43:07] <rickspencer3> I hope it didn't contaminate the device data :/
[07:44:07] <ogasawara> is it only the built in monitor webcam that's broken?
[07:44:12] <ogasawara> ie did the external one work?
[07:44:21] <rickspencer3> well, the external one was detected
[07:44:24] <rickspencer3> but did not work
[07:44:27] <rickspencer3> just a black box :/

Changed in linux (Ubuntu Raring):
assignee: nobody → Kamal Mostafa (kamalmostafa)
status: Confirmed → In Progress
Kamal Mostafa (kamalmostafa) wrote :

@Rick-

The uvc_video driver contains a machine/model-specific quirk for a similar OmniVision webcam in a different Dell machine ("UVC_QUIRK_PROBE_DEF" in uvc_driver.c). Since you're getting "UVC non compliance - GET_DEF(PROBE) not supported", I suspect that the same quirk might be appropriate for the OmniVision cam in your machine also. Admittedly, that wouldn't by itself explain why your camera works in 12.10, but especially since the failure in Raring is not consistent, this is a logical thing to try.

So, here's a Raring kernel with the UVC_QUIRK_PROBE_DEF enabled for your machine model -- please install these two .deb's with "sudo dpkg -i *.deb":
   http://people.canonical.com/~kamal/lp1168430-omniwebcam/
Any change in behavior?

I installed the kernels in the link. I confirmed 4 times that the web cam now works fine. I booted into my previously installed .17 kernel, the web cam did not work. I booted back into the customer kernel. We cam worked again.

I ran:
dmesg | grep uvcvideo

The only output was:
[ 16.071908] uvcvideo: Found UVC 1.00 device Monitor Webcam (05a9:264a)
[ 16.072857] usbcore: registered new interface driver uvcvideo

Note that after booting into the .17 kernel, I had to reselect Monitor Webcam in the gstreamer-properties video tab.

tags: removed: kernel-key
Kamal Mostafa (kamalmostafa) wrote :

@Rick-

Thanks for the confirmation. I've submitted this patch for inclusion in the Raring kernel as well as the upstream Linux kernel.

The attachment "0001-media-uvcvideo-quirk-PROBE_DEF-for-Dell-Studio-OmniV.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Tim Gardner (timg-tpi) on 2013-04-16
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Kamal Mostafa (kamalmostafa) wrote :

Reference information. The output from 'lsusb -v -d 05a9:264a' is attached here (thanks, Rick).

Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package linux - 3.8.0-19.29

---------------
linux (3.8.0-19.29) raring; urgency=low

  [ Paolo Pisati ]

  * UBUNTU: [Config] disable PL330_DMA
    - LP: #1168039

  [ Rob Herring ]

  * UBUNTU: SAUCE: (no-up) ARM: highbank: fix cache flush ordering for cpu hotplug
    - LP: #1169956

  [ <email address hidden> ]

  * SAUCE: (no-up) x86: reboot: Make Dell Optiplex 390 use reboot=pci
    - LP: #800660

  [ Kamal Mostafa ]

  * SAUCE: [media] uvcvideo: quirk PROBE_DEF for Dell Studio / OmniVision
    webcam
    - LP: #1168430

  [ Upstream Kernel Changes ]

  * Revert "drivers/rtc/rtc-at91rm9200.c: use a variable for storing IMR"
    - LP: #1168506
  * Revert "PCI/ACPI: Request _OSC control before scanning PCI root bus"
    - LP: #1168506
  * Revert "tty/8250_pnp: serial port detection regression since v3.7"
    - LP: #1168506
  * ALSA: hda - fixup D3 pin and right channel mute on Haswell HDMI audio
    - LP: #1167270
  * ASoC: imx-ssi: Fix occasional AC97 reset failure
    - LP: #1168506
  * ASoC: dma-sh7760: Fix compile error
    - LP: #1168506
  * ASoC: spear_pcm: Update to new pcm_new() API
    - LP: #1168506
  * regmap: Initialize `map->debugfs' before regcache
    - LP: #1168506
  * regmap: cache Fix regcache-rbtree sync
    - LP: #1168506
  * MIPS: Fix logic errors in bitops.c
    - LP: #1168506
  * HID: magicmouse: fix race between input_register() and probe()
    - LP: #1168506
  * spi/s3c64xx: modified error interrupt handling and init
    - LP: #1168506
  * spi/mpc512x-psc: optionally keep PSC SS asserted across xfer segmensts
    - LP: #1168506
  * gpio: stmpe: pass DT node to irqdomain
    - LP: #1168506
  * UBIFS: make space fixup work in the remount case
    - LP: #1168506
  * reiserfs: Fix warning and inode leak when deleting inode with xattrs
    - LP: #1168506
  * ALSA: hda - bug fix on return value when getting HDMI ELD info
    - LP: #1168506
  * ALSA: hda - Enabling Realtek ALC 671 codec
    - LP: #1168506
  * ALSA: hda - fix typo in proc output
    - LP: #1168506
  * drm/nouveau: fix handling empty channel list in ioctl's
    - LP: #1168506
  * drm/i915: Be sure to turn hsync/vsync back on at crt enable (v2)
    - LP: #1168506
  * drm: correctly restore mappings if drm_open fails
    - LP: #1168506
  * mm: prevent mmap_cache race in find_vma()
    - LP: #1168506
  * EISA/PCI: Init EISA early, before PNP
    - LP: #1168506
  * EISA/PCI: Fix bus res reference
    - LP: #1168506
  * ixgbe: fix registration order of driver and DCA nofitication
    - LP: #1168506
  * libata: Use integer return value for atapi_command_packet_set
    - LP: #1168506
  * libata: Set max sector to 65535 for Slimtype DVD A DS8A8SH drive
    - LP: #1168506
  * MIPS: Unbreak function tracer for 64-bit kernel.
    - LP: #1168506
  * alpha: Add irongate_io to PCI bus resources
    - LP: #1168506
  * PCI/ACPI: Always resume devices on ACPI wakeup notifications
    - LP: #1168506
  * PCI/PM: Disable runtime PM of PCIe ports
    - LP: #1168506
  * ata_piix: Fix DVD not dectected at some Haswell platforms
    - LP: #1168506
  * ftrace: Consistently restore trace function on sysctl enabling
    - LP: #1168506
  * powerpc: pS...

Read more...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Jürgen Liebmann (k-info-1) wrote :

I have the same problem with webcam "Microsoft LifeCam NX-3000".
When I boot raring ringtail with kernel 3.5.0-27 it works fine. But with the actual kernel of raring ringtail (3.8.0-19, package linux - 3.8.0-19.30) it doesn't works.
Here the output from /var/log/syslog:

Kernel: 3.8.0-19-generic

May 3 07:46:44 master kernel: [ 61.441466] uvcvideo: Found UVC 1.00 device Microsoft LifeCam NX-3000 (045e:0721)
May 3 07:46:44 master kernel: [ 61.441923] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
May 3 07:46:44 master kernel: [ 61.442272] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
May 3 07:46:44 master kernel: [ 61.442275] uvcvideo: Failed to initialize the device (-5).
May 3 07:46:44 master kernel: [ 61.442350] usbcore: registered new interface driver uvcvideo
May 3 07:46:44 master kernel: [ 61.442352] USB Video Class driver (1.1.1)

Kernel: 3.5.0-27-generic

May 3 07:39:36 master kernel: [ 370.964836] uvcvideo: Found UVC 1.00 device Microsoft LifeCam NX-3000 (045e:0721)
May 3 07:39:36 master kernel: [ 370.965309] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
May 3 07:39:36 master kernel: [ 370.966042] input: Microsoft LifeCam NX-3000 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input15
May 3 07:39:36 master kernel: [ 370.966208] usbcore: registered new interface driver uvcvideo
May 3 07:39:36 master kernel: [ 370.966212] USB Video Class driver (1.1.1)

summary: - monitor webcam not detected (intermitent)
+ OmniVision webcam not detected (intermitent)
Kamal Mostafa (kamalmostafa) wrote :

@Jürgen- This bug and the patch that fixed it are relevant only for a particular OmniVision webcam model. If you are experiencing a similar issue with a different model of webcam, please file a separate new bug here on Launchpad. Submit the new bug report from the machine experiencing the problem so that Launchpad can record your hardware specifics.

spise (spise) wrote :

same problem with Microsoft LifeCam VX-7000

dmesg | grep uvcvideo
[ 21.702980] uvcvideo: Found UVC 1.00 device Microsoft\xffffffc2\xffffffae\xffffffae LifeCam VX-7000 (045e:0723)
[ 21.703336] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[ 21.703712] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
[ 21.703731] uvcvideo: Failed to initialize the device (-5).
[ 21.703769] usbcore: registered new interface driver uvcvideo

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers