highbank: network corruption

Bug #1168039 reported by Robie Basak on 2013-04-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Raring
High
Paolo Pisati

Bug Description

SRU Justification:

    Impact: network is not reliable
    Fix: see attached patch.
    Testcase: wget https://launchpad.net/ubuntu/+archive/primary/+files/mysql-5.5_5.5.29.orig.tar.gz, if it doesn't fail, you are good.

===

Affected: linux-image-3.8.0-17-generic
Not affected: 3.5.0-25-highbank

Test case (reliably reproducible):

wget https://launchpad.net/ubuntu/+archive/primary/+files/mysql-5.5_5.5.29.orig.tar.gz

Expected result: success

Actual result:

2013-04-11 12:22:11 (148 KB/s) - Read error at byte 24576/21554128 (error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac). Retrying.

The bug occurs on a Raring kernel only. The bug does not occur using a Quantal kernel in a Raring userspace.

It looks to me like TCP data is being corrupted post-TCP-checksum.

I could not submit this using "ubuntu-bug linux". I get a crash starting "http.client.BadStatusLine:" so it looks like the same issue is preventing it.

Related branches

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1168039

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Robie Basak (racb) wrote :

As described, the bug itself causes apport to fail.

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I'd like to perform a bisect to figure out what commit caused this regression. It would be very helpful to know the earliest kernel where the issue started happening as well as the latest kernel that did not have this issue.

Can you test the following kernels and report back? We are looking for the first kernel version that exhibits this bug:

v3.6 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/
v3.7 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-raring/
v3.8-rc1: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc1-raring/

You don't have to test every kernel, just up until the kernel that first has this bug.

One thing to note, you will need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

tags: added: raring
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: performing-bisect
Paolo Pisati (p-pisati) on 2013-04-12
Changed in linux (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
tags: removed: performing-bisect
Chris Van Hoof (vanhoof) wrote :

@Paolo -- Looks good!

ubuntu@c07:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/mysql-5.5_5.5.29.orig.tar.gz
--2013-04-12 12:51:27-- https://launchpad.net/ubuntu/+archive/primary/+files/mysql-5.5_5.5.29.orig.tar.gz
Resolving launchpad.net (launchpad.net)... 91.189.89.222, 91.189.89.223
Connecting to launchpad.net (launchpad.net)|91.189.89.222|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://launchpadlibrarian.net/128638930/mysql-5.5_5.5.29.orig.tar.gz [following]
--2013-04-12 12:51:27-- https://launchpadlibrarian.net/128638930/mysql-5.5_5.5.29.orig.tar.gz
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 21554128 (21M) [application/gzipped-tar]
Saving to: ‘mysql-5.5_5.5.29.orig.tar.gz’

100%[============================================================>] 21,554,128 1.59MB/s in 11s

2013-04-12 12:51:39 (1.85 MB/s) - ‘mysql-5.5_5.5.29.orig.tar.gz’ saved [21554128/21554128]

ubuntu@c07:~$ cat /proc/version_signature
Ubuntu 3.8.0-18.28~NOpl330-generic 3.8.6

ubuntu@c07:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04
Codename: raring

Paolo Pisati (p-pisati) on 2013-04-17
description: updated
Tim Gardner (timg-tpi) on 2013-04-17
Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package linux - 3.8.0-19.29

---------------
linux (3.8.0-19.29) raring; urgency=low

  [ Paolo Pisati ]

  * UBUNTU: [Config] disable PL330_DMA
    - LP: #1168039

  [ Rob Herring ]

  * UBUNTU: SAUCE: (no-up) ARM: highbank: fix cache flush ordering for cpu hotplug
    - LP: #1169956

  [ <email address hidden> ]

  * SAUCE: (no-up) x86: reboot: Make Dell Optiplex 390 use reboot=pci
    - LP: #800660

  [ Kamal Mostafa ]

  * SAUCE: [media] uvcvideo: quirk PROBE_DEF for Dell Studio / OmniVision
    webcam
    - LP: #1168430

  [ Upstream Kernel Changes ]

  * Revert "drivers/rtc/rtc-at91rm9200.c: use a variable for storing IMR"
    - LP: #1168506
  * Revert "PCI/ACPI: Request _OSC control before scanning PCI root bus"
    - LP: #1168506
  * Revert "tty/8250_pnp: serial port detection regression since v3.7"
    - LP: #1168506
  * ALSA: hda - fixup D3 pin and right channel mute on Haswell HDMI audio
    - LP: #1167270
  * ASoC: imx-ssi: Fix occasional AC97 reset failure
    - LP: #1168506
  * ASoC: dma-sh7760: Fix compile error
    - LP: #1168506
  * ASoC: spear_pcm: Update to new pcm_new() API
    - LP: #1168506
  * regmap: Initialize `map->debugfs' before regcache
    - LP: #1168506
  * regmap: cache Fix regcache-rbtree sync
    - LP: #1168506
  * MIPS: Fix logic errors in bitops.c
    - LP: #1168506
  * HID: magicmouse: fix race between input_register() and probe()
    - LP: #1168506
  * spi/s3c64xx: modified error interrupt handling and init
    - LP: #1168506
  * spi/mpc512x-psc: optionally keep PSC SS asserted across xfer segmensts
    - LP: #1168506
  * gpio: stmpe: pass DT node to irqdomain
    - LP: #1168506
  * UBIFS: make space fixup work in the remount case
    - LP: #1168506
  * reiserfs: Fix warning and inode leak when deleting inode with xattrs
    - LP: #1168506
  * ALSA: hda - bug fix on return value when getting HDMI ELD info
    - LP: #1168506
  * ALSA: hda - Enabling Realtek ALC 671 codec
    - LP: #1168506
  * ALSA: hda - fix typo in proc output
    - LP: #1168506
  * drm/nouveau: fix handling empty channel list in ioctl's
    - LP: #1168506
  * drm/i915: Be sure to turn hsync/vsync back on at crt enable (v2)
    - LP: #1168506
  * drm: correctly restore mappings if drm_open fails
    - LP: #1168506
  * mm: prevent mmap_cache race in find_vma()
    - LP: #1168506
  * EISA/PCI: Init EISA early, before PNP
    - LP: #1168506
  * EISA/PCI: Fix bus res reference
    - LP: #1168506
  * ixgbe: fix registration order of driver and DCA nofitication
    - LP: #1168506
  * libata: Use integer return value for atapi_command_packet_set
    - LP: #1168506
  * libata: Set max sector to 65535 for Slimtype DVD A DS8A8SH drive
    - LP: #1168506
  * MIPS: Unbreak function tracer for 64-bit kernel.
    - LP: #1168506
  * alpha: Add irongate_io to PCI bus resources
    - LP: #1168506
  * PCI/ACPI: Always resume devices on ACPI wakeup notifications
    - LP: #1168506
  * PCI/PM: Disable runtime PM of PCIe ports
    - LP: #1168506
  * ata_piix: Fix DVD not dectected at some Haswell platforms
    - LP: #1168506
  * ftrace: Consistently restore trace function on sysctl enabling
    - LP: #1168506
  * powerpc: pS...

Read more...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in linux (Ubuntu):
assignee: Paolo Pisati (p-pisati) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers