[HP 1000] Screen backlight is off after startup.

Bug #1167760 reported by Po-Hsu Lin on 2013-04-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Alex Hung
Nominated for Quantal by James M. Leddy

Bug Description

cid: 201209-11731, 201209-11735 (two machines with the same model)

The screen backlight is automatically set to off after boot/reboot (after the Ubuntu logo screen).
Using the brightness adjustment key on the keyboard can bring the lights back.
Kernel upgrade won't help.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-23-generic 3.5.0-23.35~precise1
ProcVersionSignature: Ubuntu 3.5.0-23.35~precise1-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1486 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x52600000 irq 44'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,103c1854,00100202 HDA:80862806,80860101,00100000'
   Controls : 24
   Simple ctrls : 10
Date: Wed Apr 10 23:11:39 2013
HibernationDevice: RESUME=UUID=126e9e5b-4a26-4964-8eae-020440f19e70
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: Hewlett-Packard HP 1000 Notebook PC
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-23-generic root=UUID=cf922830-da62-4875-bbe2-f7d81abe55c4 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-23-generic N/A
 linux-backports-modules-3.5.0-23-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/25/2012
dmi.bios.vendor: Insyde
dmi.bios.version: F.22
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 1854
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 64.22
dmi.chassis.asset.tag: 72414P100R
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.22:bd10/25/2012:svnHewlett-Packard:pnHP1000NotebookPC:pvr0698100000005300000630000:rvnHewlett-Packard:rn1854:rvr64.22:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP 1000 Notebook PC
dmi.product.version: 0698100000005300000630000
dmi.sys.vendor: Hewlett-Packard

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Ara Pulido (ara) on 2013-04-11
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Alex Hung (alexhung)
Alex Hung (alexhung) on 2013-05-06
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Alex Hung (alexhung) wrote :

This bug is caused by BIOS reporting zero in _BQC when system boots up. As a result, kernel will set the brightness to zero and the screen is dimmed to complete black.

The attached patch adds a quirk to ignore the initial _BQC value and set the brightness to max.

tags: added: patch
Changed in linux (Ubuntu):
importance: Undecided → High
James M. Leddy (jm-leddy) wrote :

for reference, here is the patchwork: https://patchwork.kernel.org/patch/2523381/

Slated for 3.10

James M. Leddy (jm-leddy) wrote :

We should SRU this for quantal in the meantime so we can certify.

James M. Leddy (jm-leddy) wrote :

this patch is also making its way through the stable trees.

Alex Hung (alexhung) on 2013-07-11
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Anthony Wong (anthonywong) wrote :

The patch already landed in Quantal, Raring and mainline kernels.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.