Haswell HDMI Audio: Pin remains in D3 state

Bug #1167270 reported by David Henningsson on 2013-04-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
Linux
New
Undecided
Unassigned
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
David Henningsson
Nominated for Precise by David Henningsson
Nominated for Quantal by David Henningsson

Bug Description

When trying to enable HDMI audio on Haswell machines we sometimes come across the following symptom:

 - No audio output
 - When looking at the /proc/asound/cardX/codecX file, it shows for the active pin node, that the right channel is muted and that the pin is in D3 (powersave) mode.
 - It might be that this problem only happens when the computer is connected to AC power, and not when it's running on battery power.

Related branches

David Henningsson (diwic) wrote :
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

Example from the /proc/asound/cardX/codecX file:

Node 0x05 [Pin Complex] wcaps 0x40778d: 8-Channels Digital Amp-Out CP
    Control: name="HDMI/DP,pcm=3 Jack", index=0, device=0
    Control: name="IEC958 Playback Con Mask", index=0, device=0
    Control: name="IEC958 Playback Pro Mask", index=0, device=0
    Control: name="IEC958 Playback Default", index=0, device=0
    Control: name="IEC958 Playback Switch", index=0, device=0
    Control: name="ELD", index=0, device=3
    Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
    Amp-Out vals: [0x00 0x80] <---------------- Look here; they should be [0x00 0x00]
    Pincap 0x0b000094: OUT Detect HBR HDMI DP
    Pin Default 0x18560010: [Jack] Digital Out at Int HDMI
      Conn = Digital, Color = Unknown
      DefAssociation = 0x1, Sequence = 0x0
    Pin-ctls: 0x40: OUT
    Unsolicited: tag=01, enabled=1
    Power states: D0 D3 EPSS
    Power: setting=D3, actual=D3 <---------------- Look here; it should be D0
    Connection: 3
       0x02* 0x03 0x04

David Henningsson (diwic) wrote :

DKMS package for easy testing (on top of linux-image-generic-lts-quantal kernel). Includes the latest ALSA HDA driver plus the patch just posted.

description: updated
description: updated
tags: added: patch
tags: added: blocks-hwcert-enablement
David Henningsson (diwic) wrote :

This has now been committed to master-next in ubuntu-raring as well as Takashi's sound tree.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (7.6 KiB)

This bug was fixed in the package linux - 3.8.0-19.29

---------------
linux (3.8.0-19.29) raring; urgency=low

  [ Paolo Pisati ]

  * UBUNTU: [Config] disable PL330_DMA
    - LP: #1168039

  [ Rob Herring ]

  * UBUNTU: SAUCE: (no-up) ARM: highbank: fix cache flush ordering for cpu hotplug
    - LP: #1169956

  [ <email address hidden> ]

  * SAUCE: (no-up) x86: reboot: Make Dell Optiplex 390 use reboot=pci
    - LP: #800660

  [ Kamal Mostafa ]

  * SAUCE: [media] uvcvideo: quirk PROBE_DEF for Dell Studio / OmniVision
    webcam
    - LP: #1168430

  [ Upstream Kernel Changes ]

  * Revert "drivers/rtc/rtc-at91rm9200.c: use a variable for storing IMR"
    - LP: #1168506
  * Revert "PCI/ACPI: Request _OSC control before scanning PCI root bus"
    - LP: #1168506
  * Revert "tty/8250_pnp: serial port detection regression since v3.7"
    - LP: #1168506
  * ALSA: hda - fixup D3 pin and right channel mute on Haswell HDMI audio
    - LP: #1167270
  * ASoC: imx-ssi: Fix occasional AC97 reset failure
    - LP: #1168506
  * ASoC: dma-sh7760: Fix compile error
    - LP: #1168506
  * ASoC: spear_pcm: Update to new pcm_new() API
    - LP: #1168506
  * regmap: Initialize `map->debugfs' before regcache
    - LP: #1168506
  * regmap: cache Fix regcache-rbtree sync
    - LP: #1168506
  * MIPS: Fix logic errors in bitops.c
    - LP: #1168506
  * HID: magicmouse: fix race between input_register() and probe()
    - LP: #1168506
  * spi/s3c64xx: modified error interrupt handling and init
    - LP: #1168506
  * spi/mpc512x-psc: optionally keep PSC SS asserted across xfer segmensts
    - LP: #1168506
  * gpio: stmpe: pass DT node to irqdomain
    - LP: #1168506
  * UBIFS: make space fixup work in the remount case
    - LP: #1168506
  * reiserfs: Fix warning and inode leak when deleting inode with xattrs
    - LP: #1168506
  * ALSA: hda - bug fix on return value when getting HDMI ELD info
    - LP: #1168506
  * ALSA: hda - Enabling Realtek ALC 671 codec
    - LP: #1168506
  * ALSA: hda - fix typo in proc output
    - LP: #1168506
  * drm/nouveau: fix handling empty channel list in ioctl's
    - LP: #1168506
  * drm/i915: Be sure to turn hsync/vsync back on at crt enable (v2)
    - LP: #1168506
  * drm: correctly restore mappings if drm_open fails
    - LP: #1168506
  * mm: prevent mmap_cache race in find_vma()
    - LP: #1168506
  * EISA/PCI: Init EISA early, before PNP
    - LP: #1168506
  * EISA/PCI: Fix bus res reference
    - LP: #1168506
  * ixgbe: fix registration order of driver and DCA nofitication
    - LP: #1168506
  * libata: Use integer return value for atapi_command_packet_set
    - LP: #1168506
  * libata: Set max sector to 65535 for Slimtype DVD A DS8A8SH drive
    - LP: #1168506
  * MIPS: Unbreak function tracer for 64-bit kernel.
    - LP: #1168506
  * alpha: Add irongate_io to PCI bus resources
    - LP: #1168506
  * PCI/ACPI: Always resume devices on ACPI wakeup notifications
    - LP: #1168506
  * PCI/PM: Disable runtime PM of PCIe ports
    - LP: #1168506
  * ata_piix: Fix DVD not dectected at some Haswell platforms
    - LP: #1168506
  * ftrace: Consistently restore trace function on sysctl enabling
    - LP: #1168506
  * powerpc: pS...

Read more...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
Changed in intel:
status: New → Confirmed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers