Elantech clickpad/touchpad lacks multitouch features.

Bug #1166442 reported by G.Scoppino on 2013-04-08
364
This bug affects 70 people
Affects Status Importance Assigned to Milestone
linux (Arch Linux)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury
Quantal
Medium
Joseph Salisbury
Raring
Medium
Joseph Salisbury
Saucy
Medium
Joseph Salisbury

Bug Description

Newer versions of the Elantech multitouch trackpad are not fully supported in Linux. These appear in many of the newer Samsung laptops, for example. elantech.c in the kernel needs to be updated to support these models (up to v7 perhaps?)

This bug is confirmed to affect a range of samsung laptops running Ubuntu 12.04 and newer, ArchLinux, Fedora and also affects the current (3.9) upstream kernel.

A dkms package was produced in 2011 (see https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/681904/comments/64) which may fix certain older laptops affected by this issue, but doesn't fix newer models.

== Original Report ==

Hello,

So far I've been having a problem with my Elantech multitouch trackpad in Linux. Basically all i get is right click, left click, and tap to click, along with basic movement. The problem seems to be rooted in improper detection of the trackpad, likely b/c its a new revision or whatnot. Of note is that working elantech trackpads of the past in forums i scouted through show up as "ETPS/2 Elantech Touchpad". Mine just shows up in xinput as "PS/2 Elantech Touchpad". I think this might be a simple fix in the end, just improper detection, I hope. For reference, I've tried kernel 3.5 on Ubuntu 12.10 and kernel 3.8.0-17 on Ubuntu 13.04 thus far, with all combinations of psmouse.
------------------------------------------------------------------------------------------
What's expected: touchpad multitouch support
What happened: basic touchpad support
Laptop mode: Samsung Series 7 NP780 series
Ubuntu distro(s) tested: Ubuntu 12.10, Ubuntu 13.04
Kernels used: 3.5 signed (Ubuntu 12.10 default), 3.8.0-16, 3.8.0-17 signed
Other tests: Attempted using psmouse-elantech-v6, psmouse-alps, and psmouse-alps-dst. No improvements so removed.

synclient -l reports "Couldn't find synaptics properties. No synaptics driver loaded?"
------------------------------------------------------------------------------------------
See attached for more info. Ask anything you need!
---
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gscoppino 2272 F.... pulseaudio
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=f683852c-7aa0-4f32-8b86-56f0a018989d
InstallationDate: Installed on 2013-04-06 (3 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 770Z5E/780Z5E/870Z5E/880Z5E
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-17-generic.efi.signed root=UUID=cf39fbe5-c8ff-4d16-b11e-a41a4f3ae955 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-17-generic N/A
 linux-backports-modules-3.8.0-17-generic N/A
 linux-firmware 1.104
StagingDrivers: rts5139
Tags: raring staging
Uname: Linux 3.8.0-17-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-04-06 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/26/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P03ABU.139.130226.SK
dmi.board.asset.tag: No Asset Tag
dmi.board.name: NP780Z5E-S01UB
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SEC_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP03ABU.139.130226.SK:bd02/26/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn770Z5E/780Z5E/870Z5E/880Z5E:pvrP03ABU:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP780Z5E-S01UB:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 770Z5E/780Z5E/870Z5E/880Z5E
dmi.product.version: P03ABU
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
---
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gscoppino 2272 F.... pulseaudio
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=f683852c-7aa0-4f32-8b86-56f0a018989d
InstallationDate: Installed on 2013-04-06 (3 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 770Z5E/780Z5E/870Z5E/880Z5E
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-17-generic.efi.signed root=UUID=cf39fbe5-c8ff-4d16-b11e-a41a4f3ae955 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-17-generic N/A
 linux-backports-modules-3.8.0-17-generic N/A
 linux-firmware 1.104
StagingDrivers: rts5139
Tags: raring staging
Uname: Linux 3.8.0-17-generic x86_64
UpgradeStatus: Upgraded to raring on 2013-04-06 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/26/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P03ABU.139.130226.SK
dmi.board.asset.tag: No Asset Tag
dmi.board.name: NP780Z5E-S01UB
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: SEC_SW_REVISION_1234567890ABCD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP03ABU.139.130226.SK:bd02/26/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn770Z5E/780Z5E/870Z5E/880Z5E:pvrP03ABU:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP780Z5E-S01UB:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: 770Z5E/780Z5E/870Z5E/880Z5E
dmi.product.version: P03ABU
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

G.Scoppino (peppe1994) wrote :
G.Scoppino (peppe1994) wrote :
G.Scoppino (peppe1994) wrote :
G.Scoppino (peppe1994) wrote :
G.Scoppino (peppe1994) wrote :
G.Scoppino (peppe1994) wrote :
description: updated
description: updated
description: updated
G.Scoppino (peppe1994) on 2013-04-08
tags: added: elantech
tags: added: 12.10 13.04 clickpad multitouch np780 synaptics touchpad trackpad ubuntu
Ahmed Shams (ashams) wrote :

moving to kernel

affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1166442

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated
15 comments hidden view all 184 comments

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
G.Scoppino (peppe1994) wrote :

Uploaded apport info (twice by accident :P ) and changed the status. Thanks for the quick feedback guys!

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0]. You will need to install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc6-raring/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
G.Scoppino (peppe1994) on 2013-04-10
tags: added: kernel-unable-to-test-upstream
G.Scoppino (peppe1994) on 2013-04-15
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
djo (stadja) on 2013-05-13
tags: added: np730u3e
Bryce Harrington (bryce) on 2013-06-05
description: updated
tags: added: patch
Changed in linux (Ubuntu Precise):
status: New → In Progress
Changed in linux (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Medium
Changed in linux (Ubuntu Saucy):
importance: Low → Medium
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Raring):
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Precise):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Quantal):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Raring):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Saucy):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Saucy):
status: Confirmed → In Progress
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Released
Brad Figg (brad-figg) on 2013-08-01
tags: added: verification-needed-precise
tags: added: verification-needed-quantal
Brad Figg (brad-figg) on 2013-08-01
tags: added: verification-needed-raring
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-done-raring
removed: verification-needed-raring
Brad Figg (brad-figg) on 2013-08-04
tags: added: verification-done-precise verification-done-quantal
removed: verification-needed-precise verification-needed-quantal
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
104 comments hidden view all 184 comments
Daniel (skorka-b) wrote :

Reporting that this fixes the touchpad on an Sony SVF13N1L2ES. Horizontal and vertical scrolling works. Two finger clicking works as well. xinput shows many new properties for the touchpad.

Thanks a lot! Could you notify us when the patch makes it into the kernel, so we know when to remove this dkms module?

Best regards,
Daniel

cosmin (wizardelo) wrote :

Fixed also for Lenovo z710 Elantech Touchpad!
thank you.

nicobrainless (nicoseb) wrote :

Unfortunately, I have to report that, alike dave-egressive, this did not fix the issue for me.

I have the same laptop, Gygabyte U2442, and tried basically the same thread as he did.
The only thing I have ever figured out is how to get the 3-button emulation (i.e. copy-paste) adding line in my bash_rc...

It's been over 6 months and I sometimes end up booting on Windows just to be able to browse more easily!

kendatsuba, any way you might be able to help us out since you seemed to have a better understanding of the underlying issue?

Thank you.

PS: I am on ubuntu 14.04 alpha (since a couple of days), thought the newer kernel might help (I saw in another thread a few months back that 3.11 was bringing some fixes, these did not work for me when installing a 3.11 version on my ubuntu 13.10...)

Dave Gilbert (ubuntu-treblig) wrote :

lightweight/nocobrainless: Hmm given that the fix in this bug fixes something for some group of people, but you're still having issues, please open separate bugs for them.

Add a comment here with the new bug number, and in your new bug add a comment saying you think it might be related to this one.

lightweight (dave-egressive) wrote :

Thanks Dave - as per your recommendation for people with the Gigabyte U2442 laptop series (and perhaps others) for whom the fixes above don't work, I've created a new bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1272777

Sirtaj Singh Kang (sirtaj) wrote :

Confirming kendatsuba's patch fixes the issue on Toshiba Satellite E55-A5114. Touchpad was reporting "PS/2" instead of "ETPS/2" without the patch.

All functions appear to be working correctly after patching, without any need for configuration in xorg.conf.

Usul_ (usul-) wrote :

kendatsuba patch partially fixed he problem in my Asus pu301LA. Unfortunately, after installing the new module as suggested in comment #137, the right buton stopped working and the left button is sometimes recognized as the secondary button in a not predictable fashion. Tap and two finger scrolling works.
Any suggestion?

Usul_ (usul-) wrote :

Correction: also the tap does not works. Both tapping and clicking on the left button is recognized as "left click", "right click" or even "central click" unpredictably...
Unfortunately, this behaviour makes the new patch unusable. How do I remove the new module and revert to the original one?
Thanks.

Usul_ (usul-) wrote :

I forgot to mention that I am running Ubuntu 14.04 Beta 1 with kernel 3.13.0-18-generic x86_64

The instructions from kendatsuba in comment 136 worked for me. Installing the psmouse-elantech-x551c.tar.gz dkms module fixed the touchpad on my Toshiba Satellite E55-A5114 running Ubuntu Saucy (64bit)

nicobrainless (nicoseb) wrote :

@kendatsuba or anyone here who seemed to have a good understanding of these elantech issues, could you take a look at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442 and maybe make some suggestions to fix it for Gigabyte users... :(

Vincent Gerris (vgerris) wrote :

Just wanted to report that the fix from post #137 works for my Lenovo Yoga 2 11.
dmesg reported before:
[ 16.922014] input: PS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input7
and after
[ 3990.888082] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input112

thanks a bunch!
Should this somehow be reported to be included in the Ubuntu 14.04 kernel?
I updated today and have:
3.13.0-19-generic #40-Ubuntu SMP Mon Mar 24 02:36:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

weesnich (einstilz) wrote :

Also affects me on Samsung 900X3G with 14.04!
#137 did not work for me!
3+ finger gestures do not work.
I want my multitouch gestures back!

87dv (87dv) wrote :

Same on Asus X54HY (X54LY)
Ubuntu 14.04.1

I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input11
U: Uniq=
H: Handlers=mouse0 event4
B: PROP=1
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003

KZ (kzcabstone) wrote :

Verified that with fix in post #137, I can now use multi-touch on my Lenovo Y50 touch.

florin (floryn-todor) wrote :

Yes, I can confirm that fix in post #137 helped me too for Lenovo Y50-70 in order to enable multi-touch. Befor that pach the touchpad was nod detected (two finger scroll not working).

lz50 (launch-j) wrote :

Post #137 broke the right click for my Lenovo Z50. But the solution in http://superuser.com/questions/619582/right-elantech-touchpad-button-not-working-in-linux fixed it. But that solution broke the middle button emulation.
Ubuntu 14.04.1
http://superuser.com/questions/619582/right-elantech-touchpad-button-not-working-in-linux

Gabe (gabe565) wrote :

The fix in comment #137 also fixed my touchpad being detected on my Lenovo U530, and now two-finger scrolling works!

Only problem is that now there seems to be a slight (but noticeable) input lag. Does anybody else have this issue?

Gabe (gabe565) wrote :
Daniel Ceregatti (dlniel) wrote :

I'm still having to rmmod psmouse and modprobe psmouse after every boot. Upon boot, dmesg shows this:

[ 4.929432] psmouse serio1: elantech: unknown hardware version, aborting...

But after I rmmod and modprobe dmesg reports this:

[ 1750.169375] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x495f01)
[ 1750.179735] psmouse serio1: elantech: Synaptics capabilities query result 0x70, 0x15, 0x0e.

There is only one psmouse.ko in /lib/modules:

$ find /lib/modules -name psmouse.ko
/lib/modules/3.13.0-24-generic/updates/psmouse.ko

Sure, "locate psmouse.ko" finds the old module that dkms backed up in /var/lib/dkms/psmouse/original_module/3.13.0-24-generic/x86_64/psmouse.ko, but surely this isn't the one that's loading on boot, right? It seems something else is going on. I just wish I knew what. Thoughts?

lohith (lohithmv019) wrote :

Its not working after updating to new kernel version 3.13.0-35-generic ,new patches are available ?

Daniel Ceregatti (dlniel) wrote :

Answering my own question: Turns out the old psmouse was in the initramfs so running update-initramfs -u -k all and rebooting fixed it.

Also attempting to answer lohith's question: You have re-install the driver for every new kernel until support is added upstream. Just repeat the dkms commands, and run the update-initramfs command above, and you should be good.

Thor K. H. (nitrolinken) wrote :

Regarding comment #137 and its effect, I feel it is worthwhile mentioning that the ldtarball does not work for the ElanTech touchpad within the Fujitsu Celsius H730.

There, the touchpad does not _work at all_, unlike here where multitouch features are a miss. There's bug #1300427 for that issue though, but these two seem somewhat related.

If there is any data that would be relevant to this bug, then I'd be glad to provide it.

Matt (daringseal) wrote :

I'm using an ASUS TP500L laptop running 14.04 with an Elantech touchpad. Xinput lists it as an "ETPS/2 Elantech Touchpad" initially and Unity settings shows me the Touchpad area. However, it is entirely unresponsive to any form of input. I have tried the fix in #137 and it changes nothing. I have tried a couple of other dkms based fixes which have the same effect as reloading the psmouse with a bare protocol, giving me a generic PS/2 mouse and no multitouch or scrolling features. Should I post any logs?

Ali Najafi (alinajafi) wrote :

#137 and #167 helped me on Lenovo G5070 to have multitouch working (edge scrolling, two-finger scrolling, two-finger right-click, right and middle clicks on corners). However it broke the physical right click.

mika (mikavour) wrote :

I just want to report that Elantech touch-pad still not working in a new asus tp500la with bios verison 203, under ubuntu 14.04, 64bit, kernel version 3.13.0-40-generic. The touch-pad is recognized as PS/ Elanctech BUT is not working at all (no response at all) After
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
the touch pad is recognized as PS mouse. BUT there is no touch-pad functionality, which means no scrolling, no two finger click, and most important, no deactivation during typing.

Damon Hartman (area51pilot) wrote :

Same issue for me. Latest attempt was loading Kernel 3.18 but still inop as full feature touchpad. Can only load and use as a ps2/mouse.

Trent Robbins (robbintt) wrote :

Fix #137 worked for me:

Linux patterntop 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Lenovo Z50-70
aka Lenovo Z50 70

Trent Robbins (robbintt) wrote :

Fix #137 worked for me when combined with the modification/bugfix in #161:

Linux patterntop 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Lenovo Z50-70
aka Lenovo Z50 70

HOWEVER - this broke my right click exactly as described in #161. I opted to keep the broken right touch pad because the double tap seems to bring up the right click menu.

After thinking about it, I implemented the fix in the #161 link to the tar.gz file provided in #137.

This is verified working! Thanks everyone and #161 I hope you either figured this out or see this.

Talorin (talorin) wrote :

@Trent Robbins
Can you post the joined (#161 & #137) fix?

Dasder Letzte (ulmales) wrote :

@ Daniel Ceregatti
had the same problem that I had to reenter rmmod/modprobe after every boot, but update-initramfs -u -k all solved it for me as well - thanks!

@Trent Robbins
Can you post the joined fix (#161 & #137) ? i'm having the same problem.

dormux (0926889-o) wrote :

Hi there. I combined #161 with #137. Rightclick and multitouch now working on my Lenovo g50-70. Like @Trent Robbins verified, this should also fix the rightclick issue on the z50-70. You can use the dkms package from the attachment using:

sudo dkms ldtarball psmouse-elantech-x551c-G50-70.tar.gz
sudo dkms install -m psmouse -v elantech-x551c-G50-70

sudo rmmod psmouse
sudo modprobe psmouse

Trent Robbins (robbintt) wrote :

@dormux Are you occasionally getting an error where your mouse doesn't work and you have to rmmod psmouse / modprobe psmouse to reset the driver?

dormux (0926889-o) wrote :

Hi. No never experienced such behaviour. I'm using the modified driver since i wrote these lines above and never had any issues.

Alessio Treglia (quadrispro) wrote :

This affects my laptop (Lenovo Yoga 3 11.6" 2-in-1):

ubuntu@ubuntu:~$ lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 006: ID 8087:07dc Intel Corp.
Bus 002 Device 005: ID 1bcf:2c43 Sunplus Innovation Technology Inc.
Bus 002 Device 004: ID 04f3:2052 Elan Microelectronics Corp.
Bus 002 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 002 Device 002: ID 058f:6387 Alcor Micro Corp. Flash Drive
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Presumably the touchpad is the following line then:
  Bus 002 Device 004: ID 04f3:2052 Elan Microelectronics Corp.

Excerpt of /proc/bus/input/devices:

I: Bus=0018 Vendor=04f3 Product=0400 Version=0100
N: Name="ELAN0600:00 04F3:0400"
P: Phys=
S: Sysfs=/devices/pci0000:00/INT3433:00/i2c-8/i2c-ELAN0600:00/0018:04F3:0400.0003/input/input13
U: Uniq=
H: Handlers=mouse1 event12
B: PROP=0
B: EV=17
B: KEY=30000 0 0 0 0
B: REL=143
B: MSC=10

The touchscreen works fine, as well as both left and right clicks. Just the multitouch doesn't work at all.

More details on the system:

ubuntu@ubuntu:~$ uname -a
Linux ubuntu 3.16.0-23-generic #31-Ubuntu SMP Tue Oct 21 17:56:17 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
ubuntu@ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic

Also I grepped syslog for elan:
ubuntu@ubuntu:~$ grep -i elan /var/log/syslog
Feb 17 01:53:37 ubuntu kernel: [ 17.373586] usb 2-5: Manufacturer: ELAN
Feb 17 01:53:38 ubuntu kernel: [ 28.061105] input: ELAN Touchscreen as /devices/pci0000:00/0000:00:14.0/usb2/2-5/2-5:1.0/0003:04F3:2052.0001/input/input11
Feb 17 01:53:38 ubuntu kernel: [ 28.067747] hid-multitouch 0003:04F3:2052.0001: input,hiddev0,hidraw0: USB HID v1.10 Device [ELAN Touchscreen] on usb-0000:00:14.0-5/input0
Feb 17 01:53:38 ubuntu kernel: [ 28.272108] i2c_hid i2c-ELAN0600:00: error in i2c_hid_init_report size:633 / ret_size:7
Feb 17 01:53:38 ubuntu kernel: [ 28.274418] i2c_hid i2c-ELAN0600:00: error in i2c_hid_init_report size:69 / ret_size:7
Feb 17 01:53:38 ubuntu kernel: [ 28.274589] input: ELAN0600:00 04F3:0400 as /devices/pci0000:00/INT3433:00/i2c-8/i2c-ELAN0600:00/0018:04F3:0400.0003/input/input13
Feb 17 01:53:38 ubuntu kernel: [ 28.275039] hid-generic 0018:04F3:0400.0003: input,hidraw1: <UNKNOWN> HID v1.00 Mouse [ELAN0600:00 04F3:0400] on

AFAICS the issue still affects Vivid too.

Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Alessio Treglia (quadrispro) wrote :

ubuntu@ubuntu:~$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ELAN Touchscreen id=9 [slave pointer (2)]
⎜ ↳ ELAN0600:00 04F3:0400 id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Lenovo EasyCamera id=10 [slave keyboard (3)]
    ↳ Ideapad extra buttons id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

tags: removed: 12.10 13.04 kernel-unable-to-test-upstream staging ubuntu
George Moutsopoulos (gmoutso) wrote :

mika, I also have the asus TP500LN and this seems to be a different problem to this bug.

Description of bug is mouse does not work at all. Dmesg gives "lost sync at byte 6" messages. Mouse does work with proto=imps parameter but no two-finger functionality. If this is the same with you, after sudo su try
echo 1 > /sys/devices/platform/i8042/serio4/reg_07
(or serioX?)
and see if it fixes the issue.

For at least asus TP500LN a kernel patch is under consideration
https://bugzilla.kernel.org/show_bug.cgi?id=84491
https://www.marc.info/?t=142731893400011
Many thanks to Ulrik de Bie!

Perhaps you can post on bugzilla that it affects TP500LA too.

George Moutsopoulos (gmoutso) wrote :

Forgot @mika: Elantech device ETD0108

Displaying first 40 and last 40 comments. View all 184 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.