14e4:4359 [Lenovo ThinkPad Edge E530 3259] Can't install Broadcom STA driver.

Bug #1166371 reported by Jeff Marcom on 2013-04-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Alberto Milone
Precise
Undecided
Unassigned

Bug Description

[Lenovo E530]: Can't Broadcom STA driver.

Jockey reports error when installing broadcom STA driver. bcmwl-kernel-source and linux-headers-generic are installed and available.

Jockey-log output from installation:

ubuntu@201003-5465:~$ sudo jockey-text --auto-install
Additional Drivers
Searching for available drivers...

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log

2013-04-08 13:43:41,311 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-04-08 13:43:41,317 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2013-04-08 13:43:41,505 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2013-04-08 13:43:41,506 WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver
2013-04-08 13:43:41,540 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

OS: 12.04.2
Kernel: Linux 201003-5465 3.5.0-26-generic #42~precise1-Ubuntu

Card:
03:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n
 Subsystem: Broadcom Corporation Device 0607

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-26-generic 3.5.0-26.42~precise1
ProcVersionSignature: Ubuntu 3.5.0-26.42~precise1-generic 3.5.7.6
Uname: Linux 3.5.0-26-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1681 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xe4a10000 irq 47'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:14f1506e,17aa500b,00100002 HDA:80862806,80860101,00100000'
   Controls : 26
   Simple ctrls : 11
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Apr 8 13:44:43 2013
HibernationDevice: RESUME=UUID=01b37af9-2b27-4db4-91c6-12cfaae3d5ee
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
IwConfig:
 wwan0 no wireless extensions.

 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: LENOVO 3259SIU
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic root=UUID=0a1b297a-1e54-4ea7-aa01-530e8bf7c4fd ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-26-generic N/A
 linux-backports-modules-3.5.0-26-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/23/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: H0ET31WW (1.13 )
dmi.board.asset.tag: Not Available
dmi.board.name: 3259SIU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrH0ET31WW(1.13):bd05/23/2012:svnLENOVO:pn3259SIU:pvrThinkPadEdgeE530:rvnLENOVO:rn3259SIU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3259SIU
dmi.product.version: ThinkPad Edge E530
dmi.sys.vendor: LENOVO

Jeff Marcom (jeffmarcom) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)
tags: added: 201202-10641 blocks-hw-cert lexington-lab
Jeff Marcom (jeffmarcom) wrote :

Adding jockey installation log

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: quantal

i JUST WENT THROUGH THIS.

Attempt to install your wifi driver. If it install your done. If it say's BLACKLISTED or check log file /var/log/jockey.log OPEN A TERMINAL and run "sudo gedit /var/log/jockey.log" if it has a series of errors scroll to bottom and see if it lists drivers as BLACKLIST.
If so, run "sudo ls /etc/modprobe.d/" and it will return something like
alsa-base.conf blacklist.conf blacklist-oss.conf blacklist-ath_pci.conf
blacklist-firewire.conf blacklist-rare-network.conf dkms.conf
blacklist-bcm43.conf blacklist-framebuffer.conf blacklist-watchdog.conf iwlwifi.conf
blacklist-modem.conf broadcom-sta-common.conf vmwgfx-fbdev.conf
figure out witch ones have your drivers in it. I used:
blacklist-bcm43.conf
broadcom-sta-common.conf
blacklist.conf
using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" unblacklist the driver using (# driver ). The comments at the top of the file is guide for commenting. Do this for each PERTINENT file. Reboot.
YOU THINK IT WOULD HAVE WORKED BUT NOOOOO! using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" FOR each PERTINENT file and comment out every blacklisted driver from your manufacturer.
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
# blacklist b43
# blacklist b43legacy
# blacklist ssb
# blacklist bcm43xx
# blacklist brcm80211
# blacklist brcmfmac
# blacklist brcmsmac
# blacklist bcma
THIS WORKED FOR ME!!!!!!!!!!!!!!!!!!!!!!

Jeff Marcom (jeffmarcom) on 2013-04-12
summary: - [Lenovo E530]: Can't Broadcom STA driver.
+ [Lenovo E530]: Can't install Broadcom STA driver.
Ara Pulido (ara) on 2013-04-29
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → Haitao Zhang (minipanda)
importance: Undecided → High

@Haitao, please take a look at this bug, thanks

Changed in linux (Ubuntu):
assignee: Haitao Zhang (minipanda) → Alberto Milone (albertomilone)
massipinam (massimo-pinamonti) wrote :

dell inspiron 1545 kubuntu 13.04 kernel 3.9.3-pf it can't recognize wifi-nets cause "module wl not found". Here the last part of jockey.log

2013-06-04 21:00:18,269 DEBUG: Installing package: linux-headers-
2013-06-04 21:00:18,764 ERROR: enabling kmod:wl: Unable to install kernel header package linux-headers-
2013-06-04 21:00:18,919 WARNING: modinfo for module wl failed: ERROR: Module wl not found.
2013-06-04 21:00:18,991 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted

here modprobe

root@massimo-Inspiron-1545:~# modprobe -r b43 ssb wl
FATAL: Module wl not found.
root@massimo-Inspiron-1545:~# modprobe wl
FATAL: Module wl not found.

and here lspci

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

summary: - [Lenovo E530]: Can't install Broadcom STA driver.
+ 14e4:4359 [Lenovo ThinkPad Edge E530 3259] Can't install Broadcom STA
+ driver.
tags: added: bios-outdated-2.52
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Changed in linux (Ubuntu Precise):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu Precise) because there has been no activity for 60 days.]

Changed in linux (Ubuntu Precise):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers