BCM57766 (present in 2012 Apple products) is not detected by tg3 module

Bug #1162665 reported by Eugene San on 2013-04-01
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Raring
Medium
Joseph Salisbury

Bug Description

The BCM57766 not detected by tg3 driver, but there seems to be a fix:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d3f677afb8076d09d090ff0a5d1229c9dd9f136e
---
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: eugenesan 2029 F.... pulseaudio
DistroRelease: Ubuntu 13.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-04-17 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130416)
MachineType: Apple Inc. Macmini6,1
MarkForUpload: True
NonfreeKernelModules: wl
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-16-generic root=UUID=8a49d15e-5f56-4300-b7a7-bcadf35b6252 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-16.26~lp1162665v1-generic 3.8.5
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-16-generic N/A
 linux-backports-modules-3.8.0-16-generic N/A
 linux-firmware 1.105
Tags: raring
Uname: Linux 3.8.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 11/16/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MM61.88Z.0106.B03.1211161202
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-031AEE4D24BFF0B1
dmi.board.vendor: Apple Inc.
dmi.board.version: Macmini6,1
dmi.chassis.type: 16
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-031AEE4D24BFF0B1
dmi.modalias: dmi:bvnAppleInc.:bvrMM61.88Z.0106.B03.1211161202:bd11/16/2012:svnAppleInc.:pnMacmini6,1:pvr1.0:rvnAppleInc.:rnMac-031AEE4D24BFF0B1:rvrMacmini6,1:cvnAppleInc.:ct16:cvrMac-031AEE4D24BFF0B1:
dmi.product.name: Macmini6,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Eugene San (eugenesan) on 2013-04-01
description: updated

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1162665

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Eugene San (eugenesan) wrote :

All required information already referenced in bug description.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

It looks like the commit you mentioned is in v3.9-rc1:
git describe --contains d3f677afb8076d09d090ff0a5d1229c9dd9f136e
v3.9-rc1~139^2~61

Can you test the v3.9-rc1 kernel to confirm it resolves this bug? If it does, we can submit an SRU request to have that commit included in raring.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

I'll also build a raring test kernel with commit d3f677afb8076d09d090ff0a5d1229c9dd9f136e applied and post a link to it shortly.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
tags: added: raring
Joseph Salisbury (jsalisbury) wrote :

I built a test kernel with commit d3f677afb8076d09d090ff0a5d1229c9dd9f136e applied. The test kernel can be downloaded from:

http://people.canonical.com/~jsalisbury/lp1162665/

Can you test that kernel and report back if it has the bug or not.

One thing to note, you will need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Eugene San (eugenesan) wrote :

Sorry for delay, device was shipping to me.

Just finished testing.

3.8.0-16.26~lp1162665v1 from http://people.canonical.com/~jsalisbury/lp1162665/ and
3.9.0-030900rc6.201304080035 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc6-raring/ are perfectly working!

Unfortunately I wasn't able to perfrom "apport-collect 1162665".
I get "ERROR: The launchpadlib Python module is not installed. This functionality is not available".

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

tags: added: kernel-fixed-upstream
Joseph Salisbury (jsalisbury) wrote :

Sent SRU request for inclusion in the v3.8.y upstream stable kernel as well as the Raring kernel.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
Tim Gardner (timg-tpi) on 2013-04-18
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
description: updated
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
James Cameron (quozl) wrote :

Did install from ubuntu-13.04-desktop-amd64+mac.iso on Macmini6,1 and built-in ethernet did fail, symptoms matched as above in this ticket.

Did add USB ethernet, enable proposed, install new kernel -20, remove USB ethernet, reboot, and the built-in ethernet was enabled.

Did several scp of large files to confirm.

Eugene San (eugenesan) on 2013-05-13
tags: added: verification-done
removed: verification-needed-raring
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
James Cameron (quozl) wrote :

After an update, linux-image-3.8.0-21-generic 3.8.0-21.32 was installed from raring-security, and this problem has come back. Will downgrade.

Joseph Salisbury (jsalisbury) wrote :

HI James,

Thanks for the update. This bug should be fixed in Ubuntu-3.8.0-20.31. So it sounds like there is a regression in 3.8.0-21.32 now? I also see a new bug reported similar to this: bug 1182868

I'm going to work this new regression in that new bug. It would be great if you can post to that bug as well.

Thanks in advance!

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

James Cameron (quozl) wrote :

G'day Joseph, thanks for the bug reference, I've posted an update to bug #1182868.

Summary: 3.8.0-20.31 works fine, but 3.8.0-21.32 and 3.8.0-22.33 do not detect the tg3 ethernet device.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers