[MacBookAir3,1] Running iwconfig crashes (freezes) requiring hard reboot

Bug #1159232 reported by Sean Sosik-Hamor on 2013-03-23
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

Running iwconfig in a terminal freezes X on my MacBookAir3,1 requiring a hard reboot. Screen is totally frozen and accepts no keyboard or mouse input. Unable to Ctrl-Alt-F1 to console.

Mar 23 16:48:09 medic kernel: [ 1022.517346] general protection fault: 0000 [#1] SMP
Mar 23 16:48:09 medic kernel: [ 1022.517354] Modules linked in: nvidia(POF) snd_hda_codec_hdmi snd_hda_codec_cirrus coretemp kvm_intel kvm ip6t_REJECT(F) xt_hl(F) ip6t_rt(F) nf_conntrack_ipv6(F) nf_defrag_ipv6(F) joydev(F) ipt_REJECT(F) xt_comment(F) xt_LOG(F) xt_limit(F) xt_tcpudp(F) xt_addrtype(F) snd_hda_intel nf_conntrack_ipv4(F) nf_defrag_ipv4(F) snd_hda_codec snd_hwdep(F) xt_state(F) lib80211_crypt_tkip snd_pcm(F) ip6table_filter(F) ip6_tables(F) nf_conntrack_netbios_ns(F) nf_conntrack_broadcast(F) nf_nat_ftp(F) applesmc nf_nat(F) nf_conntrack_ftp(F) nf_conntrack(F) iptable_filter(F) input_polldev ip_tables(F) uvcvideo x_tables(F) videobuf2_vmalloc snd_page_alloc(F) videobuf2_memops videobuf2_core snd_seq_midi(F) microcode(F) snd_seq_midi_event(F) videodev snd_rawmidi(F) wl(POF) bcm5974 btusb lib80211 snd_seq(F) rfcomm parport_pc(F) bnep ppdev(F) snd_seq_device(F) cfg80211 bluetooth shpchp snd_timer(F) apple_bl mac_hid snd(F) soundcore(F) binfmt_misc(F) lp(F) parport(F) ext2(F) xts(F) gf128mul(F) hid_gene
Mar 23 16:48:09 medic kernel: ric dm_crypt(F) hid_apple usbhid hid video(F)
Mar 23 16:48:09 medic kernel: [ 1022.517434] CPU 1
Mar 23 16:48:09 medic kernel: [ 1022.517439] Pid: 5678, comm: iwconfig Tainted: PF O 3.8.0-13-generic #23-Ubuntu Apple Inc. MacBookAir3,1/Mac-942452F5819B1C1B
Mar 23 16:48:09 medic kernel: [ 1022.517443] RIP: 0010:[<ffffffff8169abd1>] [<ffffffff8169abd1>] wireless_process_ioctl+0x91/0x1b0
Mar 23 16:48:09 medic kernel: [ 1022.517454] RSP: 0018:ffff880094af7d80 EFLAGS: 00010206
Mar 23 16:48:09 medic kernel: [ 1022.517457] RAX: ffff88013462d000 RBX: 0000000000008b09 RCX: 01c623e401c623e4
Mar 23 16:48:09 medic kernel: [ 1022.517459] RDX: 01c623e401c623e4 RSI: ffff880094af7e20 RDI: ffff88013462d000
Mar 23 16:48:09 medic kernel: [ 1022.517462] RBP: ffff880094af7da8 R08: 0000000000000000 R09: ffffffff8169c3a0
Mar 23 16:48:09 medic kernel: [ 1022.517465] R10: 0000000000000001 R11: 0000000000000246 R12: ffffffff8169c3a0
Mar 23 16:48:09 medic kernel: [ 1022.517467] R13: ffffffff8169b710 R14: ffff880094af7dbc R15: ffff880094af7e20
Mar 23 16:48:09 medic kernel: [ 1022.517470] FS: 00007fb0add82740(0000) GS:ffff88013fd00000(0000) knlGS:0000000000000000
Mar 23 16:48:09 medic kernel: [ 1022.517473] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Mar 23 16:48:09 medic kernel: [ 1022.517476] CR2: 00007fb0ad975073 CR3: 000000007b4a5000 CR4: 00000000000407e0
Mar 23 16:48:09 medic kernel: [ 1022.517478] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Mar 23 16:48:09 medic kernel: [ 1022.517481] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Mar 23 16:48:09 medic kernel: [ 1022.517484] Process iwconfig (pid: 5678, threadinfo ffff880094af6000, task ffff8800a1732e80)
Mar 23 16:48:09 medic kernel: [ 1022.517485] Stack:
Mar 23 16:48:09 medic kernel: [ 1022.517487] 0000000000000000 0000000000008b09 ffff880094af7e20 ffffffff81cbb640
Mar 23 16:48:09 medic kernel: [ 1022.517492] 00007fffed20ec00 ffff880094af7de8 ffffffff8169b8e4 00008b0994af7e40
Mar 23 16:48:09 medic kernel: [ 1022.517497] 0000000000008b09 00007fffed20ec00 ffff880094af7e20 00000000ffffffe7
Mar 23 16:48:09 medic kernel: [ 1022.517502] Call Trace:
Mar 23 16:48:09 medic kernel: [ 1022.517508] [<ffffffff8169b8e4>] wext_handle_ioctl+0x74/0xd0
Mar 23 16:48:09 medic kernel: [ 1022.517514] [<ffffffff815cb44e>] dev_ioctl+0xce/0x5a0
Mar 23 16:48:09 medic kernel: [ 1022.517521] [<ffffffff815b0202>] sock_ioctl+0xf2/0x2b0
Mar 23 16:48:09 medic kernel: [ 1022.517526] [<ffffffff811a5809>] do_vfs_ioctl+0x99/0x570
Mar 23 16:48:09 medic kernel: [ 1022.517532] [<ffffffff811f751e>] ? proc_reg_read+0x8e/0xc0
Mar 23 16:48:09 medic kernel: [ 1022.517536] [<ffffffff811a5d71>] sys_ioctl+0x91/0xb0
Mar 23 16:48:09 medic kernel: [ 1022.517542] [<ffffffff816ce6ce>] ? do_page_fault+0xe/0x10
Mar 23 16:48:09 medic kernel: [ 1022.517547] [<ffffffff816d2cdd>] system_call_fastpath+0x1a/0x1f
Mar 23 16:48:09 medic kernel: [ 1022.517549] Code: 02 00 00 48 8b 90 70 01 00 00 48 85 c9 0f 84 80 00 00 00 48 8b 09 48 85 c9 74 78 48 85 d2 48 8b 89 90 03 00 00 0f 84 bf 00 00 00 <0f> b7 72 08 8d 8b 00 75 ff ff 39 f1 72 51 0f b7 72 0a 8d 8b 20
Mar 23 16:48:09 medic kernel: [ 1022.517594] RIP [<ffffffff8169abd1>] wireless_process_ioctl+0x91/0x1b0
Mar 23 16:48:09 medic kernel: [ 1022.517599] RSP <ffff880094af7d80>
Mar 23 16:48:09 medic kernel: [ 1022.517603] ---[ end trace e8fa2cf87f23b10f ]---

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: wireless-tools 30~pre9-8ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.9.2-0ubuntu2
Architecture: amd64
Date: Sat Mar 23 16:53:15 2013
InstallationDate: Installed on 2013-03-23 (0 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64+mac (20130320)
MarkForUpload: True
SourcePackage: wireless-tools
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sciri 2394 F.... pulseaudio
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=48d61547-b366-4cdb-a076-c62853f03e7c
InstallationDate: Installed on 2013-03-23 (11 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64+mac (20130320)
MachineType: Apple Inc. MacBookAir3,1
MarkForUpload: True
NonfreeKernelModules: nvidia wl
Package: linux (not installed)
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-15-generic root=/dev/mapper/ubuntu--vg-root ro
ProcVersionSignature: Ubuntu 3.8.0-15.25-generic 3.8.4
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-15-generic N/A
 linux-backports-modules-3.8.0-15-generic N/A
 linux-firmware 1.104
Tags: raring
Uname: Linux 3.8.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm lpadmin sambashare sudo
dmi.bios.date: 01/24/12
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B07.1201241641
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942452F5819B1C1B
dmi.board.vendor: Apple Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942452F5819B1C1B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B07.1201241641:bd01/24/12:svnAppleInc.:pnMacBookAir3,1:pvr1.0:rvnAppleInc.:rnMac-942452F5819B1C1B:rvr1.0:cvnAppleInc.:ct10:cvrMac-942452F5819B1C1B:
dmi.product.name: MacBookAir3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Sean Sosik-Hamor (sciri) wrote :
Brian Murray (brian-murray) wrote :

This seems more like a bug in the kenrel to me but I could be wrong.

affects: wireless-tools (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1159232

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc5-raring/

Changed in linux (Ubuntu):
importance: Undecided → High

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Marking Confirmed after uploading logs per request in Comment #3.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Sean Sosik-Hamor (sciri) wrote :

Unfortunately I'm unable to test further because native Raring became completely unusable on MacBookAir3,1 due to LP Bug #576648 so I switched to running virtualized Raring. I'll continue testing when I switch back to native.

Pedro Santos (zubirus) wrote :

Had the same problem on a MacBook air 5.1; uninstalling wicd-daemon reset the system to a usable state

Maxence Dolle (yaitanes) wrote :

I have the same problem with this kernel (3.8). So I just tested with the 3.9 kernel but it can't be built :

DKMS make.log for bcmwl-6.20.155.1+bdcom for kernel 3.9.0-030900rc6-generic (x86_64)
vendredi 10 mai 2013, 11:16:03 (UTC+0200)
make: entrant dans le répertoire « /usr/src/linux-headers-3.9.0-030900rc6-generic »
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  LD /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/built-in.o
  CC [M] /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/shared/linux_osl.o
  CC [M] /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_linux.o
  CC [M] /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_iw.o
  CC [M] /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.o
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1578:2: attention : initialization from incompatible pointer type [enabled by default]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1578:2: attention : (near initialization for ‘wl_cfg80211_ops.set_tx_power’) [enabled by default]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1579:2: attention : initialization from incompatible pointer type [enabled by default]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:1579:2: attention : (near initialization for ‘wl_cfg80211_ops.get_tx_power’) [enabled by default]
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c: In function ‘wl_update_bss_info’:
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:2025:3: attention : passing argument 1 of ‘cfg80211_put_bss’ from incompatible pointer type [enabled by default]
In file included from /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:33:0:
include/net/cfg80211.h:3302:6: note: expected ‘struct wiphy *’ but argument is of type ‘struct cfg80211_bss *’
/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:2025:3: erreur: too few arguments to function ‘cfg80211_put_bss’
In file included from /var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.c:33:0:
include/net/cfg80211.h:3302:6: note: declared here
make[1]: *** [/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build/src/wl/sys/wl_cfg80211.o] Erreur 1
make: *** [_module_/var/lib/dkms/bcmwl/6.20.155.1+bdcom/build] Erreur 2
make: quittant le répertoire « /usr/src/linux-headers-3.9.0-030900rc6-generic »

Shall I report another bug for this? I tested with the 3.9, 3.9rc9, 3.8rc6 kernels but it's exactly the same.

Diego (gran-diego) wrote :

my HP dm1-4120ss netbook (amd e-450, broadcom bcm4313 running ubuntu 13.04 64 bits fully updated) also has exactly this problem

Peter Koczan (peter-koczan) wrote :

Still an issue on macbook pro 6 2, 64bit, latest dist on 13.04. iwconfig -> instant crash

Sean Sosik-Hamor, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Hello everybody,

I have the same issue on a fresh install of Kubuntu 13.04 -- install done with the development CD downloaded on the 20/08/2013.

In attachment the output of dmesg after one of those crash.

I run the apport-collect script (first time, hope it will be ok).

ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: mbailly 2031 F.... pulseaudio
 /dev/snd/controlC0: mbailly 2031 F.... pulseaudio
DistroRelease: Ubuntu 13.04
HibernationDevice: RESUME=UUID=177e9e76-a458-418a-9619-9559aba47d49
InstallationDate: Installed on 2013-08-21 (20 days ago)
InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: Dell Inc. Latitude E6510
MarkForUpload: True
NonfreeKernelModules: wl
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-30-generic root=UUID=50a53b2c-d1b9-47dd-8497-941a37c201af ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-30.44-generic 3.8.13.6
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-30-generic N/A
 linux-backports-modules-3.8.0-30-generic N/A
 linux-firmware 1.106
Tags: raring
Uname: Linux 3.8.0-30-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/15/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0N5KHN
dmi.board.vendor: Dell Inc.
dmi.board.version: A03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd02/15/2011:svnDellInc.:pnLatitudeE6510:pvr0001:rvnDellInc.:rn0N5KHN:rvrA03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6510
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Marc Bailly-Bechet, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

hewfish (hewfish) wrote :

I can confirm that I have the same issue and I can reproduce it on a Dell Latitude Laptop running Xubuntu 13.04. Mine occurs every time that I execute "airmon-ng start (interface)" on any wireless interface. So there definitely seems to be a correlation with the wireless drivers or interfaces. I get a kernel crash, but can partially recover by CTRL+ALT+F1 then switch back to X with ALT+F7.

I have also tried with an external USB wireless card and had the same result.

Indeed I found that CTRL+ALT+F1 then ALT+F7 allowed me to come back to my session, but with some features sometimes not working (http access with firefox, task bar in kubuntu...).

I upgraded to Kubuntu 13.10 Beta 1 (this page: http://www.kubuntu.org/news/kubuntu-1310-beta-1) at the beginning of the week. From that moment I had no more trouble with this issue -- hopefully it won't come back.

Maybe upgrade?

Marc

hewfish, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Marc Bailly-Bechet, see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1159232/comments/47 .

summary: - Running iwconfig crashes (freezes) MacBookAir3,1 requiring hard reboot
+ [MacBookAir3,1] Running iwconfig crashes (freezes) requiring hard
+ reboot
hewfish (hewfish) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers