[HP Pavilion dv6-6023tx Entertainment Notebook PC] SD card inaccesible: mmc0: error -110 whilst initialising SD card

Bug #1158982 reported by Woody on 2013-03-22
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce:
inserts SD card. Nothing happens.
See dmesg has output: mmc0: error -110 whilst initialising SD card
I tried this on kernel 3.5.0-21-generic and SD card works fine.
I will have to try my other kernels to see which ones are affected and which aren't.
EDIT: just discovered that this only affects certain SD cards.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-26-generic 3.5.0-26.42
ProcVersionSignature: Ubuntu 3.5.0-26.42-generic 3.5.7.6
Uname: Linux 3.5.0-26-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: user 2180 F.... pulseaudio
Date: Sat Mar 23 08:04:53 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-12-15 (97 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Hewlett-Packard HP Pavilion dv6 Notebook PC
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_NZ:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-26-generic root=UUID=ac88e046-9ff1-406e-bf0c-075e8092196c ro acpi_backlight=vendor pcie_aspm=force quiet splash vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/user not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-26-generic N/A
 linux-backports-modules-3.5.0-26-generic N/A
 linux-firmware 1.95
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/05/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.1B
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1657
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 10.31
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.1B:bd10/05/2011:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr0595100000244710000020100:rvnHewlett-Packard:rn1657:rvr10.31:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 0595100000244710000020100
dmi.sys.vendor: Hewlett-Packard

Woody (wo0dy) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Just tested and kernel 3.5.0-21-generic. It is not affected.

Woody (wo0dy) on 2013-03-23
description: updated
tags: added: regression-update
Woody (wo0dy) on 2013-03-23
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc4-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Woody (wo0dy) wrote :

Running 3.9.0-030900rc4-generic
Sd card is mounting properly.
I Looked at dmesg and don't see any errors related to sd card so I assume this is fixed upstream.
I tested copying and pasting files back on the card and its all working .

I get a crash report prompt for udisksd. Not sure if this is related but its probably something else as sdcard is working fine.

No problem : ) Glad I can help out.

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Woody (wo0dy) on 2013-04-09
description: updated
Mike C. (miguelmclara-c) wrote :

I was facing the same problem with 3.8, updated to 3.9 but its exactly the same:

dmesg:
[ 3219.307280] mmc0: card e624 removed
[ 3456.883573] mmc0: error -110 whilst initialising SD card
[ 3458.295000] mmc0: error -110 whilst initialising SD card
[ 3459.706588] mmc0: error -110 whilst initialising SD card

lspci -v
13:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
 Subsystem: Hewlett-Packard Company Device 1657
 Flags: bus master, fast devsel, latency 0, IRQ 50
 Memory at c3500000 (32-bit, non-prefetchable) [size=4K]
 Expansion ROM at c2400000 [disabled] [size=64K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Device Serial Number 00-00-00-01-00-4c-e0-00
 Kernel driver in use: rtsx_pci

Tried with a SDHC Class 10 (Sandisk) and a Micro SD adapter, both give the same error!

Adam D (ethnoe) wrote :

Just solved the same problem on my HP Spectre 14.

The rtsx_pci driver is not suited for RTS 5209 reader. You need to download specific driver from Realtek ( http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false ), extract it and install using:

make
make install
depmod -a
modprobe rts_pstor

Last two commands require root privileges. Now check lspci -v once again, you should see something like:

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
        Subsystem: Hewlett-Packard Company Device 1893
        Flags: bus master, fast devsel, latency 0, IRQ 43
        Memory at f6800000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-00-00-01-00-4c-e0-00
        Kernel driver in use: rtsx_pci
        Kernel modules: rts_pstor, rtsx_pci

It means, that kernel is still using the wrong driver. Unload rtsx_pci:

modprobe -r rtsx_pci
depmod -a

(if modprobe whines about some dependencies for this modul, unload them as well). Now reload rts_pstor (modprobe -r, modprobe). The reader should work like a charm now. You should blacklist rtsx_pci, so it won't load after reboot. Just add

blacklist rtsx_pci

to /etc/modprobe.d/blacklist.conf. Hope this helps!

Peter Funk (pf-artcom-gmbh) wrote :

I'm using Ubuntu 13.04 on a clevo laptop equipped with the following chip according to lspci -v
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
 Subsystem: CLEVO/KAPOK Computer Device 7102
 Flags: bus master, fast devsel, latency 0, IRQ 44
 Memory at f7a00000 (32-bit, non-prefetchable) [size=64K]
 Capabilities: <access denied>
 Kernel driver in use: rtsx_pci

The SD-CARD reader works just fine with kernel 3.11.0-999-generic #201308290442 from
mainline build.
But with 3.8.0-29-generic #42-Ubuntu it says: mmc0: error -110 whilst initialising SD card

Any chance to get this fixed in 13.04? I can't use the mainline build in 13.04 because my virtual
machines stopped working to some other incompatibility.

Best regards, Peter.

Marco Russo (russomarco) wrote :

I've tried the solution in comment #7 and it worked partially for me, because the SD card shows up only if I insert it before booting, otherwise I need to reboot to see it. If I give the lspci -v command, the card reader isn't even listed. A workaround is using this command (you need to be root):

echo 1 > /sys/bus/pci/rescan

Obviously this is not the best of solutions. Does anyone know how to fix it? Is it a problem of driver not loading at boot time? Do I have to add something to /etc/modules?

Peter Funk (pf-artcom-gmbh) wrote :

I'm now running kernel 3.11.0-031100-generic #201309021735 and now my SDcard reader works just fine with this kernel. The problems I had with Scard reader with the 3.8.0-31 kernel from Ubuntu 13.04 were solved for me by upgrading to the mainline kernel.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Woody (wo0dy) wrote :

Its an HP Pavilion dv6-6023tx Entertainment Notebook PC . Bios is up to date.

summary: - SD card inaccesible: mmc0: error -110 whilst initialising SD card
+ [HP Pavilion dv6-6023tx Entertainment Notebook PC] SD card inaccesible:
+ mmc0: error -110 whilst initialising SD card
tags: added: latest-bios-f.1b
Woody (wo0dy) wrote :

I only know what it says on the cards. Any command that I could use to check the specs? Or specifically what info are you after?

Doesn't work: EMTEC 60x speed 1GB
Works: Transcend 2GB (no speed marked)
There are some numbers that look like serial numbers on the back. Would they be of help?

tags: added: kernel-fixed-upstream-v3.9-rc4
removed: kernel-fixed-upstream
Woody (wo0dy) wrote :

The EMTEC card:
S466MN01GI0BC
0740070901961

The Transcend card:
MMAUF02G4ACA - MP
D HEH107GK 243
Made in KOREA
and 90 degrees to that is written:
A49220 3929

You going to get some similar sd cards and do some tests? Kernel bisects?

Woody, thank you for the serial numbers. Unfortunately, I do not have the same hardware as you, so I wouldn't be able to do any such testing.

Despite this, could you please test trusty via http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Woody (wo0dy) wrote :

Yes. It was already downloading. I'll let you know once I've tested.

Woody (wo0dy) wrote :

Tested and it works fine on 14.04 daily. No errors related to the sd card in dmesg.

Woody, thank you for testing 14.04 daily. Would you need a backport to a release prior to 14.04 or may this be closed as Status Invalid?

Woody (wo0dy) wrote :

Its fixed upstream. Thats the main thing.

I have an external card reader which works so I'll be fine without a backport. I mean it would be nice, but I don't think this is very high priority.

Woody, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Trusty Tahr.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers