XPS 13 LCD backlight control does not work after suspend / resume

Bug #1158076 reported by Dylan McCall on 2013-03-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This is with a Dell XPS 13, running up to date Raring. After suspend / resume, I am unable to adjust screen brightness. As in bug #1055231, functionality is restored after I run /bin/echo 0 > /sys/class/backlight/intel_backlight/brightness, but of course that's horrible and unpleasant.

This appears to be a recent regression in Raring, though I could be imagining that it worked before. It would have only been fixed this cycle, at any rate. For Quantal, the kernel provided by ~canonical-hwe-team includes working backlight control.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-13-generic 3.8.0-13.23
ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
ApportVersion: 2.9.2-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dylan 2110 F.... pulseaudio
Date: Wed Mar 20 18:28:41 2013
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=ffc5e214-6367-4148-81c1-f6141dc80e9e
InstallationDate: Installed on 2012-06-21 (272 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Dell System XPS L321X
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=UUID=330825ac-c3a7-461a-aec1-b99756d9701d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-13-generic N/A
 linux-backports-modules-3.8.0-13-generic N/A
 linux-firmware 1.104
SourcePackage: linux
UpgradeStatus: Upgraded to raring on 2013-03-14 (6 days ago)
dmi.bios.date: 04/09/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 085X6F
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd04/09/2012:svnDellInc.:pnDellSystemXPSL321X:pvr:rvnDellInc.:rn085X6F:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L321X
dmi.sys.vendor: Dell Inc.

Dylan McCall (dylanmccall) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc3-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers