Ubuntu

System freezes after kernel upgrade

Reported by Jonathan Lumb on 2013-03-19
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I am running Ubuntu Precise (12.04). My system was recently updated to kernel version 3.2.0-39.62 and since the upgrade, the system freezes shortly after login and I have to hit the power button to restart the machine. I have now downgraded to the previous kernel (3.2.0-38.61) which works fine.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1+elementary3~precise1
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jonolumb 3351 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e00000 irq 54'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,1043102b,00100100 HDA:80862805,10431d42,00100000'
   Controls : 30
   Simple ctrls : 14
DistroRelease: elementary OS 0.2
HibernationDevice: RESUME=UUID=ac452737-b4ec-4e34-b228-629ef08a335e
InstallationMedia: elementary OS 0.2 "Luna" - Beta 1 i386 (20121114)
MachineType: ASUSTeK Computer Inc. U24E
MarkForUpload: True
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-38-generic-pae root=UUID=1b26faa2-2b50-40ee-95f1-ad152f4339d5 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-38.61-generic-pae 3.2.37
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-38-generic-pae N/A
 linux-backports-modules-3.2.0-38-generic-pae N/A
 linux-firmware 1.79.1
StagingDrivers: rts5139 mei
Tags: luna staging
Uname: Linux 3.2.0-38-generic-pae i686
UnreportableReason: This is not an official elementary package. Please remove any third party package and try again.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 12/14/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: U24E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr205:bd12/14/2011:svnASUSTeKComputerInc.:pnU24E:pvr1.0:rvnASUSTeKComputerInc.:rnU24E:rvr1.0:cvnASUSTeKComputerInc.:ct9:cvr1.0:
dmi.product.name: U24E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Jonathan Lumb (jonolumb) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1157252

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: precise regression-update
Changed in linux (Ubuntu):
importance: Medium → High
tags: added: apport-collected running-unity staging
tags: removed: apport-collected running-unity staging

apport information

tags: added: apport-collected luna staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Jonathan Lumb (jonolumb) wrote :

Please note that the attachments above were generated after having downgraded my kernel to 3.2.0-38.61 to resolve the problem.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

apport information

And this was also marked as possibly related
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1157786

psychok7 (nunok7) wrote :

i have the same problem on ubuntu 12.04 x64.
3.2.0-38 works fine. but update 3.2.0-39 and the new one 3.2.0-40 freeze my system after a while and i have to turn of my computer on the button.
I also have an intel graphic card.

BuelentR (amodent2) wrote :

OOOHHH, I so much hoped kernel 3.2.0-40 will solve my weeks-old problem, now I read this - what to do now? I do not dare to update with this info!!!! Any ideas?

Colin Tingey (colintingey) wrote :

I have the same problem too, 3.2.0-40 does the same as 3.2.0-39 and freezes shortly after logging in, so I am still having to use 3.2.0-38.

Can anybody help please?

Craig McQueen (cmcqueen1975) wrote :

This is happening to me too. It started with kernel 3.2.0-39, and also happens in kernel 3.2.0-40 and 3.2.0-41, although with 3.2.0-41 it ran okay for a few minutes before crashing. (I'm also running the -pae variant of the kernel.)

Julian Wiedmann (jwiedmann) wrote :

Jonathan Lumb,

could you please test the latest kernel in -updates (3.2.0-41.66) and see if this bug is still reproducible? Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jonathan Lumb (jonolumb) wrote :

I have now upgraded to 3.2.0-41.66 and can confirm that I am no longer seeing this bug.

Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers