CX23880 PCI Video and Audio Decoder driver not autoloaded

Bug #115719 reported by Greg Taylor on 2007-05-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned

Bug Description

I've got an ATI All-In-Wonder TV PCI that isn't being recognized by default. Here's the lspci:

00:0e.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
00:0e.0 0400: 14f1:8800 (rev 05)

And the relevant dmesg output:

[ 38.998185] Linux video capture interface: v2.00
[ 39.045649] cx2388x v4l2 driver version 0.0.6 loaded
[ 39.045727] ACPI: PCI Interrupt 0000:00:0e.0[A] -> GSI 17 (level, low) -> IRQ 19
[ 39.045777] cx88[0]: Your board isn't known (yet) to the driver. You can
[ 39.045778] cx88[0]: try to pick one of the existing card configs via
[ 39.045780] cx88[0]: card=<n> insmod option. Updating to the latest
[ 39.045781] cx88[0]: version might help as well.
[ 39.045783] cx88[0]: Here is a list of valid choices for the card=<n> insmod option:
[ 39.045786] cx88[0]: card=0 -> UNKNOWN/GENERIC
[ 39.045788] cx88[0]: card=1 -> Hauppauge WinTV 34xxx models
[ 39.045790] cx88[0]: card=2 -> GDI Black Gold
[ 39.045791] cx88[0]: card=3 -> PixelView
[ 39.045793] cx88[0]: card=4 -> ATI TV Wonder Pro
[ 39.045795] cx88[0]: card=5 -> Leadtek Winfast 2000XP Expert
[ 39.045796] cx88[0]: card=6 -> AverTV Studio 303 (M126)
[ 39.045798] cx88[0]: card=7 -> MSI TV-@nywhere Master
[ 39.045800] cx88[0]: card=8 -> Leadtek Winfast DV2000
[ 39.045810] cx88[0]: card=9 -> Leadtek PVR 2000
[ 39.045812] cx88[0]: card=10 -> IODATA GV-VCP3/PCI
[ 39.045814] cx88[0]: card=11 -> Prolink PlayTV PVR
[ 39.045816] cx88[0]: card=12 -> ASUS PVR-416
[ 39.045818] cx88[0]: card=13 -> MSI TV-@nywhere
[ 39.045820] cx88[0]: card=14 -> KWorld/VStream XPert DVB-T
[ 39.045822] cx88[0]: card=15 -> DViCO FusionHDTV DVB-T1
[ 39.045824] cx88[0]: card=16 -> KWorld LTV883RF
[ 39.045826] cx88[0]: card=17 -> DViCO FusionHDTV 3 Gold-Q
[ 39.045828] cx88[0]: card=18 -> Hauppauge Nova-T DVB-T
[ 39.045830] cx88[0]: card=19 -> Conexant DVB-T reference design
[ 39.045832] cx88[0]: card=20 -> Provideo PV259
[ 39.045834] cx88[0]: card=21 -> DViCO FusionHDTV DVB-T Plus
[ 39.045836] cx88[0]: card=22 -> pcHDTV HD3000 HDTV
[ 39.045838] cx88[0]: card=23 -> digitalnow DNTV Live! DVB-T
[ 39.045840] cx88[0]: card=24 -> Hauppauge WinTV 28xxx (Roslyn) models
[ 39.045843] cx88[0]: card=25 -> Digital-Logic MICROSPACE Entertainment Center (MEC)
[ 39.045845] cx88[0]: card=26 -> IODATA GV/BCTV7E
[ 39.045847] cx88[0]: card=27 -> PixelView PlayTV Ultra Pro (Stereo)
[ 39.045849] cx88[0]: card=28 -> DViCO FusionHDTV 3 Gold-T
[ 39.045851] cx88[0]: card=29 -> ADS Tech Instant TV DVB-T PCI
[ 39.045853] cx88[0]: card=30 -> TerraTec Cinergy 1400 DVB-T
[ 39.045855] cx88[0]: card=31 -> DViCO FusionHDTV 5 Gold
[ 39.045857] cx88[0]: card=32 -> AverMedia UltraTV Media Center PCI 550
[ 39.045860] cx88[0]: card=33 -> Kworld V-Stream Xpert DVD
[ 39.045861] cx88[0]: card=34 -> ATI HDTV Wonder
[ 39.045863] cx88[0]: card=35 -> WinFast DTV1000-T
[ 39.045865] cx88[0]: card=36 -> AVerTV 303 (M126)
[ 39.045867] cx88[0]: card=37 -> Hauppauge Nova-S-Plus DVB-S
[ 39.045869] cx88[0]: card=38 -> Hauppauge Nova-SE2 DVB-S
[ 39.045871] cx88[0]: card=39 -> KWorld DVB-S 100
[ 39.045873] cx88[0]: card=40 -> Hauppauge WinTV-HVR1100 DVB-T/Hybrid
[ 39.045875] cx88[0]: card=41 -> Hauppauge WinTV-HVR1100 DVB-T/Hybrid (Low Profile)
[ 39.045878] cx88[0]: card=42 -> digitalnow DNTV Live! DVB-T Pro
[ 39.045880] cx88[0]: card=43 -> KWorld/VStream XPert DVB-T with cx22702
[ 39.045882] cx88[0]: card=44 -> DViCO FusionHDTV DVB-T Dual Digital
[ 39.045884] cx88[0]: card=45 -> KWorld HardwareMpegTV XPert
[ 39.045886] cx88[0]: card=46 -> DViCO FusionHDTV DVB-T Hybrid
[ 39.045888] cx88[0]: card=47 -> pcHDTV HD5500 HDTV
[ 39.045890] cx88[0]: card=48 -> Kworld MCE 200 Deluxe
[ 39.045892] cx88[0]: card=49 -> PixelView PlayTV P7000
[ 39.045894] cx88[0]: card=50 -> NPG Tech Real TV FM Top 10
[ 39.045896] cx88[0]: card=51 -> WinFast DTV2000 H
[ 39.045898] cx88[0]: card=52 -> Geniatech DVB-S
[ 39.045900] cx88[0]: card=53 -> Hauppauge WinTV-HVR3000 TriMode Analog/DVB-S/DVB-T
[ 39.045902] cx88[0]: card=54 -> Norwood Micro TV Tuner
[ 39.045904] cx88[0]: card=55 -> Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM
[ 39.045907] cx88[0]: card=56 -> Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder
[ 39.045910] CORE cx88[0]: subsystem: 1002:00f9, board: UNKNOWN/GENERIC [card=0,autodetected]
[ 39.045914] TV tuner -1 at 0x1fe, Radio tuner -1 at 0x1fe
[ 39.075318] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 39.203349] cx88[0]/0: found at 0000:00:0e.0, rev: 5, irq: 19, latency: 32, mmio: 0xcb000000
[ 39.227806] tuner 0-0060: All bytes are equal. It is not a TEA5767
[ 39.227812] tuner 0-0060: chip found @ 0xc0 (cx88[0])
[ 39.239427] cx88[0]/0: registered device video0 [v4l2]
[ 39.239458] cx88[0]/0: registered device vbi0
[ 39.239475] tuner 0-0060: tuner type not set
[ 705.265153] tuner 0-0060: tuner type not set
[ 705.582231] tuner 0-0060: tuner type not set

Re-inserting the cx88xx module via modprobe with card=4 as an argument corrects the problem. I'm not sure how to fix this permanently:
sudo modprobe cx88xx card=4

Greg Taylor (gtaylor) wrote :

Oh, and this is for Feisty.

Greg Taylor (gtaylor) wrote :

Any word on this? I've confirmed that re-inserting with the card=4 flag works with tvtime.

Jeevas V (jeevas-v) wrote :

For the time being use this simple solution:

take a terminal an type

echo "options cx88xx card=4" >> /etc/modules.conf

and then restart the sys and you should be all set.

Jeevas V (jeevas-v) wrote :

I'll try to work on a patch, If you really need it.

Greg Taylor (gtaylor) wrote :

Yes, I figured this one out. But it's one of these things that should "just work", especially considering it's a pretty common card.

waxhell (waxhell) wrote :

This is kind of weird, because I have the exact same card and the drivers were automatically loaded under feisty (and gutsy, which I am currently running). Which kernel are you running?

I did have to load up the firmware for the card for the nxt2004 part to work properly. See http://www.mythtv.org/wiki/index.php/ATI_HDTV_Wonder for details.

I do have problems with scanning for channels. I know for a fact that my area is running a number of QAM-256 unencrypted channels, but the card detects none (and no ASTC channels either when the antenna is plugged in).

Greg Taylor (gtaylor) wrote :

The latest Feisty kernel. I don't have the HDTV wonder though, not sure what you're talking about as far as the nxt2004 goes.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It looks like your device still will not cause the driver to auto load in the Hardy version of the kernel. This bug won't be fixed for Feisty, but I'll get it looked at for Hardy.

The subvendor and subdevice id to be added is 1002:00f9 and the card type used should be CX88_BOARD_ATI_WONDER_PRO. It seems to be the same card as 00f8 as far as I can tell. Leann also looked in the upstream git tree and didn't see it there either.

Changed in linux-source-2.6.20:
status: New → Won't Fix
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Low
status: New → Triaged
Greg Taylor (gtaylor) wrote :

Confirmed that it still doesn't work for 2.6.24-12-generic. If I can do anything to help test this once modifications are made, please let me know. Thanks!

Greg Taylor (gtaylor) wrote :

Any news on this? Still not working under the following kernel:
Linux 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Hello, this bug has been fixed upstream. (bc13ae11227b06d2397cea1a8eb22fc2ca64e22f)

Thanks Mirsal for the reference to the patch. Looks like this is already available in Karmic. As a result I'm marking this Fix Released for now. Thanks.

ogasawara@emiko:~/ubuntu-karmic$ git show bc13ae11227b06d2397cea1a8eb22fc2ca64e22f
commit bc13ae11227b06d2397cea1a8eb22fc2ca64e22f
Author: Patrice Levesque <email address hidden>
Date: Sun Nov 2 16:37:35 2008 -0300

    V4L/DVB (9529): cx88: add a second PCI ID for ATI TV Wonder Pro

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers