Blank screen after resume from suspend - Intel ironlake - i915 - Kernel 3.8.0 - Ubuntu 13.04

Bug #1156306 reported by N1ck 7h0m4d4k15 on 2013-03-17
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

When I resume from suspend the screen remains blank (black). I can hear that Laptop awakes normally from resume (DVD noise - Fun works - Desktop sounds... etc) but I cannot see the screen.
Even if I try to hit multiple buttons on my keyboard , nothing happens. I can only reboot (via R.E.I.S.U.B).

This bug it is known upstream , please see the following link:
http://cgit.freedesktop.org/~danvet/drm-intel/commit/?h=drm-intel-nightly&id=cf0a6584aa6d382f802f2c3cacac23ccbccde0cd

BUT even when I tested the latest mainline kernel , the problem still remained !!!
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc2-raring/

The FIX
I tested the fix by myself.(I followed the link above) I downloaded the latest Stable mainline kernel from here : https://www.kernel.org/ => (Kernel 3.8.3) and changed the file : "drivers/gpu/drm/i915/intel_panel.c" manually and I replaced the appropriate lines. Then I compiled , built and installed the kernel.
Resume from suspend now works as it should.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-13-generic 3.8.0-13.22
ProcVersionSignature: Ubuntu 3.8.0-13.22-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: nikos 4948 F.... pulseaudio
CasperVersion: 1.330
Date: Sun Mar 17 20:52:25 2013
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130317)
MachineType: Acer Aspire 5733
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=(loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=/boot/iso/raring-desktop-amd64.iso noprompt noeject persistent rw
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-13-generic N/A
 linux-backports-modules-3.8.0-13-generic N/A
 linux-firmware 1.103
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/07/2011
dmi.bios.vendor: Acer
dmi.bios.version: V1.07
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 5733
dmi.board.vendor: Acer
dmi.board.version: V1.07
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.07
dmi.modalias: dmi:bvnAcer:bvrV1.07:bd11/07/2011:svnAcer:pnAspire5733:pvrV1.07:rvnAcer:rnAspire5733:rvrV1.07:cvnAcer:ct10:cvrV1.07:
dmi.product.name: Aspire 5733
dmi.product.version: V1.07
dmi.sys.vendor: Acer

N1ck 7h0m4d4k15 (nicktux) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: kernel-bug-exists-upstream
tgui (eric-c-morgan) wrote :

I too have this exact same issue. I can't wait for a fix as 13.04 has been quite a bit snappier on my old hardware.

N1ck 7h0m4d4k15 (nicktux) wrote :

@tgui, if you can't wait for a fix you can fix it by yourself. You have to know how to make the changes - compile - build and install the kernel packages.

If you don't know or don't have the time to learn, then wait 1-2 days and I will upload the .deb packages (I think I have them somewhere) and I will give you the link to download and install the kernel I used. (3.8.3 - pathced) and tell me if works.

Regards
 NikTh

Josh Karnes (josh-karnes) wrote :

FWIW I am having this same issue on an Acer C7 Chromebook. Worked fine with the 3.4.0 kernel and 12.04, 12.10 but moving to the current 3.8.0 broke something. Dunno if the 3.8.3 patched is going to break VirtualBox for me, since VB is the whole reason I moved to 3.8.0 in the first place.

N1ck 7h0m4d4k15 (nicktux) wrote :
tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

The patch mentioned in comment #6 should be in the upstream kernel as of v3.9-rc2:

git describe --contains cf0a6584aa6d382f802f2c3cacac23ccbccde0cd
v3.9-rc2~15^2~6^2~42

This can be confirmed by testing the latest 3.9 final kernel, which can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9.3-saucy/

tags: added: kernel-da-key
N1ck 7h0m4d4k15 (nicktux) wrote :

I confirm that the problem (bug) is solved.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Julian Wiedmann (jwiedmann) wrote :

Note that cf0a6584aa6d382 was reverted again later during the 3.9-rc cycle (with b1289371fcd58).

Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue is also an upstream bug, since commit cf0a6584 was reverted. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

N1ck 7h0m4d4k15 (nicktux) wrote :

Arch Linux now has the 3.9.4 kernel. I think that Arch linux use the mainline kernel and only 3 patches are applied.
https://www.archlinux.org/packages/?name=linux

https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/linux

The resume from suspend works flawlessly . Same laptop (I have dual boot Ubuntu and Arch Linux).

Also check this patch on 3.9.5 (current stable)
https://www.kernel.org/diff/diffview.cgi?file=%2Fpub%2Flinux%2Fkernel%2Fv3.x%2Fpatch-3.9.5.xz;z=149

I think they have already fix this bug.

Regards
 NikTh

Joseph Salisbury (jsalisbury) wrote :

Can you test the latest v3.8 stable kernel to see if the fix in v3.9.4 was sent to stable:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.2-raring/

If the bug still exits in the latest stable v3.8 kernel, we can perform a reverse bisect to identify the commit that fixed it in 3.9.4.

N1ck 7h0m4d4k15 (nicktux) wrote :

Yes, probably the fix was sent.

The bug is not exist in :
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.13.2-raring/

Resume from suspend works as it should.

Regards
 NikTh

Joseph Salisbury (jsalisbury) wrote :

Thanks for testing. This bug should be fixed in 3.8.0-26.38, which has the 3.8.13.2 updates. The 3.8.0-26.38 kernel is now in -proposed. Would it be possible for you to test -proposed to confirm this bug is resolved?

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

Thank you in advance!

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
N1ck 7h0m4d4k15 (nicktux) wrote :

Yes,
this bug has been fixed in 3.8.0-26.38~precise1

Resume from suspend works good.

Kyle Utecht (knutecht) wrote :

Would it be possible for one of you to post instructions for how to upgrade an acer c7 with chrubuntu to one of the kernal versions you patched?

I'm pretty new at this and can't figure out how to incorporate the kernel you patched into the script at: http://superuser.com/questions/583269/chrubuntu-acer-how-to-load-kernel-3-8-0-16-instead-3-4-0.

Thanks (and sorry if this isn't the right place to ask a question like this).

N1ck 7h0m4d4k15 (nicktux) wrote :

This bug has been fixed at 3.8.0-26.38~precise1 kernel version. The 3.8.0-26.38~precise1 kernel is the patched - ready kernel without a problem.
If you want to patch your own kernel then look at the description of the bug. You will see what I did (I'm not a kernel developer) , is not difficult.

The patch is on comment #6 and also at the link in the description.

Regards
 NikTh

Julian Wiedmann (jwiedmann) wrote :

3.8.0-26.38~precise1 is available in -updates.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers