Ubuntu

System fails to resume from suspend ONLY when suspended by closing lid

Reported by Jeff Lane on 2013-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
AceLan Kao

Bug Description

This is an odd one... When I close the lid, the system successfully suspends. However, when I open the lid, the system starts to resume, the screen flashes then turns off completely again (no backlight) and the system freezes (capslock doesnt illumintate when pressed repeatedly).

HOWEVER, if I enter suspend via the menu and wake by hitting a key, or even suspend via menu and wake by closing and opening the lid the system seems to properly resume functionality.

So to repeat, this only seems to happen when I close the lid to suspend.

Unfortunately, that's a blocker for me because I'd imagine that 99% of the use cases for suspending a laptop include just closing the lid and throwing it in a bag.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-25-generic 3.5.0-25.39~precise1
ProcVersionSignature: Ubuntu 3.5.0-25.39~precise1-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic [HD-Audio Generic], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1671 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1671 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'HDMI'/'HDA ATI HDMI at 0x90344000 irq 46'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100300'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0x90340000 irq 16'
   Mixer name : 'IDT 92HD99BXX'
   Components : 'HDA:111d76e5,103c1937,00100303'
   Controls : 18
   Simple ctrls : 10
Date: Wed Feb 27 05:35:29 2013
HibernationDevice: RESUME=UUID=675c5759-cc72-47fa-8bd7-7ee264d629d9
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: Hewlett-Packard HP Pavilion Sleekbook 14 PC
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-25-generic root=UUID=5ad98b2c-223e-4f66-a6c5-d6c9007b9386 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-25-generic N/A
 linux-backports-modules-3.5.0-25-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/01/2012
dmi.bios.vendor: Insyde
dmi.bios.version: F.13
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1937
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 87.0B
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.13:bd11/01/2012:svnHewlett-Packard:pnHPPavilionSleekbook14PC:pvr0892110000005900000320100:rvnHewlett-Packard:rn1937:rvr87.0B:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion Sleekbook 14 PC
dmi.product.version: 0892110000005900000320100
dmi.sys.vendor: Hewlett-Packard

Jeff Lane (bladernr) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → Gavin Guo (mimi0213kimo)
Changed in linux (Ubuntu):
importance: Undecided → Medium
Anthony Wong (anthonywong) wrote :

Looks like this is radeon driver issue. Could you install fglrx and try again?

Changed in linux (Ubuntu):
assignee: Gavin Guo (mimi0213kimo) → nobody
status: Confirmed → Incomplete
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)
Tim Chen (ctf) wrote :

This bug is fixed with fglrx-experimental-12.100-0ubuntu0.1.

Yang Kun (YK) (dayangkuncn) wrote :

@acelan, Hi acelan, could you please verify what Tim Chen said in comment#4 ? thanks

Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → AceLan Kao (acelankao)
importance: Medium → High
AceLan Kao (acelankao) on 2013-05-13
Changed in linux (Ubuntu):
status: Incomplete → In Progress
AceLan Kao (acelankao) wrote :

Confirm that this issue has been fixed by fglrx-experimental-12.100-0ubuntu0.1

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Ara Pulido (apulido) on 2013-09-03
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Taihsiang Ho (taihsiangho) wrote :

machine 201209-11789 with image 12.04.3 and

1. without proprietary driver
2. with proprietary driver (dumping information by "dpkg -l | grep fglrx")
ii fglrx-amdcccle-experimental-13 2:13.101-0ubuntu0.0.2 Catalyst Control Center for the AMD graphics accelerators
ii fglrx-experimental-13 2:13.101-0ubuntu0.0.2 Video driver for the AMD graphics accelerators

both of the cases didn't show this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers