Logitech Unify-Receivver for M570 not paired

Bug #1134137 reported by Samuel Suther on 2013-02-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I use Logitech M570 on ASUS n76vz. If i have a look into syslog, i got Message like this, if i plugin the unify-Receiver:

Feb 27 10:14:41 kubuntu kernel: [ 357.064230] usb 3-2: new full-speed USB device number 9 using xhci_hcd
Feb 27 10:14:41 kubuntu mtp-probe: checking bus 3, device 9: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-2"
Feb 27 10:14:41 kubuntu kernel: [ 357.086432] logitech-djreceiver 0003:046D:C52B.0013: hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-2/input2
Feb 27 10:14:41 kubuntu kernel: [ 357.086719] logitech-djreceiver 0003:046D:C52B.0013: logi_dj_probe:logi_dj_recv_query_paired_devices error:-32
Feb 27 10:14:41 kubuntu kernel: [ 357.086925] logitech-djreceiver: probe of 0003:046D:C52B.0013 failed with error -32
Feb 27 10:14:41 kubuntu mtp-probe: bus: 3, device: 9 was not an MTP device

lsusb shows this:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 004 Device 003: ID 174c:5106 ASMedia Technology Inc. Transcend StoreJet 25M3
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 005: ID 0458:002e KYE Systems Corp. (Mouse Systems)
Bus 003 Device 004: ID 0bf8:100c Fujitsu Siemens Computers Keyboard FSC KBPC PX
Bus 001 Device 004: ID 1bcf:2883 Sunplus Innovation Technology Inc.
Bus 003 Device 010: ID 046d:c52b Logitech, Inc. Unifying Receiver

But the Mouse is not paird.

SOLUTION:
The Solution, which worked for me was to change the Line 14 in /lib/udev/rules.d/97-bluetooth-hid2hci.rules
from:
KERNEL=="hiddev*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \
to
KERNEL=="hiddraw*", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c70[345abce]|c71[34bc]", \

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1134137/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1134137

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
Arjen Lentz (arjen-lentz) wrote :

I don't think the edit of /lib/udev/rules.d/97-bluetooth-hid2hci.rules is a complete solution.

I filed a new bug https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1165579 with more information.
The init of the unifying receiver works intermittently, regardless of the /lib/udev/rules.d/97-bluetooth-hid2hci.rules edit (I've tried with both, reboots inbetween). It's possible it works more often with the edit in place.

Samuel Suther (s-suther) wrote :

K, this was not the solution.
Solution is to unload and reload the Kernel-Modules.

On Startup, i start a Script, whcih do this as long, as the logitech-receiver is not parired.
This works now great.

See my German wiki, which telles about this... for english, maybe use google-translate...

http://wiki.xstable.de/doku.php/linux:asus_n76#logitech_m750_trackball

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers