Ubuntu

Precise boots to black screen due to radeondrmfb on HP ProLiant BL2x220c G5

Reported by Trevor Joynson on 2013-02-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Related dmesg output:

[ 11.847798] [drm] Initialized drm 1.1.0 20060810
[ 11.905197] [drm] radeon defaulting to kernel modesetting.
[ 11.905200] [drm] radeon kernel modesetting enabled.
[ 11.905285] radeon 0000:01:03.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 11.905483] [drm] initializing kernel modesetting (RV100 0x1002:0x515E 0x103C:0x31FB).
[ 11.905511] [drm] register mmio base: 0xFDDF0000
[ 11.905513] [drm] register mmio size: 65536
[ 11.905660] radeon 0000:01:03.0: VRAM: 128M 0x00000000F0000000 - 0x00000000F7FFFFFF (64M used)
[ 11.905663] radeon 0000:01:03.0: GTT: 512M 0x00000000D0000000 - 0x00000000EFFFFFFF
[ 11.905670] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 11.905672] [drm] Driver supports precise vblank timestamp query.
[ 11.905694] [drm] radeon: irq initialized.
[ 11.919756] [drm] Detected VRAM RAM=128M, BAR=128M
[ 11.919761] [drm] RAM width 16bits DDR
[ 11.919858] [TTM] Zone kernel: Available graphics memory: 8216894 kiB.
[ 11.919861] [TTM] Zone dma32: Available graphics memory: 2097152 kiB.
[ 11.919863] [TTM] Initializing pool allocator.
[ 11.919901] [drm] radeon: 64M of VRAM memory ready
[ 11.919904] [drm] radeon: 512M of GTT memory ready.
[ 11.919929] [drm] GART: num cpu pages 131072, num gpu pages 131072
[ 11.936056] ipmi_si 0000:01:04.6: Using irq 21
[ 11.941585] [drm] PCIE GART of 512M enabled (table at 0x0000000036C80000).
[ 11.941608] radeon 0000:01:03.0: WB disabled
[ 11.941688] [drm] Loading R100 Microcode
[ 12.027578] tg3 0000:03:04.0: irq 40 for MSI/MSI-X
[ 12.051094] ipmi_si 0000:01:04.6: Found new BMC (man_id: 0x00000b, prod_id: 0x2020, dev_id: 0x11)
[ 12.051107] ipmi_si 0000:01:04.6: IPMI kcs interface initialized
[ 12.059931] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 12.073654] tg3 0000:03:04.0: eth0: Link is up at 1000 Mbps, full duplex
[ 12.073658] tg3 0000:03:04.0: eth0: Flow control is off for TX and off for RX
[ 12.075262] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 12.097968] [drm] radeon: ring at 0x00000000D0001000
[ 12.097992] [drm] ring test succeeded in 1 usecs
[ 12.098115] [drm] radeon: ib pool ready.
[ 12.100038] [drm] ib test succeeded in 0 usecs
[ 12.100361] [drm] Radeon Display Connectors
[ 12.100363] [drm] Connector 0:
[ 12.100364] [drm] VGA
[ 12.100367] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[ 12.100368] [drm] Encoders:
[ 12.100370] [drm] CRT1: INTERNAL_DAC1
[ 12.100371] [drm] Connector 1:
[ 12.100373] [drm] VGA
[ 12.100375] [drm] DDC: 0x6c 0x6c 0x6c 0x6c 0x6c 0x6c 0x6c 0x6c
[ 12.100377] [drm] Encoders:
[ 12.100378] [drm] CRT2: INTERNAL_DAC2
[ 12.146150] No connectors reported connected with modes
[ 12.146155] [drm] Cannot find any crtc or sizes - going 1024x768
[ 12.154061] [drm] fb mappable at 0xF0040000
[ 12.154063] [drm] vram apper at 0xF0000000
[ 12.154065] [drm] size 786432
[ 12.154066] [drm] fb depth is 8
[ 12.154068] [drm] pitch is 1024
[ 12.154155] fbcon: radeondrmfb (fb0) is primary device
[ 12.154260] Console: switching to colour frame buffer device 128x48
[ 12.162054] fb0: radeondrmfb frame buffer device
[ 12.162056] drm: registered panic notifier
[ 12.162063] [drm] Initialized radeon 2.12.0 20080528 for 0000:01:03.0 on minor 0

Quantal kernel works fine, but it appears radeon/radeondrmfb may need some patches backported to precise?
---
AlsaDevices:
 total 0
 crw-rw---T 1 root audio 116, 1 Feb 26 16:26 seq
 crw-rw---T 1 root audio 116, 33 Feb 26 16:26 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
CurrentDmesg:

DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=c66a5950-8855-4c64-b82f-a2de855c8b0e
IwConfig:
 lo no wireless extensions.

 eth1 no wireless extensions.

 eth0 no wireless extensions.
MachineType: HP ProLiant BL2x220c G5
MarkForUpload: True
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 TERM=screen-bce
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-38-generic root=UUID=aab59adb-e0cf-42e1-b7aa-91181ef5aebc ro quiet
ProcVersionSignature: Ubuntu 3.2.0-38.61-generic 3.2.37
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-38-generic N/A
 linux-backports-modules-3.2.0-38-generic N/A
 linux-firmware 1.79.1
RfKill: Error: [Errno 2] No such file or directory
Tags: precise
Uname: Linux 3.2.0-38-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/25/2010
dmi.bios.vendor: HP
dmi.bios.version: I19
dmi.chassis.type: 23
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrI19:bd10/25/2010:svnHP:pnProLiantBL2x220cG5:pvr:cvnHP:ct23:cvr:
dmi.product.name: ProLiant BL2x220c G5
dmi.sys.vendor: HP

Trevor Joynson (trevorjay) wrote :

Forgot to add, I've been using nomodeset to work around this, but it can be a pain to do this on numerous blades.

Trevor Joynson (trevorjay) wrote :

lshw attached.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1133683

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: High → Medium
Trevor Joynson (trevorjay) wrote :

This is fixed with the latest Precise kernel.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers