Ubuntu

Kernel Regression-Web Cam Displays Black Screen

Reported by Timothy Siple on 2013-02-26
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
System76
High
Ian Santopietro
linux (Ubuntu)
High
Unassigned

Bug Description

Web Cam works at kernel version 3.5.0-19 and does not work at kernel version 3.5.0-25.

Web Cam applications eg. cheese only display a black screen after updating to kernel version 3.5.0-25. All web cam applications work as expected when using kernel version 3.5.0-19.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-25-generic 3.5.0-25.39
ProcVersionSignature: Ubuntu 3.5.0-25.39-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1662 F.... pulseaudio
Date: Tue Feb 26 14:27:08 2013
HibernationDevice: RESUME=UUID=616eaa19-299e-479b-8dcf-dfc36593f63a
InstallationDate: Installed on 2012-10-18 (131 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: System76, Inc. Pangolin Performance
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-25-generic root=UUID=6fb59d06-ec00-44f4-abcc-0da0f018be93 ro quiet splash acpi_os_name=Linux acpi_osi= vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-25-generic N/A
 linux-backports-modules-3.5.0-25-generic N/A
 linux-firmware 1.95
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/20/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: Pangolin Performance
dmi.board.vendor: System76, Inc.
dmi.board.version: panp9
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd04/20/2012:svnSystem76,Inc.:pnPangolinPerformance:pvrpanp9:rvnSystem76,Inc.:rnPangolinPerformance:rvrpanp9:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: Pangolin Performance
dmi.product.version: panp9
dmi.sys.vendor: System76, Inc.

Timothy Siple (twsiple63) wrote :
Changed in system76:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in system76:
assignee: nobody → Ian Santopietro (isantop)
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

tags: added: needs-bisect
tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
tags: added: regression-update

Same problem seems to occur in Kernel 3.8.0-030800rc7 from
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc7-raring/

On Wed, Feb 27, 2013 at 9:20 AM, Joseph Salisbury <
<email address hidden>> wrote:

> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v3.8 kernel[0] (Not a kernel in the daily directory) and install both
> the linux-image and linux-image-extra .deb packages.
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> If you are unable to test the mainline kernel, for example it will not
> boot, please add the tag: 'kernel-unable-to-test-upstream'.
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/
>
> ** Tags added: needs-bisect
>
> ** Tags added: kernel-da-key
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Tags added: regression-update
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1133646
>
> Title:
> Kernel Regression-Web Cam Displays Black Screen
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/system76/+bug/1133646/+subscriptions
>

--
Ian Santopietro

*Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html*

Pa gur yv y porthaur?

Public GPG key (RSA):
http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x412F52DB1BBF1234

Joseph Salisbury (jsalisbury) wrote :

Thanks for the info, Ian. Do you happen to know if it also happens with the latest final version of v3.8[0]?

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

Ian Santopietro (isantop) wrote :

Sorry about that, I could have sworn I downloaded that package.

Still no dice. Running on version 3.8.0-030800-generic

On Wed, Feb 27, 2013 at 3:11 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Thanks for the info, Ian. Do you happen to know if it also happens with
> the latest final version of v3.8[0]?
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1133646
>
> Title:
> Kernel Regression-Web Cam Displays Black Screen
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/system76/+bug/1133646/+subscriptions
>

--
Ian Santopietro

*Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html*

Pa gur yv y porthaur?

Public GPG key (RSA):
http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x412F52DB1BBF1234

Ian Santopietro (isantop) wrote :

I think we were able to find the change that broke this. Looking at the
changelog, this is the only webcam change that came between -23 and -25:

--- linux-3.5.0.orig/drivers/media/video/uvc/uvc_video.c
+++ linux-3.5.0/drivers/media/video/uvc/uvc_video.c

It looks like this change was submitted from upstream.

On Wed, Feb 27, 2013 at 3:39 PM, Ian Santopietro <email address hidden> wrote:

> Sorry about that, I could have sworn I downloaded that package.
>
> Still no dice. Running on version 3.8.0-030800-generic
>
>
> On Wed, Feb 27, 2013 at 3:11 PM, Joseph Salisbury <
> <email address hidden>> wrote:
>
>> Thanks for the info, Ian. Do you happen to know if it also happens with
>> the latest final version of v3.8[0]?
>>
>> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1133646
>>
>> Title:
>> Kernel Regression-Web Cam Displays Black Screen
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/system76/+bug/1133646/+subscriptions
>>
>
>
>
> --
> Ian Santopietro
>
> *Please avoid sending me Word or PowerPoint attachments.
> See http://www.gnu.org/philosophy/no-word-attachments.html*
>
> Pa gur yv y porthaur?
>
> Public GPG key (RSA):
> http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x412F52DB1BBF1234
>

--
Ian Santopietro

*Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html*

Pa gur yv y porthaur?

Public GPG key (RSA):
http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x412F52DB1BBF1234

Joseph Salisbury (jsalisbury) wrote :

Hi Ian,

Do you happen to have the SHA1 for the change you believe introduced this regression? I did a quick git search and see the latest upstream change in 3.5.y to drivers/media/video/uvc/uvc_video.c was the following commit:
ed0ee0ce0a3224dab5caa088a5f8b6df25924276
Applied: v3.4-rc4~4^2~7

I see the latest change to that file in the 3.5 Ubuntu tree is:
eb8666b72435635533748d5654ea506d6b600351
Applied: Ubuntu-3.5.0-17.26~164

Both of these commits were introduced prior to 3.5.0-23.

I do see the following commit applied to the Ubuntu tree:
a2f30ff - usb: gadget: uvc: fix error path in uvc_function_bind()
Applied: Ubuntu-3.5.0-24.36~321

However, this commit changed the file:
drivers/usb/gadget/f_uvc.c

I could build a test kernel with commit a2f30ff reverted, unless you see another commit that I missed. If reverting commit a2f30ff doesn't fix the bug, we can perform a bisect to narrow down the exact bad commit.

Ian Santopietro (isantop) wrote :

Hi Joseph.

I don't have the specific change available (that research was done by
my colleague, Tim, above.

That said, the -26 kernel currently sitting in proposed seems to have
reenabled the webcam. I'm doing some more comprehensive testing to ensure
that it didn't cause any more issues, but this may have been fixed already.

What is the release schedule for that -26 kernel?

On Thu, Feb 28, 2013 at 10:55 AM, Joseph Salisbury <
<email address hidden>> wrote:

> Hi Ian,
>
> Do you happen to have the SHA1 for the change you believe introduced this
> regression? I did a quick git search and see the latest upstream change in
> 3.5.y to drivers/media/video/uvc/uvc_video.c was the following commit:
> ed0ee0ce0a3224dab5caa088a5f8b6df25924276
> Applied: v3.4-rc4~4^2~7
>
> I see the latest change to that file in the 3.5 Ubuntu tree is:
> eb8666b72435635533748d5654ea506d6b600351
> Applied: Ubuntu-3.5.0-17.26~164
>
> Both of these commits were introduced prior to 3.5.0-23.
>
> I do see the following commit applied to the Ubuntu tree:
> a2f30ff - usb: gadget: uvc: fix error path in uvc_function_bind()
> Applied: Ubuntu-3.5.0-24.36~321
>
> However, this commit changed the file:
> drivers/usb/gadget/f_uvc.c
>
> I could build a test kernel with commit a2f30ff reverted, unless you see
> another commit that I missed. If reverting commit a2f30ff doesn't fix
> the bug, we can perform a bisect to narrow down the exact bad commit.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1133646
>
> Title:
> Kernel Regression-Web Cam Displays Black Screen
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/system76/+bug/1133646/+subscriptions
>

--
Ian Santopietro

*Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html*

Pa gur yv y porthaur?

Public GPG key (RSA):
http://keyserver.ubuntu.com:11371/pks/lookup?op=get&search=0x412F52DB1BBF1234

Ian Santopietro (isantop) wrote :

Are there any updates on when the 3.5.0-26 kernel is expected to be released?

Joseph Salisbury (jsalisbury) wrote :

Can you confirm if this bug is resolved in the latest Quantal kernel? If so, please mark the bug as "Fix Released".

Thanks in advance.

Changed in system76:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers