Ubuntu

regression-update kernel 3.5.0-24 alx suspend/resume

Reported by Denis Marchand on 2013-02-19
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

My laptop has a AR8162 ethernet controller. I use ubuntu 12.10 fully upgraded.

With the new updated 3.5.0-24 kernel, the new alx module provided works fine but breaks suspend/resume.

After a cold boot up, suspend/resume works fine only the first time it is used. If you want to do another one after the first resume, it fails, the system refuses to suspend and just locks the screen.

See the log below from /var/log/syslog :

Feb 19 10:10:10 deneznotebook kernel: [ 1693.252778] alx 0000:03:00.0: PHY SPD/D
PLX unresolved :ffff
Feb 19 10:10:10 deneznotebook kernel: [ 1693.252783] alx 0000:03:00.0: eth0: shu
town err(ffffffea)
Feb 19 10:10:10 deneznotebook kernel: [ 1693.252785] alx 0000:03:00.0: shutdown fail in suspend -5
Feb 19 10:10:10 deneznotebook kernel: [ 1693.252800] pci_pm_suspend(): alx_suspend+0x0/0x90 [alx] returns -5
Feb 19 10:10:10 deneznotebook kernel: [ 1693.252806] dpm_run_callback(): pci_pm_suspend+0x0/0x140 returns -5
Feb 19 10:10:10 deneznotebook kernel: [ 1693.252810] PM: Device 0000:03:00.0 failed to suspend async: error -5
Feb 19 10:10:10 deneznotebook kernel: [ 1693.357930] sd 0:0:0:0: [sda] Stopping disk
Feb 19 10:10:10 deneznotebook kernel: [ 1693.645436] PM: suspend of drv:sd dev:0:0:0:0 complete after 406.164 msecs
Feb 19 10:10:10 deneznotebook kernel: [ 1693.645548] PM: Some devices failed to suspend

Suspend/resume works fine with all the previous kernel provided through updates and a alx module built by myself from the source attached below.

Thank you

Denis Marchand
---
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: denez 2101 F.... pulseaudio
CurrentDmesg:
 [ 26.859860] alx 0000:03:00.0: eth0: wol-ctrl=2
 [ 27.239037] init: plymouth-stop pre-start process (1754) terminated with status 1
 [ 38.391607] alx 0000:03:00.0: eth0: wolopts = 20
 [ 38.391618] alx 0000:03:00.0: eth0: wol-ctrl=2
DistroRelease: LinuxMint 14
HibernationDevice: RESUME=UUID=5b2ce408-44d2-4df1-aca4-ac737ee30797
MachineType: ASUSTeK COMPUTER INC. X201EP
MarkForUpload: True
Package: linux 3.5.0.24.30 [origin: Ubuntu]
PackageArchitecture: amd64
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-24-generic root=UUID=6b624f1e-d825-4c4c-bb9e-cf63e9e5e793 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-24.37-generic 3.5.7.4
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/denez not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-24-generic N/A
 linux-backports-modules-3.5.0-24-generic N/A
 linux-firmware 1.95
Tags: third-party-packages nadia
Uname: Linux 3.5.0-24-generic x86_64
UnreportableReason: Ce paquet n'est pas officiellement pris en charge par LinuxMint. Veuillez désinstaller tout paquet tiers et réessayer.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/03/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X201EP.202
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X201EP
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX201EP.202:bd10/03/2012:svnASUSTeKCOMPUTERINC.:pnX201EP:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX201EP:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: X201EP
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Denis Marchand (denis-samizdat) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1130037

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Denis Marchand (denis-samizdat) wrote :

I have put an extract of the log file in the core of my message....

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

tags: added: apport-collected nadia third-party-packages
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: suspend-watch
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Thank you for your quick answer.

I have tested the kernel you said. Suspend/resume works fine but there is no alx module provided, so no way to use my ethernet controller out of the box.

I've noticed by the way other regessions in this kernel : the Fn key to switch the wifi on/off doesn' work anymore. And there is no way to adjust luminosity (it doesn't work with the Fn keys neither with kernel 3.5 but a least it works withe the Cinnamon desktop applet).

My laptop with luminosity set to 100% is very painfull to use...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-unable-to-test-upstream
Bernardo Reino (reinob) wrote :

Confirming bug with Lenovo Ideapad N581 with AR8161 running Kubuntu 12.04 with just-released kernel 3.5.0-24 (lts-quantal).

I only tested once, and only hibernation (S4), but had already seen this bug (before updating kernel), so I kind of expected it. When trying to hibernate for a second time (using KDE 4.10) it just went to the lock screen.

Unfortunately I haven't had time to debug this (yet). If I get some useful information I'll post it.

James Pearce (pearce-jj) wrote :

Same here (Lenovo G580, AR8162) - as a workaround, modprobe -r alx allows the system to be suspended or alx could be blacklisted, obviously that doesn't help if you use the wired adapter. lshw -c net lists alx driverversion=1.2.2.

No problems up to 3.5.0-23 with driver built from http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.5/compat-wireless-3.5.1-1-snpc.tar.bz2.

Bernardo Reino (reinob) wrote :

Workaround:
Adding "alx" to SUSPEND_MODULES in /etc/pm/config.d/whatever makes suspend/hibernate work OK again.

Hi,

Thank you Bernardo, your workaround works perfectly well !

Same issue with 3.5.0-25-generic.

Bug still there with latest update : 3.5.0-25.39

duebbert (kai-i) wrote :

Bug still there in (beta) 13.04 with kernel 3.8.0-13. Using hibernate on Asus N56VZ.

Workaround as suggested by Bernardo fixes it: Add SUSPEND_MODULES="alx" to /etc/pm/config.d/modules
Thanks, Bernardo.

Simon Déziel (sdeziel) wrote :

In my case (Lenovo Ideapad N581 with AR8161) running Precise with latest Quantal backported kernel, using the workaround of SUSPEND_MODULES="alx" helps but doest not fix the issue completely. Network manager loses control of the NIC after the first suspend and I had to resort to manage the connection via /etc/network/interfaces.

Thanks,
Simon

Steve (steve46223) wrote :

I also had this bug.

Before updating from 12.04 to 12.10, I had installed linux-backports-modules-cw-3.4-precise-generic in order to get alx. After updating to 12.10, I noticed that linux-backports-modules-cw-3.4-3.2.0-40-generic was still installed, even though (if I understand correctly) this package is for a different linux kernal than I'm now using with 12.10. Shouldn't the package have uninstalled itself (or deactivated itself) during the upgrade to 12.10? After all, linux-backports-modules-cw-3.4-precise-generic WAS uninstalled.

Anyway, I uninstalled linux-backports-modules-cw-3.4-3.2.0-40-generic through ubuntu software center, and that seems to have fixed the suspend problem!! [At least so far, knock on wood!]

(Of course it's possible that the package itself was not the problem, but some setting that got changed during the uninstallation process.)

(Things are still not 100% perfect: I still have the problem that my computer cannot automatically connect to wired networks anymore after suspending / resuming, until reboot, i.e. Simon Déziel's comment #28 above.)

Simon Déziel (sdeziel) wrote :

@Steve, the package linux-backports-modules-cw-3.4-precise-generic was providing you the module from kernel 3.4 while running on Precise kernel (3.2). Now that you are using Quantal, you are using the bundled driver from kernel 3.5 as you apparently haven't install any backports modules for this kernel.

Since you are on Quantal (12.10) you could try to use the backport drivers from kernel 3.6 by installing "linux-backports-modules-cw-3.6-3.5.0". Note that I haven't tried those myself.

FYI, backports modules are always installed in the kernel to which they are backported to (see /lib/modules/<kernel version>/updates/).

Steve (steve46223) wrote :

@Simon - Thanks for clarifying! Now everything works. To sum up:

(1) When using 12.04, my ethernet wasn't working (I have Atheros AR9485 wireless and AR8162 wired), so I installed linux-backports-modules-cw-3.4-precise-generic and switched to alx. All was well.

(2) Later on, I updated to 12.10 (linux kernel 3.5). I had the problem that suspending only worked the first time after each reboot.

(3) I removed the package linux-backports-modules-cw-3.4-3.2.0-40-generic in ubuntu software center. In theory, doing this should have made no difference whatsoever to my computer (according to Simon). But, for some mysterious reason it fixed my suspend problem. (Or else the problem went away by coincidence at the same time.) I still had the problem that the network manager cannot reconnect the wired connection after a suspend.

(4) I installed linux-backports-modules-cw-3.6-quantal-generic in ubuntu software center. I restarted (twice), and now everything works perfectly. :-D

Fabian Thommen (ft-taywa) wrote :

Same here: hibernate on Asus N56VZ with kernel 3.5.0-28-generic.

Hardware: Ethernet controller: Atheros Communications Inc. AR8161 Gigabit Ethernet (rev 10)

Add SUSPEND_MODULES="alx" to /etc/pm/config.d/modules works as workaround.

Eugene Mikhantiev (mehanik) wrote :

I had the same issue on Asus n56v with Ubuntu 13.04. Update to linux-image-3.8.0-20-generic and linux-image-extra-3.8.0-20-generic solved the problem.

Simon Déziel (sdeziel) wrote :

Thanks Eugene, that's encouraging. After looking at the changelog I think our bug is a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1172415

Now to wait for the Raring kernel to be backported to Precise :)

James Pearce (pearce-jj) wrote :

Bug still present in 3.8.0.21-generic (Ubuntu 13.04):

May 21 20:38:28 G580 kernel: [ 941.208792] alx 0000:03:00.0: PHY SPD/DPLX unresolved :ffff
May 21 20:38:28 G580 kernel: [ 941.208794] alx 0000:03:00.0 eth1: shutown err(ffffffea)
May 21 20:38:28 G580 kernel: [ 941.208795] alx 0000:03:00.0: shutdown fail in suspend -5
May 21 20:38:28 G580 kernel: [ 941.208808] pci_pm_suspend(): alx_suspend+0x0/0x90 [alx] returns -5

Machine is Lenovo G580 and the wired Ethernet device in is "Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)"; lshw shows driver=alx driverversion=1.2.3.

The stated workaround still works though (adding the line SUSPEND_MODULES="alx" to /etc/pm/config.d/suspend_modules).

James Pearce (pearce-jj) wrote :

Sorry to add, hence I don't think it's a dupe of #1172415, since that seems to be a resume issue.

James Pearce (pearce-jj) wrote :

Seems to be fixed with 3.8.0.22.

Denis Marchand, thank you for taking the time to report this bug and trying to help make Ubuntu better. However, Linux Mint is not a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!

If you are interested in learning more about software repositories and Ubuntu, check https://help.ubuntu.com/community/Repositories

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Simon Déziel (sdeziel) wrote :

@Christopher, this also affects Ubuntu at least with a Precise + 3.5 kernel. I hope that's OK to mark it as confirmed again.

Changed in linux (Ubuntu):
status: Invalid → Confirmed

Simon Déziel, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Bernardo Reino (reinob) wrote :

Christopher,

You cannot be serious. This bug has been confirmed by a number of Ubuntu users. The OP even states "I use ubuntu 12.10 fully upgraded."

If you want to somehow feel good don't just close a random bug. This is not the way to fix things.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Bernardo Reino (reinob) wrote :

Add. "Confirmed" means "Verified by somebody else than the reporter". I have, among others, verified this bug.

Bernardo Reino, that's not how linux (Ubuntu) bug reporting works. For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

As previously documented to you, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux
When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Bernardo Reino (reinob) wrote :

Christopher,

"that's not how linux (Ubuntu) bug reporting works."

I know. Ubuntu, and unfortunately most open-source, bug reporting works like this:

1. try to find irrelevant formal problems with the report itself.
2. if OP still there, ask user to update kernel.
  2.5 do this 4 or 5 times to give OP sufficient time to give up.
3. if OP still there, wait until new distribution release
  3.5 now ask OP to update
4. if still there, ask OP to do kernel bisect or some other random task he won't be able to complete.
5. if still there, close bug anyway because it is planned to remove this feature some day.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers