[MSI GT70 0NC] Precise & Quantal won't boot in UEFI

Bug #1129524 reported by Lou Hurst on 2013-02-18
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

On my MSI notebook Model GT70-0NC-008US tag under the battery shows GT70-0NC-494US
Win 8 64 bit was pre-installed, trying to run Precise or Quantal (or any other Linux distro) from live USB, system is unable to boot in UEFI mode. Subsequently unable to run from HDD in UEFI mode.

WORKAROUND: Change BIOS to Legacy and Fast Boot to disabled.

WORKAROUND: With 12.10 installed to HDD tried booting with all options given in the Wiki and with acpi=off and "quiet splash" deleted, system boots ok and into usable environment.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lou 2347 F.... pulseaudio
 /dev/snd/pcmC0D0p: lou 2347 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7410000 irq 47'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0892,146210be,00100302 HDA:80862806,80860101,00100000'
   Controls : 41
   Simple ctrls : 19
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=97d91cda-da20-46bd-8163-dd0dfc9231b5
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: Micro-Star International Co., Ltd. GT70
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-38-generic root=UUID=343a0d4c-acb6-458f-94a1-e38a5e44f7d3 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-38.61-generic 3.2.37
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-38-generic N/A
 linux-backports-modules-3.2.0-38-generic N/A
 linux-firmware 1.79.1
StagingDrivers: rts_pstor mei
Tags: precise staging
Uname: Linux 3.2.0-38-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo vboxusers
dmi.bios.date: 11/23/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E1762IMS.50U
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: MS-1762
dmi.board.vendor: Micro-Star International Co., Ltd.
dmi.board.version: REV:1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Micro-Star International
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE1762IMS.50U:bd11/23/2012:svnMicro-StarInternationalCo.,Ltd.:pnGT70:pvrREV1.0:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1762:rvrREV1.0:cvnMicro-StarInternational:ct10:cvrN/A:
dmi.product.name: GT70
dmi.product.version: REV:1.0
dmi.sys.vendor: Micro-Star International Co., Ltd.

Lou Hurst (harphauler) on 2013-02-18
tags: added: efi uefi

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1129524/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Lou Hurst (harphauler) wrote :

I'm not sure what package to attribute this to as the system freezes or hangs after the machine (MSI) boot splash. So have only given Plymouth as the package.

affects: ubuntu → plymouth (Ubuntu)
Steve Langasek (vorlon) wrote :

what exactly is shown on the screen at the time it freezes?

Changed in plymouth (Ubuntu):
status: New → Incomplete
Lou Hurst (harphauler) wrote :

In reply to comment #3, am going to comment here as I tend to think I have two separate issues with this box. Please forgive me if this is a duplicate of my other bug report.

I am unable to boot anything running the box in UEFI mode, i.e. I can't boot a live USB or DVD of any linux distro and therefore can't install in UEFI mode.

I can boot Ubuntu 12.04 from a live USB stick and install the system with no problems by changing my BIOS to Legacy and Fast Boot to disabled. Changing my BIOS to Legacy also turns off Secure Boot.

Am attaching three pictures of the boot process with a 12.10 USB stick inserted. The same thing happens with any other Linux distro - gparted, knoppix, fedora, etc. The first is of the MSI splash, the second the Ubuntu boot options and the third a black screen that occurs immediately after hitting the enter key for any of the Ubuntu boot options.

Steve Langasek (vorlon) wrote :

Sorry, I misunderstood from the descriptions that these were the same bug. It sounds like they aren't, so unduping.

At the grub boot menu, can you please hit 'e' to edit the boot option, remove 'quiet' from the boot options, and boot, to see if it still freezes at the same place?

Lou Hurst (harphauler) wrote :

In 12.04, 12.10 and 13.04 editing to remove "quiet" from the boot options then hitting F10 to continue boot, the screen immediately goes black. As I hit F10 the USB flash drive blinks once, then no further activity.

In my BIOS I've tried this with Fast Boot Enabled and Disabled.

I've tried also gparted live, Linux Mint, Fedora, Knoppix, none will boot in UEFI mode, all do the same as above, i.e. as soon as I choose and option at the first option menu it goes to a black screen.

The machine will boot in UEFI with the recovery USB stick I made for the original Win 8 install.

I do turn off Secure Boot when the system is set to UEFI.

Lou Hurst (harphauler) wrote :

I forgot to add that the version of 13.04 I used is the daily build from 2/21/2013.

Lou Hurst (harphauler) wrote :

I'm new at this bug reporting, is there a reason the status of this bug is "incomplete" after supplying requested info? Is there something further I need to do?

Thanks!

Steve Langasek (vorlon) wrote :

Because I hadn't yet processed the new info you'd added, sorry.

Can you also try booting Ubuntu with both the 'quiet' and 'splash' options dropped from the boot line, to see if that makes a difference? (If not, I think we need to refer this bug to the kernel)

Lou Hurst (harphauler) wrote :

Thank you for the reply, glad I didn't mess something up.

Per request in reply #9, edited start option with both 'quiet' and 'splash' removed from the boot line.

Response was the same as in reply #6. Upon pressing F10 to continue booting the USB drive flashes once and the screen goes black and remains that way, also no further activity from the USB stick.

This occurs with 12.04, 12.10 and 13.04 (daily build from 2/21/2013)

Steve Langasek (vorlon) wrote :

Ok, thanks for following up. That's pretty certainly not a plymouth bug then; it's either linux or grub. Reassigning to linux.

Changed in plymouth (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) on 2013-03-05
affects: plymouth (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1129524

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Quick question regarding reply #12 and data collection -

I am currently running 12.04LTS on this box with the problem. It boots into that via setting my BIOS to legacy so I am able to run apport-collect. That said will the data collection via apport-collect be good since I can't boot the box via UEFI?

Thanks.

Joseph Salisbury (jsalisbury) wrote :

Yes, the apport data will still be useful.

Does this issue only happen on Quantal and earlier releases? Do you happen to know if this also happens with Raring?

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
tags: added: kernel-da-key
Lou Hurst (harphauler) wrote :

This issue occurs with 12.04, 12.10, and 13.04 (daily build from 2/21.2013.)

Realizing it's not "on topic" it also occurs with gparted, Knoppix, Linux Mint 13, Fedora; nothing I've tried Linux works beyond this point.

Will run apport in a few moments.

Thank you.

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

When I first received this machine I created a system recovery rescue USB stick. The system boots UEFI with that rescue device and restores the system as designed. Would there be any boot files from that disk that would be beneficial for debugging here? Will be glad to provide what I can.

Thanks.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.9 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc1-raring/

Lou Hurst (harphauler) on 2013-03-11
tags: added: kernel-unable-to-test-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Lou Hurst (harphauler) wrote :

Per reply #38 -

Sorry, tried everything I know of to get this machine to boot via UEFI/EFI. Was unable to do so.

Have added tag 'kernel-unable-to-test-upstream' and marked as Confirmed.

Please advise if anything else needed.

Thank you.

Joseph Salisbury (jsalisbury) wrote :

It is possible this is a firmware bug. Do you have a way to see if you can install Windows on this machine, with UEFI enabled?

Lou Hurst (harphauler) wrote :

Short answer is yes I can install Windows on the machine UEFI. If I can avoid it I would prefer not doing that now as I'm using it with 12.04LTS as my daily work/production computer - the display is almost dead in my other computer.

Longer answer is I created a rescue USB stick when I got the machine and have successfully restored the machine to factory state twice with it. That includes the usual crapware, factory drivers, etc. I've also updated my BIOS to the latest version.

I could probably do this project in a few days; if I do it is there anything I should do after that to report back?

Thank you.

Joseph Salisbury (jsalisbury) wrote :

I understand about not wanting to disrupt your machine. Trying a Windows install with UEFI enabled would be a good way to confirm/deny if this is a BIOS bug.

Lou Hurst (harphauler) wrote :

I should be a bit more specific, I created a system restore USB stick that does successfully work with UEFI enabled. It has Windows 8 on it as part of the software. I used that stick twice previously.

That said, if I restore my system to factory is there something specific I should do after restoring Win 8 to report or upload here?

Thanks.

Lou Hurst (harphauler) wrote :

Forgot to add that I could try a restore sometime in the next week - week and a half.

Thanks again.

Lou Hurst (harphauler) wrote :

I will be restoring this machine to factory configuration with Windows 8 via UEFI this afternoon. Is there any information needed from the machine in it's factory config?

Thank you.

Hi.
The problem you describe seems similar to the ones reported on:
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1093472

Could you try to disable your integrated network card in the setup and then test if it boots with UEFI?

Lou Hurst (harphauler) wrote :

I'm sorry I'm unable to disable my network card in BIOS setup - there aren't very many options to begin with; the only one dealing with the network is what position to give it in order of priority for boot.

Ubfan (ubfan1) wrote :

There have been some reports of corrupted /EFI/ubuntu directories, so could you confirm that you can see the files in this directory -- either from a legacy boot (where you will have to mount the EFI partition somewhere), or live boot? If the directory is unreadable, uefi boots cannot find the necessary files to continue booting. (bug 1090829)

Lou Hurst (harphauler) wrote :

Booting via legacy boot on a 12.10 & 12.04 usb stick, the files are readable.

tags: removed: efi uefi
description: updated
tags: added: bios-outdated-50x
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Precise & Quantal won't boot in UEFI
+ [MSI GT70 0NC] Precise & Quantal won't boot in UEFI
Lou Hurst (harphauler) wrote :

Hi Christopher,

Thank you for the info regarding my BIOS. Am currently working out of town for the next week and half, will try to update when I get back and report then - I don't have a good way of backing up my machine right now!

I'm trying to get raring installed on my MSI gt70 OND-489NE, and I am seeing the exact same symptoms. I have updated my BIOS from the above mentioned download site, but to no avail. I still have not actually installed anything on my hard disks, but I need to get there soon, if I want to check the functioning of the system before my initial warranty runs out.

I'll boot into legacy live mode and try the command mentioned in #50. Do you also wish me to do a complete apport too.

ubuntu@ubuntu:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
E1762IMS.70X
01/21/2013

Should I try with the next ubuntu release (beta)

mpGoodwin, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the official Ubuntu documentation:
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices
Ubuntu Community: https://wiki.ubuntu.com/ReportingBugs

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Lou Hurst (harphauler) wrote :

Hi,

Finally got to update my BIOS per comment 50 & 51.

I am not able to boot the machine in EFI with any flavor of Ubuntu back to 12.04, up to and including yesterday's (9/6/2013) build of Saucy.

With BIOS set to Legacy I AM able to boot the machine into any flavor of Ubuntu up to and including yesterday's (9/6/2013) build of Saucy.

Thanks and sorry for the delay.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Changed in linux (Ubuntu):
importance: High → Low
status: Expired → Incomplete
Lou Hurst (harphauler) wrote :

>>Lou Hurst, could you please provide the output of:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date<<

E1762IMS.50X
01/21/2013

tags: added: latest-bios-50x
removed: bios-outdated-50x
description: updated
Lou Hurst (harphauler) wrote :

Hi, sorry for the lengthy delay.

Downloaded today's (12/03/2013) version of Trusty via link in comment #60.

Tried to boot in UEFI, via USB stick, no joy. System will boot to the Ubuntu choices menu (Try, Install, etc.) I chose Try, screen went black and no further activity for approximately 30 minutes. Tried the Install option, same result.

System set to Legacy, Trusty will boot into trial mode but mouse and touchpad don't seem to work.

tags: added: trusty
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
description: updated
Chris (turbine1991) wrote :

Confirmed this to affect Trusty and Utopic.

Can we please elevate this problem, it's major.

Chris, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

  With the recent release of this Ubuntu release, would like to confirm if this bug is still present. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

If you want this bot to quit automatically requesting kernel tests, add a tag named: bot-stop-nagging.

 Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.13.0-24.46
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers