rpcdebug: /proc/sys/sunrpc nodes do not exist

Bug #1127319 reported by Brian J. Cohen on 2013-02-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Tim Gardner
Quantal
Undecided
Tim Gardner
Raring
Undecided
Tim Gardner
Saucy
Wishlist
Tim Gardner

Bug Description

Steps to reproduce, on a stock 12.10 server installation:

1. # rpcdebug -m nfs -s all

Expected:

This command should enable syslog logging of NFS client debug messages.

Actual:

/proc/sys/sunrpc/nfs_debug: No such file or directory

Additional information:

# ls -al /proc/sys/sunrpc
ls: cannot access /proc/sys/sunrpc: No such file or directory

No results from 'locate sunrpc'

affects: nfs4-acl-tools (Ubuntu) → nfs-utils (Ubuntu)
Steve Langasek (vorlon) wrote :

$ grep SUNRPC_DEBUG /boot/config-3.8.0-6-generic
# CONFIG_SUNRPC_DEBUG is not set
$

Not a bug in nfs-utils; the kernel feature is simply not enabled.

affects: nfs-utils (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Tim Gardner (timg-tpi) on 2013-06-26
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Raring):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) on 2013-06-26
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) on 2013-06-27
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.10.0-1.8

---------------
linux (3.10.0-1.8) saucy; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1195717

  [ Andy Whitcroft ]

  * Revert "ubuntu: overlayfs -- follow change to do_splice_direct
    interface"
  * Revert "ubuntu: overlayfs -- expose do_splice_direct prototype"
  * Revert "SAUCE: ubuntu: overlayfs -- ovl_path_open should not take path
    reference"
  * Revert "ubuntu: overlayfs -- add FS_ALIAS"
  * Revert "ubuntu: overlayfs --
    overlayfs-copy-up-i_uid-i_gid-from-the-underlying-inode"
  * Revert "ubuntu: overlayfs -- ovl-switch-to-inode_permission"
  * Revert "ubuntu: overlayfs -- vfs-export-inode_permission-to-modules"
  * Revert "ubuntu: overlayfs -- overlayfs-create-new-inode-in-ovl_link"
  * Revert "ubuntu: overlayfs --
    overlayfs-fix-possible-leak-in-ovl_new_inode"
  * Revert "ubuntu: overlayfs -- fs-limit-filesystem-stacking-depth"
  * Revert "ubuntu: overlayfs -- overlay-overlay-filesystem-documentation"
  * Revert "ubuntu: overlayfs -- overlayfs-implement-show_options"
  * Revert "ubuntu: overlayfs -- overlayfs-add-statfs-support"
  * Revert "ubuntu: overlayfs -- overlay filesystem"
  * Revert "ubuntu: overlayfs -- vfs-introduce-clone_private_mount"
  * Revert "ubuntu: overlayfs -- vfs-export-do_splice_direct-to-modules"
  * Revert "ubuntu: overlayfs -- vfs-add-i_op-dentry_open"
  * ubuntu: overlayfs v18 -- -- overlayfs: add statfs support

  [ Erez Zadok ]

  * ubuntu: overlayfs v18 -- -- overlayfs: implement show_options

  [ Miklos Szeredi ]

  * ubuntu: overlayfs v18 -- -- vfs: add i_op->dentry_open()
  * ubuntu: overlayfs v18 -- -- vfs: export do_splice_direct() to modules
  * ubuntu: overlayfs v18 -- -- vfs: export __inode_permission() to modules
  * ubuntu: overlayfs v18 -- -- vfs: introduce clone_private_mount()
  * ubuntu: overlayfs v18 -- -- overlay filesystem
  * ubuntu: overlayfs v18 -- -- fs: limit filesystem stacking depth

  [ Neil Brown ]

  * ubuntu: overlayfs v18 -- -- overlay: overlay filesystem documentation

  [ Tim Gardner ]

  * [Config] CONFIG_SUNRPC_DEBUG=y
    - LP: #1127319
 -- Andy Whitcroft <email address hidden> Fri, 28 Jun 2013 10:26:52 +0100

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-raring
Bryan Quigley (bryanquigley) wrote :

It works. Tested on both quantal and raring (just tested enabling, and then restarting nfs-kernel-server).
Thanks!

tags: added: verification-done-quantal verification-done-raring
removed: verification-needed-quantal verification-needed-raring
Launchpad Janitor (janitor) wrote :
Download full text (11.1 KiB)

This bug was fixed in the package linux - 3.5.0-37.58

---------------
linux (3.5.0-37.58) quantal; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #1199149

  [ Brad Figg ]

  * [Config] CONFIG_ATH9K_LEGACY_RATE_CONTROL=y

  [ Tim Gardner ]

  * [Config] CONFIG_SUNRPC_DEBUG=y
    - LP: #1127319

  [ Upstream Kernel Changes ]

  * Revert "serial: 8250_pci: add support for another kind of NetMos
    Technology PCI 9835 Multi-I/O Controller"
    - LP: #1190967
  * Revert "ath9k_hw: Update rx gain initval to improve rx sensitivity"
    - LP: #1197458
  * ata_piix: add PCI IDs for Intel BayTail
    - LP: #1197458
  * libata: make ata_exec_internal_sg honor DMADIR
    - LP: #1197458
  * cfg80211: check wdev->netdev in connection work
    - LP: #1197458
  * xhci-mem: init list heads at the beginning of init
    - LP: #1197458
  * xhci: fix list access before init
    - LP: #1197458
  * xhci - correct comp_mode_recovery_timer on return from hibernate
    - LP: #1197458
  * mac80211: close AP_VLAN interfaces before unregistering all
    - LP: #1197458
  * usb: dwc3: gadget: free trb pool only from epnum 2
    - LP: #1197458
  * USB: revert periodic scheduling bugfix
    - LP: #1197458
  * USB: serial: fix Treo/Kyocera interrrupt-in urb context
    - LP: #1197458
  * USB: visor: fix initialisation of Treo/Kyocera devices
    - LP: #1197458
  * USB: mos7720: fix DMA to stack
    - LP: #1197458
  * USB: mos7840: fix DMA to stack
    - LP: #1197458
  * USB: ark3116: fix control-message timeout
    - LP: #1197458
  * USB: iuu_phoenix: fix bulk-message timeout
    - LP: #1197458
  * USB: mos7720: fix message timeouts
    - LP: #1197458
  * regulator: palmas: Fix "enable_reg" to point to the correct reg for
    SMPS10
    - LP: #1197458
  * m68k/mac: Fix unexpected interrupt with CONFIG_EARLY_PRINTK
    - LP: #1197458
  * USB: Serial: cypress_M8: Enable FRWD Dongle hidcom device
    - LP: #1197458
  * USB: serial: Add Option GTM681W to qcserial device table.
    - LP: #1197458
  * USB: keyspan: fix bogus array index
    - LP: #1197458
  * USB: mos7720: fix hardware flow control
    - LP: #1197458
  * USB: whiteheat: fix broken port configuration
    - LP: #1197458
  * USB: option: blacklist network interface on Huawei E1820
    - LP: #1197458
  * iommu/amd: Re-enable IOMMU event log interrupt after handling.
    - LP: #1197458
  * iommu/amd: Workaround for ERBT1312
    - LP: #1197458
  * xen/events: Handle VIRQ_TIMER before any other hardirq in event loop.
    - LP: #1197458
  * thinkpad-acpi: recognize latest V-Series using DMI_BIOS_VENDOR
    - LP: #1197458
  * klist: del waiter from klist_remove_waiters before wakeup waitting
    process
    - LP: #1197458
  * ACPI video: ignore BIOS backlight value for HP dm4
    - LP: #1197458
  * ACPI video: ignore BIOS initial backlight value for HP 1000
    - LP: #1197458
  * dmaengine: ste_dma40: fix pm runtime ref counting
    - LP: #1197458
  * ACPI / video: ignore BIOS initial backlight value for HP m4
    - LP: #1197458
  * ACPI / video: ignore BIOS initial backlight value for HP Pavilion g6
    - LP: #1197458
  * ALSA: usb-audio: fix Roland/Cakewalk UM-3G support
    - LP: #1197458
  * drm: fix ...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (15.4 KiB)

This bug was fixed in the package linux - 3.8.0-27.40

---------------
linux (3.8.0-27.40) raring; urgency=low

  [Brad Figg]

  * UBUNTU: [Config] CONFIG_ARM_ERRATA_643719=y

linux (3.8.0-27.39) raring; urgency=low

  [Brad Figg]

  * Release Tracking Bug
    - LP: #1199128

  [ Brad Figg ]

  * [Config] CONFIG_ATH9K_LEGACY_RATE_CONTROL=y

  [ Seth Forshee ]

  * SAUCE: Work around broken ACPI backlight on ThinkPad T430
    - LP: #1183856

  [ Stefan Bader ]

  * (d-i) Add dm-snapshot to md-modules
    - LP: #1191726

  [ Tim Gardner ]

  * [Config] CONFIG_SUNRPC_DEBUG=y
    - LP: #1127319

  [ Upstream Kernel Changes ]

  * Revert "ath9k_hw: Update rx gain initval to improve rx sensitivity"
    - LP: #1193126
  * Revert "serial: 8250_pci: add support for another kind of NetMos
    Technology PCI 9835 Multi-I/O Controller"
    - LP: #1190967
  * mac80211: close AP_VLAN interfaces before unregistering all
    - LP: #1193126
  * ath9k: use correct OTP register offsets for AR9550
    - LP: #1193126
  * regulator: palmas: Fix "enable_reg" to point to the correct reg for
    SMPS10
    - LP: #1193126
  * net: can: kvaser_usb: fix reception on "USBcan Pro" and "USBcan R" type
    hardware.
    - LP: #1193126
  * tg3: Add read dma workaround for 5720
    - LP: #1193126
  * xhci-mem: init list heads at the beginning of init
    - LP: #1193126
  * xhci: fix list access before init
    - LP: #1193126
  * xhci - correct comp_mode_recovery_timer on return from hibernate
    - LP: #1193126
  * xhci: Disable D3cold for buggy TI redrivers.
    - LP: #1193126
  * usb: dwc3: pci: PHY should be deleted later than dwc3 core
    - LP: #1193126
  * usb: dwc3: gadget: free trb pool only from epnum 2
    - LP: #1193126
  * usb: musb: make use_sg flag URB specific
    - LP: #1193126
  * USB: revert periodic scheduling bugfix
    - LP: #1193126
  * USB: serial: fix Treo/Kyocera interrrupt-in urb context
    - LP: #1193126
  * USB: visor: fix initialisation of Treo/Kyocera devices
    - LP: #1193126
  * USB: mos7720: fix DMA to stack
    - LP: #1193126
  * USB: mos7840: fix DMA to stack
    - LP: #1193126
  * USB: ark3116: fix control-message timeout
    - LP: #1193126
  * USB: iuu_phoenix: fix bulk-message timeout
    - LP: #1193126
  * USB: mos7720: fix message timeouts
    - LP: #1193126
  * USB: zte_ev: fix control-message timeouts
    - LP: #1193126
  * USB: Serial: cypress_M8: Enable FRWD Dongle hidcom device
    - LP: #1193126
  * USB: serial: Add Option GTM681W to qcserial device table.
    - LP: #1193126
  * USB: zte_ev: fix broken open
    - LP: #1193126
  * USB: keyspan: fix bogus array index
    - LP: #1193126
  * USB: mos7720: fix hardware flow control
    - LP: #1193126
  * x86/PCI: Map PCI setup data with ioremap() so it can be in highmem
    - LP: #1193126
  * USB: whiteheat: fix broken port configuration
    - LP: #1193126
  * USB: option: blacklist network interface on Huawei E1820
    - LP: #1193126
  * USB: option,zte_ev: move most ZTE CDMA devices to zte_ev
    - LP: #1193126
  * ecryptfs: fixed msync to flush data
    - LP: #1193126
  * dmaengine: ste_dma40: fix pm runtime ref counting
    - LP: #1193126
  * cifs: fix off-by-one bug in build_unc...

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers