regression: D-link DUB-H7 usb hub

Bug #1120472 reported by Animtim on 2013-02-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I'm using an Intuos 3 wacom tablet.
On Raring alpha, it doesn't work at all: no cursor movement.

I tested on both KDE and XFCE desktop, no difference.

If it can help, I know I had the exact same issue on 12.04 only if using a kernel starting from 3.7 (anything above 3.6.x = tablet didn't work)

WORKAROUND: A mainline kernel with this patch: https://lkml.org/lkml/2013/2/18/115

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xserver-xorg-input-wacom 1:0.19.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 9 18:15:18 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: kubuntu
InstallationDate: Installed on 2012-11-18 (83 days ago)
InstallationMedia: Xubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120817.3)
MachineType: CLEVO CO. W240EU/W250EUQ/W270EUQ
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-5-generic root=UUID=f64dd25b-704e-4015-bbeb-e086a5d6cdc9 ro quiet splash vt.handoff=7
SourcePackage: xf86-input-wacom
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/24/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: W240EU/W250EUQ/W270EUQ
dmi.board.vendor: CLEVO CO.
dmi.board.version: V3.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd02/24/2012:svnCLEVOCO.:pnW240EU/W250EUQ/W270EUQ:pvrNotApplicable:rvnCLEVOCO.:rnW240EU/W250EUQ/W270EUQ:rvrV3.0:cvnNoEnclosure:ct10:cvrN/A:
dmi.product.name: W240EU/W250EUQ/W270EUQ
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO CO.
version.compiz: compiz N/A
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.42-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.0-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu2
xserver.bootTime: Sat Feb 9 17:20:50 2013
xserver.configfile: default
xserver.errors: Wacom Intuos3 9x12 stylus: Invalid type 'touch' for this device.
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu2
xserver.video_driver: intel

Animtim (animtim) wrote :
Animtim (animtim) wrote :

More infos:

-Only the the Inutos 3 doesn't work at all as described above.

-With a Graphire 4 , it "works" BUT not with Qt/Krita : it makes no stroke at all when drawing.
(If you think this is a different bug, tell me I'll paste it in a separate report)

Animtim (animtim) wrote :

Ok after a clean full rebuild of krita, it actually works correctly with the graphire4 now.
(still cursor is a bit buggy if both intuos3 and graphire4 are both connected, but not too big issue..)

So the problem remains with the intuos 3 which is not working at all, it looks like it's not properly detected/configured
(see: "xserver.errors: Wacom Intuos3 9x12 stylus: Invalid type 'touch' for this device" , it may be related)

Animtim (animtim) wrote :

More infos:

-Using a 3.6.11 kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/ in Raring, intuos3 works.
-latest 3.8.0.6 kernel update: still doesn't work.

-The graphire4 that works doesn't have any related file in /usr/share/libwacom
(exact model: 056a:0016 Wacom Co., Ltd Graphire 4 6x8 )

while the intuos3 that doesn't work have a corresponding file there
(exact model: 056a:00b2 Wacom Co., Ltd Intuos3 9x12 )

Any ideas what I could try to get it working with latest default kernel?

bugbot (bugbot) on 2013-02-14
tags: added: xubuntu
Animtim (animtim) wrote :

More infos:
I finally found out that this is a bug related to the usb hub I'm using(D-link DUB-H7).
It must be a kernel change upstream in the way it handles power or usb hub, as I can reproduce it with another different distribution, with any kernel starting from 3.7 (while with other kernel up to 3.6 it worked fine).

Timo Aaltonen (tjaalton) on 2013-02-19
summary: - wacom tablet doesn't work
+ regression: D-link DUB-H7 usb hub
affects: xf86-input-wacom (Ubuntu) → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Animtim (animtim) wrote :

Good news, I found the real problem and the fix :)

I finally found out it's not the hub but the laptop usb port/controller, as I plugged directly the intuos3 tablet on it and it still didn't work (I should have tried this from the beginning, shame on me.. )

I've identified my usb controller and the driver used, and found this bug related to same hardware:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1072918

So I've tried a mainline kernel with this patch: https://lkml.org/lkml/2013/2/18/115

Now it works perfectly :D

(note that I'm using Manjaro since a few days, so I can't test anymore on Raring alpha for now, but as I could reproduce the problem exactly I guess the fix will apply here too)

tags: added: cherry-pick
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers