HP envy dv4 - radio kill hotkey does not work

Bug #1118689 reported by James M. Leddy on 2013-02-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Alex Hung
Linux
New
Undecided
Unassigned
Fedora
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

We have a fix that we used on pre-installs. However, the upstream fix was not included, afaict. This bug is so we can track the fix as it makes its way to upstream and the ubuntu kernel.

http://<email address hidden>/msg03568.html

tags: added: blocks-hwcert-enablement

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1118689

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Tim Lander (timlanderj) wrote :

This is still an issue as for kernel 3.10 rc2. It works in Kernel 3.5..

What information can I provide to expedite resolution of this. Do I need to perform any additional steps?

Changed in hwe-next:
assignee: nobody → Alex Hung (alexhung)
importance: Undecided → Medium
status: New → Confirmed
Tim Lander (timlanderj) wrote :

Has this been looked at recently? I would really like to have this feature working on my laptop. I run Ubuntu religiously but this is a pain.

It worked in 12.04 LTS kernel 3.5 but after that it never worked again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
status: New → Confirmed
Alex Hung (alexhung) wrote :

@Tim,

The patch may no longer valid as HP changes some of their BIOS behaviours for wireless hotkey. Do you have any problems other than wireless hotkey?

After kernel 3.6, Linux kernel returns true for _OSI("Windows 2012"), and wireless hotkey triggers different event (not WMI). A different kernel (hp-wireless) is needed but it is not available until kernel 3.14.

Do you want to try mainline kernel later than 3.14 @ http://kernel.ubuntu.com/~kernel-ppa/mainline/?

If it doesn't work, will you please upload acpidump (sudo acpidump > acpi.log) for my references?

Alex Hung (alexhung) wrote :

The original bug is caused by a bug in WMI driver in kernel 3.5; however, with _OSI("Windows 2012") = true, BIOS no longer uses WMI to control wireless, and therefore it can be fixed by another kernel driver (see https://bugs.launchpad.net/ubuntu/+source/linux-lts-saucy/+bug/1303737).

I verified it on HP 242 G2 (LP#1303737) with two kernel versions and it works pretty well.

Joseph Salisbury (jsalisbury) wrote :

bug 1303737 should be fixed by commit 15d75fcebdf78d316a980487eddcac8e4f1574c8, which is in Trusty as of Ubuntu-3.13.0-28.51. This commit is a cherry pick of upstream 54290fa6.

Can you test the 3.13.0-28.51 kernel and confirm if it fixes this bug or not? It can be downloaded from:
https://launchpad.net/~canonical-kernel-team/+archive/ppa/+files/linux-image-3.13.0-28-generic_3.13.0-28.51_amd64.deb

Alex Hung (alexhung) wrote :

I had the same result as Edward Lin on LP#1303737 on HP Envy dv6 - the package in #8 does not work, but linux-image-3.13.0-28-generic_3.13.0-28.51~precise1_amd64.deb @ https://launchpad.net/~canonical-kernel-team/+archive/ppa/+build/6042244 works fine.

Alex Hung (alexhung) wrote :

I found there are more than hp-wireless module are missing in deb from #8 on the same hardware. For example, lan and wlan stop working. The attached is output of lsmod on 3.13.0-28 kernel

Alex Hung (alexhung) wrote :

The attached is output of lsmod on 3.18.0-24 kernel

Alex Hung (alexhung) wrote :

I compiled kernel with UBUNTU: Ubuntu-3.13.0-32.57 (a33d370dc60413a4cfa520d26009831fd601a33b), and installed the following deb packages:

linux-headers-3.13.0-32-generic_3.13.0-32.57_amd64.deb
linux-headers-3.13.0-32_3.13.0-32.56_all.deb
linux-headers-3.13.0-32_3.13.0-32.57_all.deb
linux-image-3.13.0-32-generic_3.13.0-32.57_amd64.deb
linux-image-extra-3.13.0-32-generic_3.13.0-32.57_amd64.deb

The hp-wireless module is loaded correctly. and the F12 wireless button works perfectly.

Changed in hwe-next:
status: Confirmed → Fix Committed
Alex Hung (alexhung) on 2014-08-04
Changed in hwe-next:
status: Fix Committed → Fix Released

This bug was nominated against a series that is no longer supported, ie quantal. The bug task representing the quantal nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Quantal):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers