Ubuntu

Inverted internal mic on Acer AOA150 (ZG5)

Reported by David Henningsson on 2013-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

This bug is for tracking purposes only. Please do not triage.

Related branches

David Henningsson (diwic) wrote :
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)

This patch enables internal mic input on the machine.

Cc: <email address hidden>
BugLink: https://bugs.launchpad.net/bugs/1107477
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index dc75607..de512c5 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -2363,6 +2363,7 @@ static const struct hda_model_fixup alc268_fixup_models[] = {
 };

 static const struct snd_pci_quirk alc268_fixup_tbl[] = {
+ SND_PCI_QUIRK(0x1025, 0x015b, "Acer AOA 150 (ZG5)", ALC268_FIXUP_INV_DMIC),
  /* below is codec SSID since multiple Toshiba laptops have the
   * same PCI SSID 1179:ff00
   */
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Mon, 28 Jan 2013 05:45:47 +0100,
David Henningsson wrote:
>
> This patch enables internal mic input on the machine.
>
> Cc: <email address hidden>
> BugLink: https://bugs.launchpad.net/bugs/1107477
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied.

Takashi

> ---
> sound/pci/hda/patch_realtek.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
> index dc75607..de512c5 100644
> --- a/sound/pci/hda/patch_realtek.c
> +++ b/sound/pci/hda/patch_realtek.c
> @@ -2363,6 +2363,7 @@ static const struct hda_model_fixup alc268_fixup_models[] = {
> };
>
> static const struct snd_pci_quirk alc268_fixup_tbl[] = {
> + SND_PCI_QUIRK(0x1025, 0x015b, "Acer AOA 150 (ZG5)", ALC268_FIXUP_INV_DMIC),
> /* below is codec SSID since multiple Toshiba laptops have the
> * same PCI SSID 1179:ff00
> */
> --
> 1.7.9.5
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-4.8

---------------
linux (3.8.0-4.8) raring; urgency=low

  [ Allen Ibara ]

  * SAUCE: imx6: dts: Add IMX6Q AHCI support

  [ Andy Whitcroft ]

  * rebase to v3.8-rc6
  * updateconfigs following rebase to v3.8-rc6

  [Leann Ogasawara]

  * Release Tracking Bug
    - LP: #1112573

  [ Paolo Pisati ]

  * SAUCE: imx6: enable sata clk if SATA_AHCI_PLATFORM
  * [Config] SERIAL_AMBA_PL011=y (vexpress serial console)
  * [Config] MMC_ARMMMCI=y (vexpress mmc)
  * [Config] FB_ARMCLCD=y (vexpress framebuffer)

  [ Seth Forshee ]

  * [Config] CONFIG_MAC80211_MESSAGE_TRACING=y

  [ Upstream Kernel Changes ]

  * rebase to v3.8-rc6
    - LP: #1107477
 -- Leann Ogasawara <email address hidden> Fri, 01 Feb 2013 07:20:59 -0800

Changed in linux (Ubuntu):
status: In Progress → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers