Ubuntu

Ubuntu 13.04 and 12.04.2: Login screen does not appear after installing OS on SL4545 G7

Reported by Leann Ogasawara on 2013-01-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Quantal
Medium
Leann Ogasawara

Bug Description

== Quantal SRU Justification ==
A regression was discovered while testing HP SL4545 G7 systems with the recent 3.5.0-22.34 Quantal kernel. The regression results in a failure to display a login screen/prompt upon booting. Booting into a previous 3.5.0-17.28 Quantal kernel confirms the issue does not exist. This issue was bisected and it was determined the following commit introduced the regression:

commit 83325d072185899b706de2956170b246585aaec9
Author: Egbert Eich <email address hidden>
Date: Wed Oct 24 18:29:49 2012 +0200

    DRM/Radeon: Fix Load Detection on legacy primary DAC.

== Fix ==
After additional testing, it was then confirmed that the following upstream commit (which has also been CC'd to stable) resolves the issue:

commit 51861d4eebc2ddc25c77084343d060fa79f6e291
Author: Jerome Glisse <email address hidden>
Date: Tue Jan 8 18:41:01 2013 -0500

    radeon/kms: force rn50 chip to always report connected on analog output

== Test Case ==
Boot eg. the 3.5.0-22.34 Quantal kernel on an HP SL4545 G7 system and confirm the login screen/prompt is *not* displayed and ssh'ing into the system one can see the following message in dmesg output:

[ 5.848056] No connectors reported connected with modes
[ 5.848059] [drm] Cannot find any crtc or sizes - going 1024x768

Boot a kernel with commit 51861d4e applied on an HP SL4545 G7 system and confirm the login screen/prompt is displayed and the above message is not seen in dmesg output.

=== Original Bug Description ==

Ubuntu 13.04 and 12.04.02: Login screen does not appear after installing OS on SL4545 G7 server. Quantal works fine...

Expected Result: Login should be successful. But even after blacklisting, we are unable to get the login screen

Note: System ROM - A31 12/06/2012
      iLO Firmware Version - 1.55 Oct 26 2012

Severity: Critical
Request Type: pre release issue
Ubuntu OS Details: 13.04, 12.04.2 (01/17/2013) build.
HP Quix ID: QXCR1001260069
Hardware Configuraiton:
Issue Description:
Install Ubuntu 13.04 Raring Ringtail or 12.04.2 and reboot the system. Login screen does not appear and video shows as disconnected in management integrated remote console. As well no login in prompt on the server console. But we can ssh to the ssh. 12.10 Quantal works fine without any issue.

Workaround: Boot the system with nomodeset kernel parameter and we can see the login screen. This server has radeon driver for graphics.

lspci -s 01:03.0 -xxvv
01:03.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI ES1000 (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 31fb
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 64 (2000ns min), Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Region 1: I/O ports at 2000 [size=256]
 Region 2: Memory at fd9f0000 (32-bit, non-prefetchable) [size=64K]
 [virtual] Expansion ROM at fd900000 [disabled] [size=128K]
 Capabilities: [50] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 Kernel modules: radeon, radeonfb
00: 02 10 5e 51 87 01 90 02 02 00 00 03 10 40 00 00
10: 08 00 00 f0 01 20 00 00 00 00 9f fd 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 3c 10 fb 31
30: 00 00 00 00 50 00 00 00 00 00 00 00 0a 01 08 00

Private bug details available at:
https://bugs.launchpad.net/hp/+bug/1098328

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1103320

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: raring

The patch to resolve this issue in Quantal is already applied and available in the 3.5.0-1.5 (or newer) Raring kernels. Marking the actively developed linux task (ie Raring) Fix Released.

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Quantal):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
description: updated
description: updated
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-23.35). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-23.35

---------------
linux (3.5.0-23.35) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1103932

  [ Upstream Kernel Changes ]

  * Revert "fsnotify: change locking order"
    - LP: #1101666
  * Revert "fsnotify: dont put marks on temporary list when clearing marks
    by group"
    - LP: #1101666
  * Revert "fsnotify: introduce locked versions of fsnotify_add_mark() and
    fsnotify_remove_mark()"
    - LP: #1101666
  * Revert "fsnotify: pass group to fsnotify_destroy_mark()"
    - LP: #1101666
  * Revert "fsnotify: use a mutex instead of a spinlock to protect a groups
    mark list"
    - LP: #1101666
  * Revert "fanotify: add an extra flag to mark_remove_from_mask that
    indicates wheather a mark should be destroyed"
    - LP: #1101666
  * Revert "fsnotify: take groups mark_lock before mark lock"
    - LP: #1101666
  * Revert "fsnotify: use reference counting for groups"
    - LP: #1101666
  * Revert "fsnotify: introduce fsnotify_get_group()"
    - LP: #1101666
  * radeon/kms: force rn50 chip to always report connected on analog output
    - LP: #1103320
 -- Luis Henriques <email address hidden> Thu, 24 Jan 2013 11:06:25 +0000

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

I have just tried the 3.5.0-23.35 kernel package, the same problem occurrs still. I have a HP Pavilion zx5000, with a Radeon Mobility 9200 (AGP). Using the "nomodeset" workaround is not an option, as it prevents X from seeing the correct resolution of the display, and I am stuck with a 1024x768 resolution rather than the correct 1280x800. My workaround is to not use a 3.5.0-23 kernel, and instead lock the system at 3.5.0-22.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers