Please consider applying upstream patches for mtip32xx

Bug #1099913 reported by Kent Baxley on 2013-01-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Dell-poweredge project
High
Kent Baxley
linux (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Tim Gardner
Raring
High
Unassigned
linux-lts-quantal (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Tim Gardner
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

The quantal-lts-backport kernel contains some much-needed updates for the mtip32xx driver, however, Dell has requested that we also apply an additional set of upstream patches, hopefully in time to make the 12.04.2 kernel freeze deadline.

Attached is a zip file with 15 patches, the files have been renamed chronologically, so that they can be applied in order. All apply cleanly, using the ubuntu-precise git repo, lts-backport-quantal branch. All patches are already upstream, in fact, and they are already in the lts-backport-raring branch.

Hopefully this will be straight-forward.

The patches mostly consist of bug fixes, but, there is one that enables a few new devices. Each patch's filename contains description of what it does.

We have a PowerEdge R820 and a T620 to do any verification work.

Kent Baxley (kentb) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1099913

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Kent Baxley (kentb) wrote :

Since we are just asking for some patches to be reviewed, setting to confirmed.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in dell-poweredge:
status: New → Confirmed
assignee: nobody → Kent Baxley (kentb)
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key patch precise quantal
Tim Gardner (timg-tpi) wrote :

The patch requested patch series is essentially everything that has been applied to drivers/block/mtip32xx from v3.5..v3.8-rc3:

git log --reverse --pretty=oneline v3.5..v3.8-rc3 -- drivers/block/mtip32xx

1a131458ddf24d3dddb355ce00f32365557c1eed mtip32xx: Add support for new devices
12a166c919310f4c967d0959b4ed073cced850d7 mtip32xx: Handle NCQ commands during the security locked s
d7c8b945480b3505708c47aad2bca20bd20de2bd mtip32xx: Increase timeout for standby command
b62868e50e65e59556b550f745dac9a9a51ff841 mtip32xx: Proper reporting of write protect status on big-
45422e7431f3afa049d07a99a35de8f8ceea6b3c mtip32xx: Change printk to pr_xxxx
ac64e6572d3906c3874175cf5345a37dc7f983f5 mtip32xx: Remove dead code
97651ea687d3b6a214c32b49f79523db709fba18 mtip32xx: fix user_buffer check in exec_drive_command
4453bc88f0f7be6d84b50b2e1c1ed239c45fb14a mtip32xx:Added appropriate timeout value for secure erase
3208795e612406df04a32b46eb5ea5fccfa51d69 mtip32xx: fix potential crash on SEC_ERASE_UNIT
eda45314922f500f3547d36d317efc05ed823e3e mtip32xx: Fix to make lba address correct in big-endian sy
4b9e884523f63f7bfd6fcbcdfe6f9f9545d98c13 mtip32xx: Fix incorrect mask used for erase mode
7c5d62388e88729775b10a1748f2810e413f1e51 mtip32xx: fix shift larger than type warning
298d80152c895859bd128552db7a5b228e8a23f7 mtip32xx: fix potential NULL pointer dereference in mtip_t
836413e8c78ecbc55aa31f3cb600f8ee1aa355a2 mtip32xx: Fix padding issue

Changed in linux (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux-lts-quantal (Ubuntu Quantal):
status: New → Invalid
Changed in linux-lts-quantal (Ubuntu Raring):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Invalid
Changed in linux-lts-quantal (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) on 2013-01-16
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Kent Baxley (kentb) on 2013-01-30
Changed in dell-poweredge:
status: Confirmed → In Progress
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-24.37). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Kent Baxley (kentb) wrote :

Looks good. Tested on a Dell PowerEdge R820 with one of the mtip32xx PCIeSSD devices. No regressions were noted with these new patches.

Thanks!

tags: added: verification-done-quantal
removed: verification-needed-quantal
Tim Gardner (timg-tpi) wrote :

Released with linux 3.5.0-24.36

Changed in linux-lts-quantal (Ubuntu Precise):
status: In Progress → Fix Released
Tim Gardner (timg-tpi) wrote :

Release with linux 3.5.0-24.36

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in dell-poweredge:
status: In Progress → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers