Ubuntu

Linux kernel 3.5.0-20 won't boot [unable to handle kernel paging request at f91fe4fc in trace_event_raw_init+0xb/0x20]

Reported by pierre-antoine roiron on 2012-12-07
108
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I have Ubuntu 12.10 32bit installed (upgraded in october from 12.04), running smothly on a Lenovo Thinkpad Edge with linux kernel 3.5.0-19. I upgraded to 3.5.0-20 this morning and the laptop don't want to boot anymore (purple screen without Ubuntu logo, than blackscreen frozen, no activity noise from drive). Reverting to 3.5.0-19 is okay.
I tried to launch "ubuntu-bug linux" but it tries to report a bug against 3.5.0-19 (of course...), so I attached dmesg.0 which should be the dmesg from the failed 3.5.0-20 boot try, if my understanding is okay.
How can I collect more infos about this bug, considering it's not booting? Thanks for any help.
---
ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: guitares-roiron 2240 F.... pulseaudio
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=12ad3bf8-910d-4a2f-ab00-c66770dc6c64
InstallationDate: Installed on 2012-04-27 (224 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: LENOVO 0301GXG
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-19-generic root=UUID=270ca18e-c813-4990-8646-73688e84bb47 ro quiet splash
ProcVersionSignature: Ubuntu 3.5.0-19.30-generic 3.5.7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-19-generic N/A
 linux-backports-modules-3.5.0-19-generic N/A
 linux-firmware 1.95
Tags: quantal running-unity
Uname: Linux 3.5.0-19-generic i686
UpgradeStatus: Upgraded to quantal on 2012-10-01 (68 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
WifiSyslog:

dmi.bios.date: 01/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 80ET44WW (1.21 )
dmi.board.name: 0301GXG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr80ET44WW(1.21):bd01/04/2011:svnLENOVO:pn0301GXG:pvrThinkPadEdge:rvnLENOVO:rn0301GXG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0301GXG
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

description: updated

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Private Security → Public

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1087622

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal

I can't get to a terminal to execute this script.

Dave Gilbert (ubuntu-treblig) wrote :

This oops looks like the nasty; I can see a similar oops in bug 1087584 in the WiFiSyslog.txt around the 08:34 mark.

[ 17.782530] Could not create debugfs 'i915_gem_object_create' directory
[ 17.782595] Error: Driver 'i915' is already registered, aborting...
[ 17.848044] BUG: unable to handle kernel paging request at f91fe4fc
[ 17.848051] IP: [<c10df1c8>] register_ftrace_event+0x98/0x280
[ 17.848059] *pdpt = 0000000001973001 *pde = 00000000312d1067 *pte = 0000000000000000
[ 17.848063] Oops: 0002 [#1] SMP
[ 17.848065] Modules linked in: iwlwifi(+) snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device i915(+) mac80211 drm_kms_helper microcode(+) btusb cfg80211 drm psmouse bluetooth snd mei lpc_ich serio_raw nvram soundcore snd_page_alloc i2c_algo_bit mac_hid ext2 video lp parport ums_realtek uas r8169 hid_generic usbhid hid usb_storage
[ 17.848084]
[ 17.848087] Pid: 495, comm: modprobe Not tainted 3.5.0-20-generic #31-Ubuntu LENOVO 0301GXG/0301GXG
[ 17.848091] EIP: 0060:[<c10df1c8>] EFLAGS: 00010246 CPU: 3
[ 17.848093] EIP is at register_ftrace_event+0x98/0x280
[ 17.848094] EAX: f91fe4fc EBX: f9048d94 ECX: 00000444 EDX: 00000000
[ 17.848096] ESI: f9048d9c EDI: c1856938 EBP: f1709ed4 ESP: f1709ec0
[ 17.848097] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 17.848098] CR0: 8005003b CR2: f91fe4fc CR3: 3157c000 CR4: 000007f0
[ 17.848100] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[ 17.848101] DR6: ffff0ff0 DR7: 00000400
[ 17.848103] Process modprobe (pid: 495, ti=f1708000 task=f6c3bf70 task.ti=f1708000)
[ 17.848104] Stack:
[ 17.848105] 00000000 00000003 f9048d80 f90400d9 f1f4fc74 f1709edc c10e836b f1709f08
[ 17.848110] c10e8dea c10d5f76 f1709efc 000001ac c10e9572 f1f4fc0c f904a220 f1f4fd44
[ 17.848114] f9049ff4 f1f4fc74 f1709f40 c10e96a6 f1f4fc74 f1f4fd44 f1f4fcdc f1f4fc74
[ 17.848119] Call Trace:
[ 17.848124] [<c10e836b>] trace_event_raw_init+0xb/0x20
[ 17.848127] [<c10e8dea>] __trace_add_event_call+0x2a/0x3f0
[ 17.848131] [<c10d5f76>] ? ring_buffer_time_stamp+0x6/0x10
[ 17.848134] [<c10e9572>] ? trace_module_notify+0x72/0x260
[ 17.848136] [<c10e96a6>] trace_module_notify+0x1a6/0x260
[ 17.848140] [<c15ce063>] notifier_call_chain+0x43/0x60
[ 17.848145] [<c106b241>] __blocking_notifier_call_chain+0x41/0x80
[ 17.848148] [<c106b29f>] blocking_notifier_call_chain+0x1f/0x30
[ 17.848152] [<c10a2b58>] sys_init_module+0x58/0x210
[ 17.848157] [<c114f3ed>] ? sys_write+0x3d/0x70
[ 17.848161] [<c15d16df>] sysenter_do_call+0x12/0x28
[ 17.848162] Code: 1e 3b 4a 10 75 13 e9 d0 00 00 00 39 4a 10 90 8d 74 26 00 0f 84 c2 00 00 00 8b 12 85 d2 75 ec 8b 47 04 89 77 04 89 7b 08 89 43 0c <89> 30 8b 4b 14 8b 39 85 ff 0f 84 51 01 00 00 8b 71 04 85 f6 0f
[ 17.848191] EIP: [<c10df1c8>] register_ftrace_event+0x98/0x280 SS:ESP 0068:f1709ec0
[ 17.848194] CR2: 00000000f91fe4fc
[ 17.848197] ---[ end trace f094a54d170c8986 ]---

summary: - Linux kernel 3.5.0-20 won't boot
+ Linux kernel 3.5.0-20 won't boot [unable to handle kernel paging request
+ at f91fe4fc in trace_event_raw_init+0xb/0x20]

apport information

tags: added: apport-collected running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I added the wanted infos using the command
# apport-collect 1087622

I hope it will help.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Aisano (info-ais-sanmarino) wrote :

Behaviour here is a little bit different: 3.5.0-20 seems to boot and does display the log-on screen. However, the Ubuntu "drums" do not sound, and though the mouse pointer moves there is no reaction whatsoever on pressing a keyboard key or clicking a mouse button. I need to switch off the computer.
Going back to 3.5.0-19 worked on second try.
Could it be that something is hanging up when trying to play the drums sound? It's the first thing that does not work as usual.

I compared my dmesg logs from a failed start and a successful 3.5.0-19 start. The first 860 or so lines a pretty much identical (after removing time stamps) but then there are suspicious messages such as
* init: failsafe main process (794) killed by TERM signal
* Could not create debugfs 'i915_reg_rw' directory
* BUG: unable to handle kernel paging request at...
I am attaching the part of the file staring from the differing messages.

I get the same error. I get to the desktop because my laptop is configured to bypass the login screen, however I do not get wifi nor sound. I have got a Fujitsu LifeBook T730.

Kernel log of partly successful boot.

Luis Henriques (henrix) wrote :

We believe we found the root cause and I've uploaded a test kernel that will fix the issue. You can download the test kernel here:

http://people.canonical.com/~henrix/lp1087622/

There are 2 versions, one for amd64 (64bits) and other for i386 (32bits). Please give it a try to see if it solves the problem and, if possible, report back with a dmesg. Remember to install, at least, the linux-image-* and the linux-image-extra-* packages. Thanks.

This version of the module fixed the problem for me.

Scott (scott3091) wrote :

The new kernel didn't resolve my issue. I'm running Linux Mint 14 (64-bit), and I haven't been able to boot since 3.5.0-17. I see a bunch of USB devices being recognized and then the system doesn't go any further. I'll troubleshoot later this afternoon to confirm whether it's really the same issue. I have a Lenovo Z580 notebook.

Luis Henriques (henrix) wrote :

Scott, you're definitely seeing a different issue: this bug has been introduced in kernel 3.5.0-20.31. Please open another bug report. You can do this very easily from the command line, by running: 'ubuntu-bug linux'.

Aisano (info-ais-sanmarino) wrote :

I tried to install the new kernel but software-center's progress bar stopped at about 95% and remained there for about 15 minutes, after which I closed it. It had not frozen, it reacted to closing and displayed the rotating progress arrows.

Today 3.5.0-20 effectively booted; I started the system and when I came back after dinner (~30 min) I was able to log on. I found that sound did not work but could run programs and download the proposed kernel (which did not complete installation).

When I shut down the system (to see if I still had a bootable state) I got the shut-down screen (blinking dots) for several minutes; I hit ESC and saw that the last message was "saving system clock to hardware clockhutting...". Probably a message written on top of another. As nothing seemed to change I switched off the computer and booted 3.5.0-19.

I tried to install the test kernel (i386) using the software center :
- headers installed smoothly
- image did crash the laptop : black screen with lots comments, hex numbers, and others things I don't understand. I had to hard reboot to 3.5.0-19.
I attached the dmesg file, hoping it can help.

Luis Henriques (henrix) wrote :

The easiest way to install these test kernels is to manually download all the *.deb files into a directory. Then, in a terminal, just execute:

 $ cd <DIR-WITH-DEB-FILES>
 $ sudo dpkg -i *.deb

Download full text (4.0 KiB)

I tried to install them using dpkg instead of the software center. The system did not crash but the result's not really better :

guitares-roiron@guitares:~/Bureau$ sudo dpkg -i *.deb
(Lecture de la base de données... 269877 fichiers et répertoires déjà installés.)
Préparation du remplacement de linux-headers-3.5.0-20 3.5.0-20.31+lp1087622v1 (en utilisant linux-headers-3.5.0-20_3.5.0-20.31+lp1087622v1_all.deb) ...
Dépaquetage de la mise à jour de linux-headers-3.5.0-20 ...
Préparation du remplacement de linux-headers-3.5.0-20-generic 3.5.0-20.31+lp1087622v1 (en utilisant linux-headers-3.5.0-20-generic_3.5.0-20.31+lp1087622v1_i386.deb) ...
Dépaquetage de la mise à jour de linux-headers-3.5.0-20-generic ...
Préparation du remplacement de linux-image-3.5.0-20-generic 3.5.0-20.31 (en utilisant linux-image-3.5.0-20-generic_3.5.0-20.31+lp1087622v1_i386.deb) ...
Done.
Dépaquetage de la mise à jour de linux-image-3.5.0-20-generic ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.5.0-20-generic /boot/vmlinuz-3.5.0-20-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.5.0-20-generic /boot/vmlinuz-3.5.0-20-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.5.0-20-generic...
P: Writing config for /boot/vmlinuz-3.5.0-19-generic...
P: Writing config for /boot/vmlinuz-3.5.0-18-generic...
P: Writing config for /boot/vmlinuz-3.5.0-16-generic...
P: Writing config for /boot/vmlinuz-3.2.0-32-generic-pae...
Killed

5 minutes later, seeing that nothing was going to happen, I send a Ctrl+C, and here's what the process returned :

^CFailed to process /etc/kernel/postrm.d at /var/lib/dpkg/info/linux-image-3.5.0-20-generic.postrm line 328.
dpkg : avertissement : le sous-processus ancien script post-removal a retourné une erreur de sortie d'état 255
dpkg: trying script from the new package instead ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.5.0-20-generic /boot/vmlinuz-3.5.0-20-generic
run-parts: executing /etc/kernel/postrm.d/zz-extlinux 3.5.0-20-generic /boot/vmlinuz-3.5.0-20-generic
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.5.0-20-generic...
P: Writing config for /boot/vmlinuz-3.5.0-19-generic...
P: Writing config for /boot/vmlinuz-3.5.0-18-generic...
P: Writing config for /boot/vmlinuz-3.5.0-16-generic...
P: Writing config for /boot/vmlinuz-3.2.0-32-generic-pae...

Then it was stuck again. sending Ctrl-C returned the following :

^CFailed to process /etc/kernel/postrm.d at /var/lib/dpkg/tmp.ci/postrm line 328.
dpkg: erreur de traitement de linux-image-3.5.0-20-generic_3.5.0-20.31+lp1087622v1_i386.deb (--install) :
 le sous-processus nouveau script post-removal a retourné une erreur de sortie d'état 255
/usr/bin/os-prober: 112: /usr/bin/os-prober: cannot create /tmp/os-prober.RfwQJG/mounted-map: Directory nonexistent
/usr/bin/os-prober: 113: /usr/bin/os-prober: cannot create /tmp/os-prober.RfwQJG/swaps-map: Directory nonexistent
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.5.0-20-generic /boot/vmlinuz-3.5.0-20-generic
run-part...

Read more...

Changed in linux (Ubuntu):
importance: Undecided → High
Luis Henriques (henrix) on 2012-12-12
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

Thanks Luis.

3.5.0-20-generic #31+lp1087622v1 AMD64 works for me.

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-21.32). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-done-quantal
removed: verification-needed-quantal
Aisano (info-ais-sanmarino) wrote :

3.5.0-21 works for me.

3.5.0-21-generic #32-Ubuntu seems working for me too. Had a similar problem before. Now it boots without problem.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (24.2 KiB)

This bug was fixed in the package linux - 3.5.0-21.32

---------------
linux (3.5.0-21.32) quantal-proposed; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1088979
  * SAUCE: i915_hsw: move i915_hsw_enabled symbol to intel_ips
    - LP: #1087622

linux (3.5.0-20.31) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086759

  [ Ben Widawsky ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_WAIT_TIMEOUT
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_CONTEXT_[CREATE,DESTROY]
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: add register read IOCTL
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define i915_execbuffer2_[set,get]_context_id
    - LP: #1085245

  [ Chris Wilson ]

  * SAUCE: i915_hsw: Include #define I915_GEM_PARAM_HAS_SEMAPHORES
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_SECURE_BATCHES
    - LP: #1085245

  [ Daniel Vetter ]

  * SAUCE: i915_hsw: drm/i915: call intel_enable_gtt
    - LP: #1085245
  * SAUCE: i915_hsw: drm: add helper to sort panels to the head of the
    connector list
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link bw helpers
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract drm_dp_max_lane_count helper
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_channel_eq_ok
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract helpers to compute new training values
    from sink request
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_clock_recovery_ok
    - LP: #1085245

  [ Dave Airlie ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_PRIME_VMAP_FLUSH
    - LP: #1085245

  [ Leann Ogasawara ]

  * SAUCE: i915_hsw: Provide an ubuntu/i915 driver for Haswell graphics
    - LP: #1085245
  * SAUCE: i915_hsw: Revert "drm: Make the .mode_fixup() operations mode
    argument a const pointer" for ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Rename ubuntu/i915 driver i915_hsw
    - LP: #1085245
  * SAUCE: i915_hsw: Only support Haswell with ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_WAIT
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link train delay functions from radeon
    - LP: #1085245
  * SAUCE: i915_hsw: drm/dp: Update DPCD defines
    - LP: #1085245
  * SAUCE: i915_hsw: Update intel_ips.h file location
    - LP: #1085245
  * SAUCE: i915_hsw: Provide updated drm_mm.h and drm_mm.c for ubuntu/i915
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Stop using AGP layer for GEN6+
    - LP: #1085245
  * SAUCE: i915_hsw: Add i915_hsw_gpu_*() calls for ubuntu/i915
    - LP: #1085245
  * i915_hsw: [Config] Enable CONFIG_DRM_I915_HSW=m
    - LP: #1085245

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: fix hsw_fdi_link_train "retry" code
    - LP: #1085245
  * SAUCE: drm/i915: reject modes the LPT FDI receiver can't handle
    - LP: #1085245
  * SAUCE: drm/i915: add support for mPHY destination on i...

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers