Random kernel crashes when using Xorg with radeon module

Bug #1085187 reported by Carla Sella on 2012-11-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
High
Unassigned

Bug Description

I downloaded this Raring Ringtail ISO: http://cdimage.ubuntu.com/daily-live/20121129/raring-desktop-amd64.iso.
I created a live non persistent USB key with Unetbootin.
When booting my PC from this live USB key into a live session with the above image and also with Precise 12.10.1 I get a kernel oops, see attached image-1.
If I boot my PC from the same live USB key, but instead of selecting "try Ubuntu" I select "Install Ubuntu" I get a messed up background with red spots and signs, see image-2.
Even with the display all messed up I can carry out the installation, but when I boot my PC I get a red spotted and messed up backgroud, as soon as I login to my session I get a kernel oops again - see image-3.
If I install the proprietary ATI drivers (apt-get install fglrx), and reboot at least I can logon to my session but I get various crashes, so I think that the problem is related the video drivers (I have an ATI radeon HD 6670 video card).
I am attaching a lshw.txt file with my PC's hardware and the output of dmesg, lsusb and lspci.

Carla Sella (carla-sella) wrote :
description: updated
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
description: updated
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: raring

Did this issue just start happening with the daily image from 11/29? Are there earlier images that don't exhibit this bug? Also, I noticed you say this happens with Precise, but mention the 12.10.1 kernel.

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key
Carla Sella (carla-sella) wrote :

Hello Joseph,
I am having the same exact problem with Precise 12.10.1 the one you downloaded from www.ubuntu.com.
When I found that I had the problem with Precise, I downloaded Raring's daily ISO to see if the problem was still there, and so it was.
I have not tried out any other versions up to now, only Precise 12.10.1 and Raring's 29/11/2012 daily.

Carla Sella (carla-sella) wrote :

Joseph, forgive me I am wrong 12.10.1 is Quantal not Preicse, sorry I made a big mess.
I was talking about Ubuntu's last version 12.10.1 Quantal Quetzal.
Sorry.

Carla Sella (carla-sella) wrote :

I tried also Ubunut 12.0.4.1 and I have the same problems.

Carla Sella (carla-sella) wrote :

Other thing to say: this is a new PC and the versions that I tried (12.04.1, 12.10.1 and 13.04) are first installations, so there is no version on which we did not have this issue.

Carla Sella (carla-sella) wrote :

If I boot from a live USB and add the parameter radeon.nomodeset=0 or radeon.nomodeset=1 then there is no kernel oops, but the screen resolution is completly wrong and probably the monitor type is not even detected.

Carla Sella (carla-sella) wrote :

I tried to install kernel 3.7.0-rc7 (not the ones from the Ubuntu mainline builds) just to se what happens, but the problem is still there, I am attaching the logs if it can be of any help.

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

So summarizing all the tests I have done:

- I have tried to install Ubuntu 12.04, 12.10 and 13.04 daily ISO's (29/11/2012 and today's: 2/12/2012) but with all versions I have kernel oops when loggin on to my session and if I try a live USB key and select "try Ubuntu" I get immediate kernel oops;
- I have tried to install kernel 3.7.0-rc7 from kernel.org but the problem is not solved;
- If I remove the ATI radeon HD 6670 video card and use the INTEL HD2500 integrated one I can install Ubuntu and logon to my session without any problem;
- If I install Ubuntu with the Intel video card and then attach the ATI one, I can boot my PC, but as soon as I logon to my session I get kernel oops:

After this I can assume that the problem may be due to the ATI drivers that make the kernel crash.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Summary of the problem:
Random kernel crashes when using Xorg with radeon module

Description:
Kernel crash at ubuntu user logon or "startx".
There are also a lot of red spots and signs on the monitor, see bug on
launchpad.
https://bugs.launchpad.net/bugs/1085187

Keywords: radeon HD 6770, kms, drm, kernel-oops, crash, hw-specific,
<https://launchpad.net/ubuntu/+bugs?field.tag=hw-specific>ATI,

Kernel version: Linux version 3.7.0-rc8-custom+ (root@duex) (gcc version
4.7.2 (Ubuntu/Linaro 4.7.2-12ubuntu2) ) #1 SMP Sat Dec 8 18:00:39 CET 2012

See attached kernel log (crlog1.txt and crlog2.txt) output taken via
kdump mechanism

Environment: Ubuntu Raring Ringtail (development branch) - Release: 13.04

Software: See attached si_ver_linux.txt for the output of ver_linux script

Processor information: See attached si_cpuinfo.txt for /proc/cpuinfo

Module information: See attached si_proc_modules.txt for /proc/modules

Loaded driver and hardware information: See attached si_proc_ioports.txt
for /proc/ioports - See attached si_proc_iomem.txt for /proc/iomem

PCI information: See attached si_lspci.txt for lspci -vvv

SCSI information: See attached si_proc_scsi_scsi.txt for /proc/scsi/scsi

See attached si_ls_proc.txt for the output of "ls /proc"

Workaround:
Problems disappear when one of the following is applied
a) Using fglrx instead of radeon
b) Using "radeon.nomodeset=0" command line
c) Setting Option "NoAccel" "True" in xorg.conf

--
Carla Sella
email:<email address hidden>
https://launchpad.net/~carla-sella
http://qa.ubuntu.com/

summary: - kernel oops during boot of Raring and Precise with live USB and after
- logon
+ Random kernel crashes when using Xorg with radeon module
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Carla Sella (carla-sella) wrote :

As I received no answer from the Maintainer I reported the bug on Bugzilla.kernel.org:
https://bugzilla.kernel.org/show_bug.cgi?id=52071

Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed

Carla Sella, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the release you may boot into with FGLRX from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux 1085187

Also, could you please test the latest upstream kernel available (not the daily folder, but the one all the way at the bottom) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: precise quantal
Changed in linux (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.