USB Hotplug is not working

Bug #1082877 reported by Manfred Meyer on 2012-11-25
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi,
I installed Ubuntu 12.10 on my new Notebook (Asus Zenbook Prime UX31a) and the USB hotplug is not working (USB3.0 ports are used).

When I restart the notebook with the USB devices plugged in, all devices are found by Ubuntu.

I tried some flash devices and a Logitech MX510, with the same behaviour everywhere.

I tried to find some messages in the syslog, but I couldn't find any notification there.

Imho, there is also no relevant option in the EFI setup.

I hope you can help me, thanks a lot!

----
Some additional informations from the question thread:

- With boot from Live USB stick, hotplug works fine
- I'm using proposed relases
- dmesg and 'udevadm monitor -e' does not give any output und plugging in a usb device
- a known issue is an error in the btusb module. Even on blacklisting this module, hotplugging is not avaible

See also for the full thread https://answers.launchpad.net/ubuntu/+source/util-linux/+question/215163

Manfred Meyer (manni-m) on 2012-11-25
description: updated
Manfred Meyer (manni-m) on 2012-11-25
description: updated
Phillip Susi (psusi) wrote :

Please attach /var/log/dmesg

affects: util-linux (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1082877

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Manfred Meyer (manni-m) wrote :

Okay, uploaded the file.

Another observation I did: When I start the program 'darktable', with has camera support included, all usb devices - not only cameras - are detected, but only when they are plugged in when I start the software or when I explecit click on 'search for new devices'.

So my guess, there is maybe just a module no loaded?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc7-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Manfred Meyer (manni-m) wrote :

Hmm, well, I found the problem and also could 'fix' it:

I connected my smartphone (Sony Neo V) to the Notebook to use USB tethering. I don't know what I did, maybe I disconnected the smartphone without deactivating thethering. But this gave me the issue.
I just connected my smartphone again for battery charging, and due to the issue it wasn't found by Ubuntu. But while it was charging, I just played with the thethering options - and suddenly, Ubuntu detected my smartphone. Then I tried to connect other USB device - all devices are working with hotplug now.

So, this was definetly the error. I tried, but I couldn't reproduce the issue.

Anyway, I think it is still a bug. I attached the relevant part of the 'syslog', whereat there are no special informations. There were no messages in dmesg.

Changed in linux (Ubuntu):
status: Incomplete → Opinion
Manfred Meyer (manni-m) wrote :

just an additional information: It was 2 weeks ago when i used usb tethering, which gaves me the error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments