default quantal kernel does not boot my macbook air

Bug #1082059 reported by William on 2012-11-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Quantal
Medium
Chris J Arges
Raring
Medium
Unassigned

Bug Description

SRU Justification:

Impact: Booting i386 kernels on 64-bit efi firmware does not work on quantal.

Fix: Upstream commit 5189c2a7c7769ee9d037d76c1a7b8550ccf3481c can be cherry-picked into quantal. This commit is already present in raring.

Testcase: Properly boot an i386 quantal kernel on a device that has 64-bit EFI firmware.

--

I have been trying to create a small i386 bootimage for mac using grub efi boot on my new macbook air.
With precise it was not possible to use an i386 kernel on a 64bit efi firmware but this has been resolved with eficross.
But after installing quantal with debootstrap on a usb stick with a small vfat image for holding grub-efi i cannot boot the system with kernel 3.5.18. So I started installing the latest mainline kernel from ppa which worked without problems.

After installing about 10 kernels :) i found that it had to do with the changes between kernel 3.6.4 and 3.6.5, so i investigated the changelog file and there is some significant change for efi cross arch.

commit 31fd7858aab67b6c4104cd7323a69f257a170572
Author: Olof Johansson <email address hidden>
Date: Wed Oct 24 10:00:44 2012 -0700

    x86: efi: Turn off efi_enabled after setup on mixed fw/kernel

    commit 5189c2a7c7769ee9d037d76c1a7b8550ccf3481c upstream.

    When 32-bit EFI is used with 64-bit kernel (or vice versa), turn off
    efi_enabled once setup is done. Beyond setup, it is normally used to
    determine if runtime services are available and we will have none.

    This will resolve issues stemming from efivars modprobe panicking on a
    32/64-bit setup, as well as some reboot issues on similar setups.

    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=45991

    Reported-by: Marko Kohtala <email address hidden>
    Reported-by: Maxim Kammerer <email address hidden>
    Signed-off-by: Olof Johansson <email address hidden>
    Acked-by: Maarten Lankhorst <email address hidden>
    Cc: Matthew Garrett <email address hidden>
    Signed-off-by: Matt Fleming <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

I wanted to take that patch and apply it to the quantal kernel but i get an error while patching so there are more changes for efi (duh).

If someone could help me with this patch maybe this can be added to the quantal kernel?

Regards,

William van de Velde

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1082059

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal
William (kc-cobradevil) wrote :

Ok i tried to get some log files but i have no browser on the minimal usb stick. After typing, on another PC, the auth url it bailed out with a python error. So i have no logfiles?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Chris J Arges (arges) wrote :

I have built a test kernel with the proposed patch here backported to quantal.
http://people.canonical.com/~arges/lp1082059/

Changed in linux (Ubuntu):
assignee: nobody → Chris J Arges (christopherarges)
status: Triaged → In Progress
tags: added: bot-stop-nagging
Changed in linux (Ubuntu Quantal):
assignee: nobody → Chris J Arges (christopherarges)
importance: Undecided → Medium
Changed in linux (Ubuntu):
assignee: Chris J Arges (christopherarges) → nobody
importance: Medium → Undecided
Changed in linux (Ubuntu Quantal):
status: New → In Progress
William (kc-cobradevil) wrote :

Hello Chris,

I have tested the kernel and the system boots without problems now.
Thank you for looking into this.

Regards,
William van de Velde

Chris J Arges (arges) on 2012-11-27
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Released
Chris J Arges (arges) on 2012-11-27
description: updated
Chris J Arges (arges) wrote :
Changed in linux (Ubuntu Raring):
importance: Undecided → Medium
Herton R. Krzesinski (herton) wrote :

Commited fix to master-next, with buglink to this bug added, on the 3.5.7.1 stable update.

Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-20.31). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
William (kc-cobradevil) wrote :

After adding the proposed kernel my macbook air boots without issues.

Thank you for this fix.

Luis Henriques (henrix) wrote :

Tagging as verified as per comment #8.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (24.2 KiB)

This bug was fixed in the package linux - 3.5.0-21.32

---------------
linux (3.5.0-21.32) quantal-proposed; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1088979
  * SAUCE: i915_hsw: move i915_hsw_enabled symbol to intel_ips
    - LP: #1087622

linux (3.5.0-20.31) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086759

  [ Ben Widawsky ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_WAIT_TIMEOUT
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_CONTEXT_[CREATE,DESTROY]
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: add register read IOCTL
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define i915_execbuffer2_[set,get]_context_id
    - LP: #1085245

  [ Chris Wilson ]

  * SAUCE: i915_hsw: Include #define I915_GEM_PARAM_HAS_SEMAPHORES
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_SECURE_BATCHES
    - LP: #1085245

  [ Daniel Vetter ]

  * SAUCE: i915_hsw: drm/i915: call intel_enable_gtt
    - LP: #1085245
  * SAUCE: i915_hsw: drm: add helper to sort panels to the head of the
    connector list
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link bw helpers
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract drm_dp_max_lane_count helper
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_channel_eq_ok
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract helpers to compute new training values
    from sink request
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_clock_recovery_ok
    - LP: #1085245

  [ Dave Airlie ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_PRIME_VMAP_FLUSH
    - LP: #1085245

  [ Leann Ogasawara ]

  * SAUCE: i915_hsw: Provide an ubuntu/i915 driver for Haswell graphics
    - LP: #1085245
  * SAUCE: i915_hsw: Revert "drm: Make the .mode_fixup() operations mode
    argument a const pointer" for ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Rename ubuntu/i915 driver i915_hsw
    - LP: #1085245
  * SAUCE: i915_hsw: Only support Haswell with ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_WAIT
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link train delay functions from radeon
    - LP: #1085245
  * SAUCE: i915_hsw: drm/dp: Update DPCD defines
    - LP: #1085245
  * SAUCE: i915_hsw: Update intel_ips.h file location
    - LP: #1085245
  * SAUCE: i915_hsw: Provide updated drm_mm.h and drm_mm.c for ubuntu/i915
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Stop using AGP layer for GEN6+
    - LP: #1085245
  * SAUCE: i915_hsw: Add i915_hsw_gpu_*() calls for ubuntu/i915
    - LP: #1085245
  * i915_hsw: [Config] Enable CONFIG_DRM_I915_HSW=m
    - LP: #1085245

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: fix hsw_fdi_link_train "retry" code
    - LP: #1085245
  * SAUCE: drm/i915: reject modes the LPT FDI receiver can't handle
    - LP: #1085245
  * SAUCE: drm/i915: add support for mPHY destination on i...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers