Missing support for Realtek ALC292

Bug #1081466 reported by David Henningsson on 2012-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson

Bug Description

We need a simple quirk to enable it.

This bug is for tracking purposes. Please do not triage.

Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)

We found a new codec ID 292, and that just a simple quirk would enable
sound output/input on this ALC292 chip.

BugLink: https://bugs.launchpad.net/bugs/1081466
Cc: <email address hidden>
Tested-by: Acelan Kao <email address hidden>
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 4d26852..f1ca742 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -7099,6 +7099,7 @@ static const struct hda_codec_preset snd_hda_preset_realtek[] = {
  { .id = 0x10ec0282, .name = "ALC282", .patch = patch_alc269 },
  { .id = 0x10ec0283, .name = "ALC283", .patch = patch_alc269 },
  { .id = 0x10ec0290, .name = "ALC290", .patch = patch_alc269 },
+ { .id = 0x10ec0292, .name = "ALC292", .patch = patch_alc269 },
  { .id = 0x10ec0861, .rev = 0x100340, .name = "ALC660",
    .patch = patch_alc861 },
  { .id = 0x10ec0660, .name = "ALC660-VD", .patch = patch_alc861vd },
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Wed, 21 Nov 2012 08:57:58 +0100,
David Henningsson wrote:
>
> We found a new codec ID 292, and that just a simple quirk would enable
> sound output/input on this ALC292 chip.
>
> BugLink: https://bugs.launchpad.net/bugs/1081466
> Cc: <email address hidden>
> Tested-by: Acelan Kao <email address hidden>
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied.

Takashi

> ---
> sound/pci/hda/patch_realtek.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
> index 4d26852..f1ca742 100644
> --- a/sound/pci/hda/patch_realtek.c
> +++ b/sound/pci/hda/patch_realtek.c
> @@ -7099,6 +7099,7 @@ static const struct hda_codec_preset snd_hda_preset_realtek[] = {
> { .id = 0x10ec0282, .name = "ALC282", .patch = patch_alc269 },
> { .id = 0x10ec0283, .name = "ALC283", .patch = patch_alc269 },
> { .id = 0x10ec0290, .name = "ALC290", .patch = patch_alc269 },
> + { .id = 0x10ec0292, .name = "ALC292", .patch = patch_alc269 },
> { .id = 0x10ec0861, .rev = 0x100340, .name = "ALC660",
> .patch = patch_alc861 },
> { .id = 0x10ec0660, .name = "ALC660-VD", .patch = patch_alc861vd },
> --
> 1.7.9.5
>

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.7.0-4.12

---------------
linux (3.7.0-4.12) raring; urgency=low

  [ Tim Gardner ]

  * Revert "[Config] Use -j1 for headers_install"
  * Revert "[Config] install-arch-headers needs a valid config"
    Strayed into the weeds in search of the root cause of the periodic
    build failure.
    Fixes powerpc FTBS introduced in -4.11.
  * [Config] hmake -j1
    The kernel makefile appears to have parallel dependency
    problems for the install_headers target. This appears to be root
    cause for a periodic build failure on N-way machines.
 -- Leann Ogasawara <email address hidden> Tue, 27 Nov 2012 12:33:06 -0800

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

Fixed with an upstreams stable release, thus no need to verify.

tags: added: verification-done-oneiric
Luis Henriques (henrix) on 2013-01-07
tags: added: verification-done-quantal
Luis Henriques (henrix) on 2013-01-07
tags: added: verification-done-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers